www.makemkv.com

MakeMKV support forum
It is currently Wed Jul 18, 2018 8:43 am

All times are UTC




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: v1.8.11 not working
PostPosted: Sat Aug 02, 2014 5:34 pm 
Offline

Joined: Sat Aug 02, 2014 5:23 pm
Posts: 4
Hi. I have been using MakeMKV for a year or so for all my bluray rips. Had no problems with versions or with beta keys until now. I have just tried to use older version and got message that key expired and version too old so needed to update. No problem this has happened before and always works. So removed old version in control panel, downloaded 1.8.11 and installed. All appeared to be ok but when try to open program I get message that the application has failed to initialize. Never seen this before and have tried over and over to get it to work but it won't. Can reinstall earlier version (1.8.9) however with no problems. Any suggestions greatly received. Thanks.

edit: reverted to 1.8.9 with new key and it is working, but annoying that I cannot update to new version


Top
 Profile  
Reply with quote  
 Post subject: Re: v1.8.11 not working
PostPosted: Sun Aug 03, 2014 1:14 am 
Offline

Joined: Sun Jul 24, 2011 11:21 pm
Posts: 5196
If you have any version of MakeMKV running when you do the update, key files will not be updated. And there are some instances where part of MakeMKV is still running, but you don't see it. Open the Task Manager and make sure NOTHING says "makemkv" in the Processes tab, the re-try the install. v1.8.11 should ask about uninstalling the old version. Tell it yes, then wait for that to complete before continuing the 1.8.11 install.

_________________
How to aid in finding the answer to your problem: http://www.makemkv.com/faq/item/8


Top
 Profile  
Reply with quote  
 Post subject: Re: v1.8.11 not working
PostPosted: Sun Aug 03, 2014 1:52 pm 
Offline

Joined: Sat Aug 02, 2014 5:23 pm
Posts: 4
Woodstock wrote:
If you have any version of MakeMKV running when you do the update, key files will not be updated. And there are some instances where part of MakeMKV is still running, but you don't see it. Open the Task Manager and make sure NOTHING says "makemkv" in the Processes tab, the re-try the install. v1.8.11 should ask about uninstalling the old version. Tell it yes, then wait for that to complete before continuing the 1.8.11 install.


Thanks for your help Woodstock. I have tried this and I still get the same message when I try and open 1.8.11.
In task manager when the I run 1.8.9 I can see two processes running, when I close the program and uninstall 1.8.9 using the uninstall feature in the programs tab and the check again neither of these files appear and nothing else mentions MakeMKV. The uninstall is virtually instantaneous taking literally 1 second, but states it was successful. I then install 1.8.11, and it all goes OK and says it has installed correctly - all files appear correct under ProgramFiles (x86)\MakeMKV folder. However, when I click on the program exe file I get the message "Application failed to initialize". If I then uninstall 1.8.11 and reinstall 1.8.9 that opens fine. No idea what is going on here but tried it over and over but still does not work. Any more suggestions? Thanks.


Top
 Profile  
Reply with quote  
 Post subject: Re: v1.8.11 not working
PostPosted: Sun Aug 03, 2014 5:56 pm 
Offline

Joined: Sat Aug 02, 2014 5:23 pm
Posts: 4
Update: After a lot of effort I have managed to get it to work. After I got the message that Application would not initialize on the next attempt to open program when UAC came up I decided to disable UAC and reboot, it then seemed to work, so then re-enabled UAC and rebooted and it also now seems to be working. It must be something to do with permissions and have no idea why doing this has solved it. Will see if it continues to work, otherwise will be back! Thanks for help.


Top
 Profile  
Reply with quote  
 Post subject: Re: v1.8.11 not working
PostPosted: Mon Aug 04, 2014 3:14 pm 
Offline

Joined: Sun Jul 24, 2011 11:21 pm
Posts: 5196
MakeMKV does need admin privileges to get hardware access, so it needs to be installed by an admin. After that, updates have to be run by an admin, as well.

However, you SHOULD have gotten a message from Windows saying something like "This program requires administrator privileges to install, Continue?"

_________________
How to aid in finding the answer to your problem: http://www.makemkv.com/faq/item/8


Top
 Profile  
Reply with quote  
 Post subject: Re: v1.8.11 not working
PostPosted: Mon Aug 04, 2014 3:34 pm 
Offline

Joined: Sat Aug 02, 2014 5:23 pm
Posts: 4
Woodstock wrote:
MakeMKV does need admin privileges to get hardware access, so it needs to be installed by an admin. After that, updates have to be run by an admin, as well.

However, you SHOULD have gotten a message from Windows saying something like "This program requires administrator privileges to install, Continue?"


Hi Woodstock. The PC is my HTPC which I built and set up and I am the only one that has admin privileges on it. But even then I was trying to run the program as administrator but it still wasn't working before I tried the disable/enable UAC that I mentioned. After that it seems to be working OK - will try it again tonight when I get home to make sure. Its an odd one but hopefully I wont have any more problems. Thanks for your help.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group