www.makemkv.com

MakeMKV support forum
It is currently Sun Jul 15, 2018 7:10 pm

All times are UTC




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Wed May 02, 2018 2:34 pm 
Offline

Joined: Mon Mar 07, 2016 8:27 pm
Posts: 53
I just installed the latest version 1.12.2 on my Qnap ubuntu VM and even when using the default profile I'm getting the following error when opening a BD:

Code:
Profile parsing error: Invalid token '"-sel:all'
Profile parsing error: Invalid token '-sel:special"'


It seems that '-sel' is no longer supported. The profile should only select eng audio or audio with no language. However in my case English and German audio tracks are selected (the only two trakcs on that BD).

default profile:
Code:
"-sel:all,+sel:(eng|nolang),-sel:core,-sel:havelossless,+sel:mvcvideo,-sel:subtitle*(all),+sel:(forced*(eng)),-sel:special"


Top
 Profile  
Reply with quote  
PostPosted: Thu May 10, 2018 3:47 pm 
Offline

Joined: Mon Mar 07, 2016 8:27 pm
Posts: 53
Over 200 views, but no reply?
Does nobody else have this issue besides me?

Any suggestion what could I do?


Top
 Profile  
Reply with quote  
PostPosted: Thu May 10, 2018 3:56 pm 
Offline

Joined: Mon Jun 06, 2016 8:23 pm
Posts: 165
Just a guess, but judging by the stray " in each fail msg, I'd try removing the double-quotes surrounding the full string & see how that works. Worth a shot.

_________________
Buy MakeMKV - Latest Beta Key - Current Version (changelogs) - Old Versions - Batch Converter


Top
 Profile  
Reply with quote  
PostPosted: Thu May 10, 2018 4:25 pm 
Offline

Joined: Sun Jul 24, 2011 11:21 pm
Posts: 5193
What is the COMPLETE XML container you're editing? In the default profile, the container spans 3 lines. Here is the one I use in my normal profile:

Code:
    <profileSettings
        app_DefaultSelectionString="-sel:all,+sel:(favlang|nolang),-sel:mvcvideo,=100:all,-10:favlang"
    />

_________________
How to aid in finding the answer to your problem: http://www.makemkv.com/faq/item/8


Top
 Profile  
Reply with quote  
PostPosted: Sun May 13, 2018 4:14 pm 
Offline

Joined: Mon Mar 07, 2016 8:27 pm
Posts: 53
d00zah wrote:
Just a guess, but judging by the stray " in each fail msg, I'd try removing the double-quotes surrounding the full string & see how that works. Worth a shot.

Sorry for late reply. Weirdly, that did the trick! Thanks!

Woodstock wrote:
What is the COMPLETE XML container you're editing? In the default profile, the container spans 3 lines. Here is the one I use in my normal profile:

Code:
    <profileSettings
        app_DefaultSelectionString="-sel:all,+sel:(favlang|nolang),-sel:mvcvideo,=100:all,-10:favlang"
    />


I just did it in the advanced settings directly. Where di I find the XML container?


Top
 Profile  
Reply with quote  
PostPosted: Sun May 13, 2018 4:16 pm 
Offline

Joined: Mon Jun 06, 2016 8:23 pm
Posts: 165
Even a stopped clock... :D

_________________
Buy MakeMKV - Latest Beta Key - Current Version (changelogs) - Old Versions - Batch Converter


Top
 Profile  
Reply with quote  
PostPosted: Sun May 13, 2018 4:47 pm 
Offline

Joined: Sun Jul 24, 2011 11:21 pm
Posts: 5193
Any modified XML profiles should be stored in your MakeMKV data directory. And the selection rules in a profile are used unless you override them in the Advanced tab. In a profile, there SHOULD be quotes around the string, but not in the advanced tab.

You can start by copying a "stock" profile, which, in recent versions, are stored in appdata.tar in your MakeMKV program directory. Since you're on Linux, opening a TAR file is simple; you can extract everything into a directory, or just the xml files, if you want.

MakeMKV ships with four profiles:

aac-st.mmcp.xml
default.mmcp.xml
flac.mmcp.xml
wdtv.mmcp.xml

Comments within the files explain much of what is being done. Here is the current "default.mmcp.xml" file contents:

Code:
<?xml version="1.0" encoding="utf-8"?>
<profile>
    <!-- profile name - Default -->
    <name lang="mogz">:5086</name>

    <!-- Common MKV flags -->
    <mkvSettings
        ignoreForcedSubtitlesFlag="true"
        useISO639Type2T="false"
        setFirstAudioTrackAsDefault="true"
        setFirstSubtitleTrackAsDefault="true"
        setFirstForcedSubtitleTrackAsDefault="true"
        insertFirstChapter00IfMissing="true"
    />

    <!-- Settings overridable in preferences -->
    <profileSettings
        app_DefaultSelectionString="-sel:all,+sel:(favlang|nolang|single),-sel:(havemulti|havecore),-sel:mvcvideo,=100:all,-10:favlang"
    />

    <!-- Output formats currently supported by MakeMKV -->
    <outputSettings name="copy" outputFormat="directCopy">
        <description lang="eng">Copy track as is</description>
        <description lang="ger">Track 1:1 kopieren</description>
    </outputSettings>

    <outputSettings name="lpcm" outputFormat="LPCM-raw">
        <description lang="eng">Save as raw LPCM</description>
        <description lang="ger">Als RAW LPCM speichern</description>
    </outputSettings>

    <outputSettings name="wavex" outputFormat="LPCM-wavex">
        <description lang="eng">Save as LPCM in WAV container</description>
        <description lang="ger">Als LPCM im WAV-Container speichern</description>
    </outputSettings>

    <outputSettings name="flac-best" outputFormat="FLAC">
        <description lang="eng">Save as FLAC (best compression)</description>
        <description lang="ger">Als FLAC speichern (höchste Komprimierungsstufe)</description>
        <extraArgs>-compression_level 12</extraArgs>
    </outputSettings>

    <outputSettings name="flac-fast" outputFormat="FLAC">
        <description lang="eng">Save as FLAC (fast compression)</description>
        <extraArgs>-compression_level 5</extraArgs>
    </outputSettings>

    <!-- Default rule - copy as is -->
    <trackSettings input="default">
        <output outputSettingsName="copy"
                defaultSelection="$app_DefaultSelectionString">
        </output>
    </trackSettings>

    <!-- Save LPCM mono or stereo as raw LPCM -->
    <trackSettings input="LPCM-stereo">
        <output outputSettingsName="lpcm"
                defaultSelection="$app_DefaultSelectionString">
        </output>
    </trackSettings>

    <!-- Put multi-channel LPCM into WAVEX container-->
    <trackSettings input="LPCM-multi">
        <output outputSettingsName="wavex"
                defaultSelection="$app_DefaultSelectionString">
        </output>
    </trackSettings>

</profile>


After you change a stock profile, save it under a different name to your MakeMKV data directory, making sure it ends in .xml. It should be read in automatically when you start MakeMKV.

_________________
How to aid in finding the answer to your problem: http://www.makemkv.com/faq/item/8


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group