Generelle Synchronisations-Probleme (Bild vs. Ton)

Everything related to MakeMKV
Post Reply
BlueVelvet
Posts: 4
Joined: Sat Feb 16, 2019 8:10 pm

Generelle Synchronisations-Probleme (Bild vs. Ton)

Post by BlueVelvet » Sat Feb 16, 2019 8:25 pm

Hi,

da ich wahrscheinlich Stunden brauchen würde, um mein Anliegen ins englische zu übersetzen, schreib ich mal in meiner Muttersprache.

Ich habe mit MakeMKV ca. 40 - 50 BD's für meine lokale MediaGallery konvertiert, um dann herauszufinden, dass bei allen (!) Filmen / Serien / Kurzfilmen der Ton grob pro Stunde 1 sekunde vorgeht. Also bei einem 2 Stunden Film ist der Ton am Schluß 2 Sekunden vor dem dazu passenden Bild zu hören.

Komisch macht die Sache eines: Starte ich die Wiedergabe von Anfang an und springe gleich in die letzten 5 Minuten, ist der Ton synchron. Umgekehrt aber, wenn ich den Film habe 2 Stunden laufen lassen und springe dann auf Zeitmarke 0:05:00 (5 Minuten), hab ich auch hier den Versatz. Es kommt also drauf an, wie lange der Film nicht gestoppt wurde. Pausieren ändert nichts, der Versatz bleibt.

Es ist übrigens kein Player-Problem, das Problem habe ich an allen getesteten Geräten in identischem Ausmaß (PS4, XBox One S, MPC, VLC, PS3 über PS Media Server, Wiedergabe am Android-Handy, und und und ...).

Und nochmal: das Problem ist im identischen Ausmaß bei allen (!) bisher kopierten Filmen identisch. Auch wenn ich einen Kurzfilm, der 5 Minuten dauert, kurz vor Ende wieder auf die 1 Minuten-Marke setze, damit er von hier aus weiterläuft, und das oft genug macht, so dass der Film halt nicht ans Ende kommt, ist es nach ca. 25 Minuten gucken und hin-und-her-springen auch soweit, dass man den Versatz hören/sehen kann.

Ich hoffe, ich konnte das korrekt wiedergeben, dass man versteht, was ich meine. Ich hoffe, man kann das irgendwo in den Einstellungen hinterlegen.

Danke schonmal.

Grüße,

Ralph
Google translation wrote:since I would probably need hours to translate my request into English, I write in my native language.

I used MakeMKV to convert about 40 - 50 BD's for my local MediaGallery to find out that for all (!) Movies / series / short films, the sound is roughly 1 second per hour. So for a 2 hour movie, the sound at the end is 2 seconds before the matching picture.

Funny thing is one thing: if I start playing from the beginning and jump straight into the last 5 minutes, the sound is in sync. Conversely, if I let the movie run for 2 hours and then jump to timestamp 0:05:00 (5 minutes), I also have the offset here. So it depends on how long the movie was not stopped. Pausing does not change anything, the offset remains.

By the way, it's not a player issue, the problem is similar on all the tested devices (PS4, Xbox One S, MPC, VLC, PS3 over PS Media Server, Android Play, and and and ...).

And again: the problem is the same extent identical in all (!) Previously copied films. Even if I put a short film that lasts 5 minutes, just before the end of the 1 minute mark, so that it continues to run from here, and often enough, so that the film does not come to an end, it is after approx Watch for 25 minutes and jump back and forth so far that you can hear / see the offset.

I hope I could correctly reflect that one understands what I mean. I hope you can deposit this somewhere in the settings.

Chetwood
Posts: 773
Joined: Mon Aug 30, 2010 9:16 am

Re: Generelle Synchronisations-Probleme (Bild vs. Ton)

Post by Chetwood » Sun Feb 17, 2019 5:36 am

Noch nie ähnliches gehabt und an MakeMKV kann's eigentlich nicht liegen. Was ist MediaGallery? Ich könnte mir schon vorstellen, dass es bei Wiedergabe über Netzwerk zu solchen Problemen kommen kann. Macht's nen Unterschied, wenn du die m2ts eines Films direkt wiedergibst?
MultiMakeMKV: MakeMKV batch processing (Win)
MultiShrink: DVD Shrink batch processing
Offizieller Uebersetzer von DVD Shrink deutsch

Grauhaar
Posts: 228
Joined: Thu Sep 15, 2016 3:46 pm

Re: Generelle Synchronisations-Probleme (Bild vs. Ton)

Post by Grauhaar » Sun Feb 17, 2019 9:35 am

Das liegt zu 100% nicht an den von MakeMKV erstellten Dateien, sonst hätte ja alle das Problem. Daegen spricht ja auch, wenn man gleich zum Ende springt und dort startet, dann passt es. Also sind die Dateien okay.
Leider steht im Post nicht dabei, "wie" die "Player" die Daten beziehen. Als Stream? Über welchen Streamserver? Habe mal nach "MediaGallery" gesucht, aber nichts brauchbares gefunden, oder ist damit nur der Medien Topf ganz allgemein gemeint? Ich tippe mal darauf, weil der Ton nach einiger Zeit out of sync ist, dass die Abspielgeschwindigkeit bzw. Anzeigedauer aus dem MKV Header falsch interpretiert wird, bzw. falsch an die Videobild Anzeigedauer angepasst wird. (für das Bild wird sie in Nanosekunden im MKV Header angegeben, bei 50Hz 20.000.000, bei 23,976Hz 41.708.333). Am besten mal die MKV Datei im VLC direkt ohne Streaming oder anderen Unsinn am PC abspielen um alle Fehlerquellen zu eleminieren.
Ich hatte vor Jahren auch mal einen Hardware MediaPlayer der kam mit den 23,976Hz der Blu-ray nicht ganz klar, die Ausgabe zum TV wurde immer mit 24Hz gemacht, die 0,024Hz wurden unterschlagen, mit dem Ergebnis dass es alle x Sekunden zu einem Ruckler im Bild kam. Mit einem Software Update wurde das Problem dann gelöst.

BlueVelvet
Posts: 4
Joined: Sat Feb 16, 2019 8:10 pm

Re: Generelle Synchronisations-Probleme (Bild vs. Ton)

Post by BlueVelvet » Wed Mar 06, 2019 10:18 pm

Hi,

erstmal Danke für die Antworten (bin leider nicht per Mail informiert worden) und Sorry, dass ich jetzt erst wieder geguckt habe ... hatte das Thema ein wenig zur Seite geschoben.

Zum Begriff MediaGallery: das ist einfach nur ein Begriff für das, was ich aufbauen möchte: ganz simpel eine NAS o.ä., auf der die Filme abgelegt werden, und dann entweder per LAN direktzugriff oder per Streaming abgespielt werden. Also bitte nicht das Wort MediaGallery auf die Goldwaage legen :D

Zum Thema wie wird abgespielt: alles lokal (ich hab auch gestreamt, aber ich hab auf jedem Gerät die Filme auch mal lokal abgelegt zum Abspielen). Film auf der Platte (dort direkt abgelegt), oder auf einem USB-Stick oder einer USB-Festplatte für die PS3 oder die XBox, dort auf die Platte kopiert oder von USB direkt abgespielt, ist alles egal. VLC direkt am PC ohne Streaming und sonstigem Schnickschnack liefert selbes Ergebnis.

Kopier ich die Disc 1:1 auf die Platte, ist kein Versatz da, erstelle ich mit MakeMKV von der PLatte weg das MKV-File, ist der Versatz auch wieder da.

Zum Thema, dass der MKV Header falsch interpretiert wird: ich hab die Filme mittlerweile von drei Kollegen testen lassen, alle Berichten identisches, zwei haben auch mit verschiedensten Playern und Wiedergabevarianten getestet: die von mir auf meinem PC erstellten MKV's desyncen nach einigen Minuten. Und immer auf die selbe Weise (also je länger der Film läuft, egal wie oft man vor oder zurück springt).

Natürlich könnte ich jetzt per MKVToolnix oder ähnlichem die Rate anpassen, dass es nicht mehr desynct, aber das wollte ich vermeiden. Vor allem muss ich ja erstmal den genauen Versatz ausmitteln, und dann hoffen, dass er bei allen Filmen bis auf die letzte Nachkommastelle identisch ist.

Die Frage, die sich mir noch stellt, ist: kann man hier irgendwo ein Log aktivieren, dass jemand mal reingucken kann, was während dem Konvertierungsvorgang schief läuft?

Danke für Eure Mühe.

Grüße,

Ralph

Grauhaar
Posts: 228
Joined: Thu Sep 15, 2016 3:46 pm

Re: Generelle Synchronisations-Probleme (Bild vs. Ton)

Post by Grauhaar » Thu Mar 07, 2019 7:50 am

BlueVelvet wrote:
Wed Mar 06, 2019 10:18 pm
Kopier ich die Disc 1:1 auf die Platte, ist kein Versatz da, erstelle ich mit MakeMKV von der PLatte weg das MKV-File, ist der Versatz auch wieder da.
Das eine ist die MakeMKV Backup Funktion (Abspielen der M2TS Datei, oder wie?), die andere das erstellen einer MKV Datei. Aber nochmal, die MKV Datei kann nicht defekt sein, sonst wäre der Ton, wenn man gleich ans Ende springt, ja auch versetzt, was er ja nicht ist. Im "Digitalen" Bereich wird alles mit Timestamps gemacht, nennt sich PTS (PresentationTimeStamp). Video und Audio haben einen, so wrd alles wieder zusammengefügt. Wäre der PTS falsch (dann hätten ja ALLE mit vom MakeMKV erstellten Dateien ein Problem), dann wäre der Ton auch am Ende "out auf sync".

Aktuell habe ich keinen Plan waran es liegen könnte. Evtl. mal einen ganz anderen Rechner für die Erstellung dafür benutzen, wobei es (eigentlich) nicht daran liegen kann. Aber wer weiß ....

Ich (und vermutlich auch alle anderen) haben solche Probleme noch nie gehabt und ich habe hunderte Blu-rays mi MakeMKV in eine MKV Datei gepackt. Allerdings nutze ich einen Hardware MediaPlayer für das Abspielen, aber auch der arbeitet wie allen anderen mit dem PTS.

Gibt es vielleicht irgendeine gemeinsame Basis wie gleicher Rechner Typ, verwendete Software etc. ???
Die Frage, die sich mir noch stellt, ist: kann man hier irgendwo ein Log aktivieren, dass jemand mal reingucken kann, was während dem Konvertierungsvorgang schief läuft?
Nennt sich Debug Log. Einfach im Forum danach schauen. Vermuitlich wird da aber nichts drin darüber drin stehen, aber Versuch macht klug.

By the way, es wäre besser, Du würdest in Englisch schreiben. Dieses ist ein Internationales Forum und es wäre grauenvoll, wenn hier jeder in seiner Landessprache schreiben würde, zumal es auch die Möglichkeiten auf eine Antwort stark einschränkt.

BlueVelvet
Posts: 4
Joined: Sat Feb 16, 2019 8:10 pm

Re: Generelle Synchronisations-Probleme (Bild vs. Ton)

Post by BlueVelvet » Fri Mar 08, 2019 12:29 am

Thema englisch schreiben, siehe Eingangspost. Entweder ich komm mit deutsch weiter, oder ich lass es ...

Thema "das hatte noch keiner", da will ich jetzt nicht aufdringlich werden, aber da gibts Haufenweise Posts ohne Lösungen, entweder meldet sich auf einen Tipp oder eine Rückfrage der Anfragende einfach nicht mehr oder es gibt keine Rückmeldungen, ob Tipps geholfen haben oder was auch immer. Zwei Beispiele:
viewtopic.php?t=15166
viewtopic.php?style=6&t=4097

Grüße,

Ralph

Chetwood
Posts: 773
Joined: Mon Aug 30, 2010 9:16 am

Re: Generelle Synchronisations-Probleme (Bild vs. Ton)

Post by Chetwood » Fri Mar 08, 2019 5:28 am

BlueVelvet wrote:
Fri Mar 08, 2019 12:29 am
Thema englisch schreiben, siehe Eingangspost. Entweder ich komm mit deutsch weiter, oder ich lass es ...
deepl.com existiert.
MultiMakeMKV: MakeMKV batch processing (Win)
MultiShrink: DVD Shrink batch processing
Offizieller Uebersetzer von DVD Shrink deutsch

BlueVelvet
Posts: 4
Joined: Sat Feb 16, 2019 8:10 pm

Re: Generelle Synchronisations-Probleme (Bild vs. Ton)

Post by BlueVelvet » Wed Mar 27, 2019 12:23 am

OK, in english ... :roll:
since I would probably need hours to translate my request into English, I write in my native language.

I used MakeMKV to convert about 40 - 50 BD's for my local MediaGallery to find out that for all (!) Movies / series / short films, the sound is roughly 1 second per hour. So for a 2 hour movie, the sound at the end is 2 seconds before the matching picture.

Funny thing is one thing: if I start playing from the beginning and jump straight into the last 5 minutes, the sound is in sync. Conversely, if I let the movie run for 2 hours and then jump to timestamp 0:05:00 (5 minutes), I also have the offset here. So it depends on how long the movie was not stopped. Pausing does not change anything, the offset remains.

By the way, it's not a player issue, the problem is similar on all the tested devices (PS4, Xbox One S, MPC, VLC, PS3 over PS Media Server, Android Play, and and and ...).

And again: the problem is the same extent identical in all (!) Previously copied films. Even if I put a short film that lasts 5 minutes, just before the end of the 1 minute mark, so that it continues to run from here, and often enough, so that the film does not come to an end, it is after approx Watch for 25 minutes and jump back and forth so far that you can hear / see the offset.

I hope I could correctly reflect that one understands what I mean. I hope you can deposit this somewhere in the settings.
Chetwood wrote:
Never had anything like this before and it can't really be due to MakeMKV. What is MediaGallery? I could already imagine that it can come with playback over network to such problems. Does it make a difference if you play the m2ts of a movie directly?
Grauhaar wrote:
This is 100% not due to the files created by MakeMKV, otherwise everyone would have the problem. Daegen also speaks, if you jump to the end and start there, then it fits. So the files are okay.
Unfortunately the post doesn't say "how" the "players" get the data. As stream? About which stream server? I searched for "MediaGallery", but found nothing useful, or is it just the media pot in general meant? I guess, because the sound is out of sync after some time, that the playback speed or display time from the MKV header is wrongly interpreted, or incorrectly adapted to the video image display time. (for the picture it is given in nanoseconds in the MKV header, at 50Hz 20,000,000, at 23.976Hz 41,708,333). It is best to play the MKV file in the VLC directly without streaming or other nonsense on the PC to eliminate all sources of error.
Years ago I also had a hardware media player that didn't quite work with the 23.976Hz of the Blu-ray, the output to the TV was always made with 24Hz, the 0.024Hz were embezzled, with the result that every x seconds there was a jerk in the picture. With a software update the problem was solved.
I wrote:
first of all thanks for the answers (unfortunately I wasn't informed by mail) and sorry that I only looked again now ... had moved the topic a little to the side.

About the term MediaGallery: this is just a term for what I want to build: simply a NAS or similar, on which the movies are stored, and then played either via LAN direct access or via streaming. So please don't put the word MediaGallery on the gold scale :D

About the topic how to play: everything local (I also streamed, but I also stored the movies locally on each device for playing). Movie on the disk (stored there directly), or on a USB stick or a USB hard drive for the PS3 or the XBox, copied there on the disk or played directly from USB, everything does not matter. VLC directly on the PC without streaming and other bells and whistles delivers the same result.

If I copy the disc 1:1 onto the disk, there is no offset, if I create the MKV file with MakeMKV away from the PLatte, the offset is also there again.

On the subject that the MKV header is misinterpreted: I have had the movies tested by three colleagues, all reports identical, two have also tested with different players and playback variants: the MKV's I created on my PC desynced after a few minutes. And always in the same way (so the longer the movie runs, no matter how often you jump back and forth).

Of course, I could now adjust the rate via MKVToolnix or similar so that it doesn't desync anymore, but I wanted to avoid that. First of all, I have to determine the exact offset, and then hope that it is identical for all movies except for the last decimal place.

The question I still have to ask myself is: can you activate a log somewhere here that someone can have a look at what goes wrong during the conversion process?
Grauhaar wrote:
If I copy the disc 1:1 onto the disk, there is no offset, if I create the MKV file with MakeMKV away from the PLatte, the offset is also there again.
One is the MakeMKV backup function (playing the M2TS file, or how?), the other is creating an MKV file. But again, the MKV file can't be defective, otherwise the sound, if you jump right to the end, would also be offset, which it is not. In the "digital" area everything is done with timestamps, called PTS (PresentationTimeStamp). Video and audio have one, so everything is put together again. If the PTS were wrong (then ALL files created by the MakeMKV would have a problem), then the sound would also be "out on sync" at the end.

Currently I have no plan waran it could be. Possibly use a completely different computer for the creation, where it (actually) can't be because of it. But who knows ....

I (and probably all others) have never had such problems and I have packed hundreds of Blu-rays with MakeMKV into a MKV file. However, I use a hardware MediaPlayer for playback, but it also works with the PTS like all the others.

Is there any common basis like same computer type, used software etc. ???
The question I still have to ask myself is: can you activate a log somewhere here that someone can take a look at what goes wrong during the conversion process?
It's called Debug Log. Just check the forum for it. Probably there won't be anything in it about it, but try makes wise.

By the way, it would be better if you wrote in English. This is an international forum and it would be horrible if everyone here would write in their own language, especially since it also greatly restricts the possibilities of an answer.
I wrote:
Topic "nobody had that yet", now I don't want to be intrusive, but there are lots of posts without solutions, either a tip or a question of the inquirer simply doesn't answer any more or there is no feedback whether tips have helped or whatever. Two examples:
viewtopic.php?t=15166
viewtopic.php?style=6&t=4097
The problem still exists. Does nobody really have any more ideas?

Translated with www.DeepL.com/Translator

Post Reply