Subtitles

Everything related to MakeMKV
Pecker
Posts: 23
Joined: Mon Aug 08, 2011 9:07 am

Subtitles

Post by Pecker » Mon Aug 08, 2011 9:12 am

I have had great fun over the past couple of months ripping all of my Blu-ray Discs and DVDs using MakeMKV.

However, I've now found that most of the foreign language ones won't display the subtitles. I'm also now led to believe that this is a known problem and has been for some time.

Does anyone know if this is being fixed?

Cheers.

Steve W

crowfax
Posts: 972
Joined: Thu Feb 18, 2010 5:55 am

Re: Subtitles

Post by crowfax » Mon Aug 08, 2011 3:31 pm

Pecker wrote:However, I've now found that most of the foreign language ones won't display the subtitles.
MakeMKV rips subtitles without any problem. The issue is likely your playback device/software.

How are you playing back the files?
Home Theater PC: Assassin HTPC, XBMCbuntu 12.0 (Frodo), Intel i5 3570k 3.4 GHz Ivy Bridge w/ HD 4000, LG BD-ROM
Playback Devices: Mede8er MED600X3D, MyGica EnjoyTV 120, Xtreamer SideWinder 3, Crystal Acoustics MediaMatchBox

Pecker
Posts: 23
Joined: Mon Aug 08, 2011 9:07 am

Re: Subtitles

Post by Pecker » Mon Aug 08, 2011 5:14 pm

WDTV Live media player.

I have one with the official firmware and another with the BRad custom formware - same problem with both.

Steve W

crowfax
Posts: 972
Joined: Thu Feb 18, 2010 5:55 am

Re: Subtitles

Post by crowfax » Mon Aug 08, 2011 9:18 pm

I have the same player. The WD TV Live won't play PGS subtitles from MKV files. You'll have to extract the subtitles and convert them to IDX.
Home Theater PC: Assassin HTPC, XBMCbuntu 12.0 (Frodo), Intel i5 3570k 3.4 GHz Ivy Bridge w/ HD 4000, LG BD-ROM
Playback Devices: Mede8er MED600X3D, MyGica EnjoyTV 120, Xtreamer SideWinder 3, Crystal Acoustics MediaMatchBox

Pecker
Posts: 23
Joined: Mon Aug 08, 2011 9:07 am

Re: Subtitles

Post by Pecker » Wed Aug 10, 2011 10:56 am

crowfax wrote:I have the same player. The WD TV Live won't play PGS subtitles from MKV files. You'll have to extract the subtitles and convert them to IDX.
Okay. Any chance you could tell me how to do that?

Cheers.

Also, is there any chance the WD will be updated to play PGS subs from MKV, or is this not possible?

Steve W

crowfax
Posts: 972
Joined: Thu Feb 18, 2010 5:55 am

Re: Subtitles

Post by crowfax » Wed Aug 10, 2011 3:33 pm

You're in luck. New firmware came out yesterday for the WD TV Live. It now supports PGS subtitles inside MKV files.

http://www.wdc.com/wdproducts/updates/? ... fwdtv_live
Home Theater PC: Assassin HTPC, XBMCbuntu 12.0 (Frodo), Intel i5 3570k 3.4 GHz Ivy Bridge w/ HD 4000, LG BD-ROM
Playback Devices: Mede8er MED600X3D, MyGica EnjoyTV 120, Xtreamer SideWinder 3, Crystal Acoustics MediaMatchBox

Pecker
Posts: 23
Joined: Mon Aug 08, 2011 9:07 am

Re: Subtitles

Post by Pecker » Thu Aug 11, 2011 1:11 pm

I've just tried the new WDTV Live firmware with a grand total of 00.00% success on my films ripped using MakeMKV.

Actually that's not quite true. Previously it usually said 'Unsupported Subtitle Format', or something like that.

Now it shows the subtitles as being there in the subtitle option, but the subs just don't appear. I've tested this on OldBoy, Run Lola Run and the Italian sections of The Godfather Part 2.

Steve W

crowfax
Posts: 972
Joined: Thu Feb 18, 2010 5:55 am

Re: Subtitles

Post by crowfax » Thu Aug 11, 2011 2:54 pm

That's very weird.

What region are you in? I'll order OldBoy and test it.
Home Theater PC: Assassin HTPC, XBMCbuntu 12.0 (Frodo), Intel i5 3570k 3.4 GHz Ivy Bridge w/ HD 4000, LG BD-ROM
Playback Devices: Mede8er MED600X3D, MyGica EnjoyTV 120, Xtreamer SideWinder 3, Crystal Acoustics MediaMatchBox

Pecker
Posts: 23
Joined: Mon Aug 08, 2011 9:07 am

Re: Subtitles

Post by Pecker » Thu Aug 11, 2011 4:15 pm

crowfax wrote:That's very weird.

What region are you in? I'll order OldBoy and test it.
I'm in the UK (Region 2/B).

It's not just OldBoy. Almost all of my foreign language films wouldn't show subs when I first checked, and I gave up with the new firmware after testing those three.

Steve W

Romansh
Posts: 872
Joined: Sat Jan 22, 2011 7:09 pm

Re: Subtitles

Post by Romansh » Thu Aug 11, 2011 11:34 pm

crowfax wrote:You're in luck. New firmware came out yesterday for the WD TV Live. It now supports PGS subtitles inside MKV files.

http://www.wdc.com/wdproducts/updates/? ... fwdtv_live
FWIW, you have to check the full release notes to see the new feature. The firmware version is 1.06.15_V.

This is good news, whether it actually works yet or not - as it suggests WD does intend to support PGS in MKV.

:D :D :D

crowfax
Posts: 972
Joined: Thu Feb 18, 2010 5:55 am

Re: Subtitles

Post by crowfax » Fri Aug 12, 2011 2:55 am

Romansh wrote:This is good news, whether it actually works yet or not - as it suggests WD does intend to support PGS in MKV.
I have it, it does. I've tested many different discs now.
Home Theater PC: Assassin HTPC, XBMCbuntu 12.0 (Frodo), Intel i5 3570k 3.4 GHz Ivy Bridge w/ HD 4000, LG BD-ROM
Playback Devices: Mede8er MED600X3D, MyGica EnjoyTV 120, Xtreamer SideWinder 3, Crystal Acoustics MediaMatchBox

Pecker
Posts: 23
Joined: Mon Aug 08, 2011 9:07 am

Re: Subtitles

Post by Pecker » Thu Aug 18, 2011 11:59 am

crowfax wrote:
Romansh wrote:This is good news, whether it actually works yet or not - as it suggests WD does intend to support PGS in MKV.
I have it, it does. I've tested many different discs now.
Have you tested OldBoy or Run Lola Run yet?

Steve W

crowfax
Posts: 972
Joined: Thu Feb 18, 2010 5:55 am

Re: Subtitles

Post by crowfax » Thu Aug 18, 2011 2:35 pm

Pecker wrote:Have you tested OldBoy or Run Lola Run yet?
Oldboy should be arriving next week.
Home Theater PC: Assassin HTPC, XBMCbuntu 12.0 (Frodo), Intel i5 3570k 3.4 GHz Ivy Bridge w/ HD 4000, LG BD-ROM
Playback Devices: Mede8er MED600X3D, MyGica EnjoyTV 120, Xtreamer SideWinder 3, Crystal Acoustics MediaMatchBox

Pecker
Posts: 23
Joined: Mon Aug 08, 2011 9:07 am

Re: Subtitles

Post by Pecker » Fri Aug 19, 2011 9:35 am

crowfax wrote:
Pecker wrote:Have you tested OldBoy or Run Lola Run yet?
Oldboy should be arriving next week.
It's a superb film.

Steve W

crowfax
Posts: 972
Joined: Thu Feb 18, 2010 5:55 am

Re: Subtitles

Post by crowfax » Sat Aug 20, 2011 5:55 pm

I've run across something interesting. Do me a favor and remux one of your files that isn't playing the subtitles and try it again. Don't change anything, just remux it with MKVmergeGUI:
http://www.bunkus.org/videotools/mkvtoo ... loads.html

Does the remuxed file now display subtitles on the WD TV?
Home Theater PC: Assassin HTPC, XBMCbuntu 12.0 (Frodo), Intel i5 3570k 3.4 GHz Ivy Bridge w/ HD 4000, LG BD-ROM
Playback Devices: Mede8er MED600X3D, MyGica EnjoyTV 120, Xtreamer SideWinder 3, Crystal Acoustics MediaMatchBox

Post Reply