Subtitles

Everything related to MakeMKV
Post Reply
roadzy
Posts: 3
Joined: Tue Jan 22, 2013 12:48 am

Subtitles

Post by roadzy » Wed Jan 23, 2013 11:24 pm

I'm a bit confused and hope someone can explain this better to me. Just got done with my HDDVD collection and I am moving on to my DVDs. On my HDDVD i selected just the english subtitles so in the event there are forced titles, its there. Now I'm doing the same process on my DVDs and every one has the subtitles turned on by default. What am I doing wrong?

bw001
Posts: 76
Joined: Fri Aug 12, 2011 6:33 pm

Re: Subtitles

Post by bw001 » Tue Feb 12, 2013 4:18 pm

What do you mean "turned on by default"? Are you referring to the checkboxes selected in MakeMKV or that your player defaults to display subtitles?

I know with XBMC, I have to turn off subtitles and then set that as the default setting. Otherwise, they alway display.

Chetwood
Posts: 859
Joined: Mon Aug 30, 2010 9:16 am

Re: Subtitles

Post by Chetwood » Wed Feb 13, 2013 6:57 am

Even when both default and forced flag are set to no in the mkv?
MultiMakeMKV: MakeMKV batch processing (Win)
MultiShrink: DVD Shrink batch processing
Offizieller Uebersetzer von DVD Shrink deutsch

fryk.
Posts: 35
Joined: Tue Oct 09, 2012 7:57 am

Re: Subtitles

Post by fryk. » Wed Feb 13, 2013 7:07 am

In MKV every language should have its "default subtitle track".

bw001
Posts: 76
Joined: Fri Aug 12, 2011 6:33 pm

Re: Subtitles

Post by bw001 » Wed Feb 13, 2013 1:51 pm

Chetwood wrote:Even when both default and forced flag are set to no in the mkv?
Default flag on the subtitle track was probably set to Yes, since that appears to be the default when I rip.

Chetwood
Posts: 859
Joined: Mon Aug 30, 2010 9:16 am

Re: Subtitles

Post by Chetwood » Thu Feb 14, 2013 7:18 am

Hasn't been for a while.
MultiMakeMKV: MakeMKV batch processing (Win)
MultiShrink: DVD Shrink batch processing
Offizieller Uebersetzer von DVD Shrink deutsch

Romansh
Posts: 872
Joined: Sat Jan 22, 2011 7:09 pm

Re: Subtitles

Post by Romansh » Thu Feb 14, 2013 1:37 pm

Chetwood wrote:Hasn't been for a while.
It still is, AFAICT. Are you sure you're not disabling it in your conversion profile?

Chetwood
Posts: 859
Joined: Mon Aug 30, 2010 9:16 am

Re: Subtitles

Post by Chetwood » Fri Feb 15, 2013 1:36 pm

My conversion profile looks like this:

ignoreForcedSubtitlesFlag="false"

-sel:all,+sel:(deu|eng|nolang),-sel:(core),-10:deu,-15:forced

This should have no influence on the default flag being set or not. Apparently it does cause using the default profile the first sub is flagged as default.
MultiMakeMKV: MakeMKV batch processing (Win)
MultiShrink: DVD Shrink batch processing
Offizieller Uebersetzer von DVD Shrink deutsch

Romansh
Posts: 872
Joined: Sat Jan 22, 2011 7:09 pm

Re: Subtitles

Post by Romansh » Fri Feb 15, 2013 1:50 pm

Maybe a bug.

Chetwood
Posts: 859
Joined: Mon Aug 30, 2010 9:16 am

Re: Subtitles

Post by Chetwood » Sat Feb 16, 2013 6:30 am

Pretty much the first bug in my favour, ever ;)
fryk. wrote:In MKV every language should have its "default subtitle track".
You're sure about that, is it in the specs? Apparently it's not mandatory for mkvmerge-
MultiMakeMKV: MakeMKV batch processing (Win)
MultiShrink: DVD Shrink batch processing
Offizieller Uebersetzer von DVD Shrink deutsch

fryk.
Posts: 35
Joined: Tue Oct 09, 2012 7:57 am

Re: Subtitles

Post by fryk. » Sun Feb 17, 2013 10:48 pm

FlagDefault
Set if that track (audio, video or subs) SHOULD be active if no language found matches the user preference.
http://matroska.org/technical/specs/index.html
The "default track" flag tells the player that this track should be played unless the user overrides that decision somehow. You usually mark the original audio track with "default track" and leave it off for the rest of them, e.g. for the director's commentary or some translations you don't want (e.g. Lord of the Rings, mark "English" as "default track" but not "German" and "Director's comments (English)").
http://forum.doom9.org/showthread.php?p ... ost1529705

So the flag SHOULD be set, no force.

Post Reply