Naming MKV output

Discussion of advanced MakeMKV functionality, expert mode, conversion profiles
Post Reply
meyoda99
Posts: 1
Joined: Thu Apr 20, 2017 3:22 pm

Naming MKV output

Post by meyoda99 » Thu Apr 20, 2017 3:37 pm

As a new and registered user I cannot find a way to configure MKV so the output name is the same name of the movie/show as detected by MKV. In other words, the default name of the output MKV file is always "title00.mkv" and is not the name of the movie that I wish to convert.

Please advice...

NOTE: If this is not possible in the current version, can a feature be added so users have the ability to set the name of the output file?

Thanks.

Woodstock
Posts: 5368
Joined: Sun Jul 24, 2011 11:21 pm

Re: Naming MKV output

Post by Woodstock » Thu Apr 20, 2017 7:10 pm

Preferences->General, make sure that "Expert mode" is checked. New options will appear on your screen.

When you open a disk, you can now edit what is present for the disk name. This affects the title names displayed. You will also be able to edit the individual title names, which will affect the file name.

And, if you look at the "Name" label "button", it is a "pull-down", where you can edit OTHER information about the title, including the file name.

Play around - there's more to it than I can explain in a short message, and it can do everything you want.
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

MSDowney
Posts: 7
Joined: Mon Jul 03, 2017 6:12 pm

Re: Naming MKV output

Post by MSDowney » Tue Aug 22, 2017 8:08 pm

Woodstock wrote:Preferences->General, make sure that "Expert mode" is checked. New options will appear on your screen.

When you open a disk, you can now edit what is present for the disk name. This affects the title names displayed. You will also be able to edit the individual title names, which will affect the file name.

And, if you look at the "Name" label "button", it is a "pull-down", where you can edit OTHER information about the title, including the file name.

Play around - there's more to it than I can explain in a short message, and it can do everything you want.
Is this only in the Registered (purchased) version? I am looking in the advanced window and all it has is

Default Profile
Default Selection Rule
dtsdecoderdll.dll locaton

There are not other options

Lovely Rita
Posts: 223
Joined: Wed Apr 17, 2013 10:29 pm

Re: Naming MKV output

Post by Lovely Rita » Tue Aug 22, 2017 10:12 pm

You're looking up the wrong tree. :D
Woodstock wrote:Preferences->General, make sure that "Expert Mode" is checked.
Your Preference window may look different since I'm on a Mac. 8)



Image
Registered User :wink:
Buy MakeMKV

indyjoe1977
Posts: 22
Joined: Wed Aug 23, 2017 3:59 pm

Re: Naming MKV output

Post by indyjoe1977 » Tue Sep 12, 2017 4:47 pm

This was helpful for me, too! Thanks! :mrgreen:

elbandito1200
Posts: 1
Joined: Fri Dec 29, 2017 6:16 pm

Re: Naming MKV output

Post by elbandito1200 » Fri Dec 29, 2017 6:25 pm

Gotta "hijack" this thread somehow concerning getting rid of this "_t00"-addition to the ripped filenames.

Often Makemkv ripped the files naming them "title0x" with x variing according to the track being ripped. I found, that you can change that to the name you want if you click the corresponding title in the list and then enter the name in the "Settings"-field after "Name". BUT: Makemkv still adds "_t0x" (x being the tracknumber obviously) to that name. How can I remove that?

Thx for any help!

Greetz

Elbandito1200

Edit: Never mind, I found it in the dropdown menu: filename - change the name there and it's getting ripped as you want it.

Woodstock
Posts: 5368
Joined: Sun Jul 24, 2011 11:21 pm

Re: Naming MKV output

Post by Woodstock » Fri Dec 29, 2017 9:08 pm

That was kind of why I put together the "Changing names with Expert mode enabled" topic in the General section. There are a lot of things hidden until you turn on Expert mode. And Expert mode itself is rather buried. :roll:
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

Post Reply