Profiles don't work anymore since v1.14.0

Discussion of advanced MakeMKV functionality, expert mode, conversion profiles
Post Reply
SantaKlaus666
Posts: 2
Joined: Tue Nov 06, 2018 11:44 pm

Profiles don't work anymore since v1.14.0

Post by SantaKlaus666 » Tue Nov 06, 2018 11:49 pm

Since the current release, all presets/profiles for stream selection/editing don't work anymore. Is this a known bug? Has the syntax/API been changed?

Woodstock
Posts: 5538
Joined: Sun Jul 24, 2011 11:21 pm

Re: Profiles don't work anymore since v1.14.0

Post by Woodstock » Wed Nov 07, 2018 5:56 pm

Where did you store your profiles?

If your CHANGED profiles were kept in your MakeMKV data directory, they should be unchanged and still useful; I'm doing a rip right now with v1.14.0 and my self-created profile.

Any profile stored in the MakeMKV program directory will have been deleted during the install. This has been the case for several years.

The MakeMKV data directory is configured in Preferences->General.
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

mike admin
Posts: 3442
Joined: Wed Nov 26, 2008 2:26 am
Contact:

Re: Profiles don't work anymore since v1.14.0

Post by mike admin » Thu Nov 08, 2018 12:30 pm

I believe you are asking about default selection string. Before 1.14.0 the default selection string could be specified in 3 places:
1) in profile, globally, in profileSettings section
2) in program preferences, overriding (1)
3) in profile, in each track settings, overriding or amending (2)

With 1.14.0 the location (1) is removed. This location was an artifact of early profile implementation, with confusing logic when to apply rules from settings or from profile. All you need to do is to copy your selection rule from profile to settings.

If you have a drastically different selection rules per profiles, you still can override selection rule in track setting section of each profile. You would end up copying value a few times, but I can't imagine this in real life.

SantaKlaus666
Posts: 2
Joined: Tue Nov 06, 2018 11:44 pm

Re: Profiles don't work anymore since v1.14.0

Post by SantaKlaus666 » Fri Nov 09, 2018 7:24 am

Since I was relying on (1), you should think of splitting up profiles and selection rules and also allow different selection rules. Think for example if you frequently rip movies from two different original languages, Let's say English movies and Spanish movies. Since you want to always keep the original language dub (English or Spanish in that cases), but your native language is any other e. g. Japanese, then you'd need two selection rules: one for selection your native language and English and another for your native language and Spanish and you'd choose depending in the movie to rip.

mike admin
Posts: 3442
Joined: Wed Nov 26, 2008 2:26 am
Contact:

Re: Profiles don't work anymore since v1.14.0

Post by mike admin » Fri Nov 09, 2018 8:44 am

But you still can override the selection logic in profile by putting the same rules to track settings. Yes, you will have to duplicate the line 3 or 4 times, but this is one-time effort considering the profile is updated very infrequently...

Meister_Proper
Posts: 55
Joined: Mon Mar 07, 2016 8:27 pm

Re: Profiles don't work anymore since v1.14.0

Post by Meister_Proper » Fri Nov 09, 2018 12:35 pm

I experience the same behavior as OP. I'm using a Docker (jlesage/makemkv) on my Qnap NAS with v1.14.0 at the moment. Before v.1.14.0 everything was as usual.
Woodstock wrote:
Wed Nov 07, 2018 5:56 pm
Where did you store your profiles?

If your CHANGED profiles were kept in your MakeMKV data directory, they should be unchanged and still useful; I'm doing a rip right now with v1.14.0 and my self-created profile.

Any profile stored in the MakeMKV program directory will have been deleted during the install. This has been the case for several years.

The MakeMKV data directory is configured in Preferences->General.
Yes, my custom profile is stored in the data directory. It was also automatically chosen by makemkv as the default profile after updating to 1.14.0.
However, it didnt use the specified settings in the profile. All languages and subtitles/audio tracks were selected.

I needed to change the "Default selection rule" to what is present in my profile.
Image

However, what about the mkv specific settings stored in the profile:

Code: Select all

<mkvSettings 
        ignoreForcedSubtitlesFlag="false"
        useISO639Type2T="false"
        setFirstAudioTrackAsDefault="true"
        setFirstSubtitleTrackAsDefault="true"
        setFirstForcedSubtitleTrackAsDefault="false"
        insertFirstChapter00IfMissing="true"
How can I preserve those settings?
mike admin wrote:
Thu Nov 08, 2018 12:30 pm
I believe you are asking about default selection string. Before 1.14.0 the default selection string could be specified in 3 places:
1) in profile, globally, in profileSettings section
2) in program preferences, overriding (1)
3) in profile, in each track settings, overriding or amending (2)

With 1.14.0 the location (1) is removed. This location was an artifact of early profile implementation, with confusing logic when to apply rules from settings or from profile. All you need to do is to copy your selection rule from profile to settings.

If you have a drastically different selection rules per profiles, you still can override selection rule in track setting section of each profile. You would end up copying value a few times, but I can't imagine this in real life.
So if I understand you correctly you remove the possibility of storing a custom profile under the /data directory?
What do you mean by 3)? As I want to continue using a profile, rather than using the profile preferences.

mike admin
Posts: 3442
Joined: Wed Nov 26, 2008 2:26 am
Contact:

Re: Profiles don't work anymore since v1.14.0

Post by mike admin » Sat Nov 10, 2018 2:00 pm

Meister_Proper wrote:
Fri Nov 09, 2018 12:35 pm
I needed to change the "Default selection rule" to what is present in my profile.
Image
Yes, this is the only change you had to make.
Meister_Proper wrote:
Fri Nov 09, 2018 12:35 pm
However, what about the mkv specific settings stored in the profile:

Code: Select all

<mkvSettings 
        ignoreForcedSubtitlesFlag="false"
        useISO639Type2T="false"
        setFirstAudioTrackAsDefault="true"
        setFirstSubtitleTrackAsDefault="true"
        setFirstForcedSubtitleTrackAsDefault="false"
        insertFirstChapter00IfMissing="true"
How can I preserve those settings?
I do not understand the question. Nothing else in profiles had changed, these settings are still there.

Meister_Proper wrote:
Fri Nov 09, 2018 12:35 pm
So if I understand you correctly you remove the possibility of storing a custom profile under the /data directory?
No
Meister_Proper wrote:
Fri Nov 09, 2018 12:35 pm
What do you mean by 3)? As I want to continue using a profile, rather than using the profile preferences.
I do not understand the question, sorry.

Meister_Proper
Posts: 55
Joined: Mon Mar 07, 2016 8:27 pm

Re: Profiles don't work anymore since v1.14.0

Post by Meister_Proper » Sat Nov 10, 2018 4:18 pm

mike admin wrote:
Sat Nov 10, 2018 2:00 pm
Meister_Proper wrote:
Fri Nov 09, 2018 12:35 pm
However, what about the mkv specific settings stored in the profile:

Code: Select all

<mkvSettings 
        ignoreForcedSubtitlesFlag="false"
        useISO639Type2T="false"
        setFirstAudioTrackAsDefault="true"
        setFirstSubtitleTrackAsDefault="true"
        setFirstForcedSubtitleTrackAsDefault="false"
        insertFirstChapter00IfMissing="true"
How can I preserve those settings?
I do not understand the question. Nothing else in profiles had changed, these settings are still there.
My question was whether these settings are still honored in my case. So you answered my question :)
mike admin wrote:
Sat Nov 10, 2018 2:00 pm
Meister_Proper wrote:
Fri Nov 09, 2018 12:35 pm
So if I understand you correctly you remove the possibility of storing a custom profile under the /data directory?
No
Meister_Proper wrote:
Fri Nov 09, 2018 12:35 pm
What do you mean by 3)? As I want to continue using a profile, rather than using the profile preferences.
I do not understand the question, sorry.
Alright, no problem. What I wanted to ask is the best way to use a profile and/or the best place to put a profile so that I dont need to change any setting within makemkv itself.

mike admin
Posts: 3442
Joined: Wed Nov 26, 2008 2:26 am
Contact:

Re: Profiles don't work anymore since v1.14.0

Post by mike admin » Tue Nov 13, 2018 1:17 pm

Meister_Proper wrote:
Sat Nov 10, 2018 4:18 pm
Alright, no problem. What I wanted to ask is the best way to use a profile and/or the best place to put a profile so that I dont need to change any setting within makemkv itself.
Just create your own profile (you may take any of pre-existing ones from appdata.tar and use as base). Then keep the profile in "MakeMKV data directory" as set in preferences (not installation directory). This way your profile will survive upgrades/downgrades and multiple installs.

Post Reply