UHD Disc not ripping correctly

Please post here for issues related to UHD discs
Post Reply
MovieWatcher
Posts: 6
Joined: Fri Feb 09, 2018 8:05 pm

UHD Disc not ripping correctly

Post by MovieWatcher » Fri Feb 09, 2018 8:11 pm

When I upgraded to the latest version of MakeMKV all movies that I tried ripping are not coming out correctly. Now it does rip the movie but the movie video will flash constantly. Looking at the codec in VLC it looks like at one moment the video is "normal" and the next moment it looks like the HDR signal is engaged. Then the video codec goes back to normal. It does this constantly. This basically makes the video unwatchable. Any ideas on what is going on?

Woodstock
Posts: 6346
Joined: Sun Jul 24, 2011 11:21 pm

Re: UHD Disc not ripping correctly

Post by Woodstock » Fri Feb 09, 2018 8:37 pm

You're probably trying to play High Dynamic Range video with a player that can't convert it to your monitor. There's a topic running already about HDR video and how to play it back.
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

MovieWatcher
Posts: 6
Joined: Fri Feb 09, 2018 8:05 pm

Re: UHD Disc not ripping correctly

Post by MovieWatcher » Fri Feb 09, 2018 10:12 pm

My TV which supports HDR is the one that is flashing. My computer monitor plays it back fine but I was using VLC to see if I could determine the problem. That's when I noticed that the codec information in the file was changing from what I believe is HDR signal to a non-HDR signal. In version 1.10 the video looks fine. Only on 1.12 has this started to happen.

MovieWatcher
Posts: 6
Joined: Fri Feb 09, 2018 8:05 pm

Re: UHD Disc not ripping correctly

Post by MovieWatcher » Fri Feb 09, 2018 11:17 pm

When I mean HDR and non-HDR. The Max luminance, Min luminance, Primary R, Primary G, Primary B, White Point, MaxCLL, and MaxFall will appear and disappear in the files Codec as the movie plays. VLC 4.0 (Nightly Build), is able to handle this just fine, but my HDR TV seems to be flashing as the data appears and disappears. I assume the TV is going back and forth engaging HDR mode. Again this makes it unwatchable. I'm using the Shield to watch movies.

MovieWatcher
Posts: 6
Joined: Fri Feb 09, 2018 8:05 pm

Re: UHD Disc not ripping correctly

Post by MovieWatcher » Fri Feb 09, 2018 11:18 pm

Also the debug file shows everything is fine, no errors when reading the disc.

MovieWatcher
Posts: 6
Joined: Fri Feb 09, 2018 8:05 pm

Re: UHD Disc not ripping correctly

Post by MovieWatcher » Sat Feb 10, 2018 2:49 am

I uninstalled version 1.10.12 and reinstalled 1.10.10. Looks like the same thing is happening in that version too. Maybe the previous discs didn't have HDR. Also I was paying closer attention to the stream and it looks like Stream 0 is the main video and Stream 1 is first audio then the HDR information pops in under Stream 1, then it goes away and the audio takes its place. Then a second later the HDR Stream pops back in again. I checked my Deadpool rip and the HDR information is inside Stream 0 and does not pop in and out. So not sure what is happening.

Woodstock
Posts: 6346
Joined: Sun Jul 24, 2011 11:21 pm

Re: UHD Disc not ripping correctly

Post by Woodstock » Sat Feb 10, 2018 4:35 pm

It's not necessarily the TV - that's why I said "a player"... Are you feeding the file directly to the TV, or playing it back with software, outputting to the TV? It makes a difference, if the playback software is not HDR-compatible.

Of course, I'm just echoing what I read in other topics - I don't have an HDR display to experiment with. Which is why I suggested checking out the topic where the HDR-centric people are discussing this issue. ;)
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

MovieWatcher
Posts: 6
Joined: Fri Feb 09, 2018 8:05 pm

Re: UHD Disc not ripping correctly

Post by MovieWatcher » Sun Feb 11, 2018 4:01 pm

Well after resetting the Shield everything seems to be working again. So it could have been malfunctioning software or hardware. So it IS ripping correctly, but it is weird that the HDR data is popping in and out in the data stream, but the TV or the Shield is now reading it correctly. So thanks Mike for the good work.

Post Reply