4k solo mystery

Please post here for issues related to UHD discs
Post Reply
makememe
Posts: 42
Joined: Sat Jun 07, 2014 10:15 am

4k solo mystery

Post by makememe » Fri May 24, 2019 12:41 am

If this answered somewhere here, I looked quickly. My apologies.

I have the sound cut out at about 36:04. When it does the atmos reminder comes back when the sound returns. The movie goes silent for a few seconds. This copy was purchased from bestbuy.

So I purchased another copy from amazon. the same shi* happens. My jaw hit the floor. It is in the same place in the movie and with the same audio out and then atmos reminder upper right. wtf.

Has anyone else experienced this? I am about to return this for a another, but I have a feeling I am not experiencing one the great coincidences of mkv history.

Thanks.


makememe
Posts: 42
Joined: Sat Jun 07, 2014 10:15 am

Re: 4k solo mystery

Post by makememe » Sun May 26, 2019 10:56 am

Thanks, great response to someone that did not search correctly. I did not focus on atmos, big flop by me. sorry.

The lesson learned, "These movies have no issue when actually playing the physical disc... just the MKV." and also that atmos is closed source...goodygumdrops. it seems to impact players that use ffmpeg.

I am not sure, yet, my options with the shield, but time to find out.

it is still a mystery to me the drop, one drop, is the same spot for both rips but I see others reporting the same symptom different movies. I do not get that, but now I know the problem not the 4k solo print.

I appreciate the help.

SamuriHL
Posts: 860
Joined: Mon Jun 14, 2010 5:32 pm

Re: 4k solo mystery

Post by SamuriHL » Sun May 26, 2019 2:21 pm

I hesitate to post this here but the ATMOS in MKV problem has plagued a lot of us for a while. Incredibles 2 was notorious for issue, but, it's really a problem with ATMOS in MKV in general. What I hesitate posting is that another product has solved this problem once and for all. But this is the MakeMKV forum so I'm not going to advertise it here. Nonetheless, they put in SIGNIFICANT effort, essentially rewriting their handling of MLP completely, in order to solve this problem. Some people's equipment are more sensitive to the problems than others, so you'll see lots of people claim to have no issue which is awesome. But, after a lot of time and effort, the other product's team definitely found issues with how ATMOS is being stored in MKV. I've had to rerip almost all my ATMOS MKV's to solve this problem once and for all. I don't know if Mike intends to look into this issue for MakeMKV or not, but, it's without a doubt a real problem.

mike admin
Posts: 3584
Joined: Wed Nov 26, 2008 2:26 am
Contact:

Re: 4k solo mystery

Post by mike admin » Mon May 27, 2019 10:05 pm

SamuriHL wrote:
Sun May 26, 2019 2:21 pm
I hesitate to post this here but the ATMOS in MKV problem has plagued a lot of us for a while. Incredibles 2 was notorious for issue, but, it's really a problem with ATMOS in MKV in general. What I hesitate posting is that another product has solved this problem once and for all. But this is the MakeMKV forum so I'm not going to advertise it here. Nonetheless, they put in SIGNIFICANT effort, essentially rewriting their handling of MLP completely, in order to solve this problem. Some people's equipment are more sensitive to the problems than others, so you'll see lots of people claim to have no issue which is awesome. But, after a lot of time and effort, the other product's team definitely found issues with how ATMOS is being stored in MKV. I've had to rerip almost all my ATMOS MKV's to solve this problem once and for all. I don't know if Mike intends to look into this issue for MakeMKV or not, but, it's without a doubt a real problem.
Do they just discard atmos metadata or they actually keep it and make it "compatible" with ffmpeg?
How does MakeMKV built-in ffmpeg behave, I mean is it possible to convert such track with MakeMKV (to flac or aac)?

I would appreciate a sample of such "bad" track - ideally, in a form of audio-only MKV with instructions how to reproduce the issue (version of ffmpeg affected).

SamuriHL
Posts: 860
Joined: Mon Jun 14, 2010 5:32 pm

Re: 4k solo mystery

Post by SamuriHL » Mon May 27, 2019 10:13 pm

mike admin wrote:
Mon May 27, 2019 10:05 pm

Do they just discard atmos metadata or they actually keep it and make it "compatible" with ffmpeg?
How does MakeMKV built-in ffmpeg behave, I mean is it possible to convert such track with MakeMKV (to flac or aac)?

I would appreciate a sample of such "bad" track - ideally, in a form of audio-only MKV with instructions how to reproduce the issue (version of ffmpeg affected).
I'm not sure about what they've done, but, since you are asking about it the product in question is CloneBD and here is the relevant release notes:

fix: allow multiple MLP Frames per PES
fix: exception when ordering PIDs in stream map with MLP
...
improved: major rewrite of MLP handling (Dolby TrueHD, Atmos)

Someone should be able to send you an ATMOS track from pretty much any of the Disney titles (the animated ones are the worse in my experience) which should show the issue.

MRX_BD_07
Posts: 4
Joined: Mon Jun 03, 2019 5:27 pm

Re: 4k solo mystery

Post by MRX_BD_07 » Mon Jun 03, 2019 5:48 pm

I don´t really think that this here is an "mkv" issue.
This reminds me of something I´ve read on GitHub....
-> https://github.com/Nevcairiel/LAVFilters/issues/208
There is something very similar addressed... Especially Disney Discs are affected because they exceed this 11,3 Mbit/s "limit" very easily.
Can you check how high the Bitrate goes at 36:04? (or any other position in the movie where this curiosity appears?)

Post Reply