X-Men Apocalypse won't rip

Please post here for issues related to UHD discs
Post Reply
recordplay
Posts: 8
Joined: Thu Oct 25, 2018 4:39 pm

X-Men Apocalypse won't rip

Post by recordplay » Mon May 27, 2019 5:13 pm

So I went to best buy and bought X-Men Apocalypse to watch before the new movie comes out. I opened it up to rip it in Makemkv and and it's taking a long time to recognize the disc. When it finally does I get tons of errors and the disc never completes. So I took the suggestions and cleaned the disc and got the same result. I took the disc back and exchanged because i figured it was a bad disc. Opened the new one and got the same result. So went and exchanged it again and while its a little better, it still does not rip. I get read errors and it rips very slow. I'm using the latest Makemkv and an Asus BW-16DHT. Has anyone had problems with this disc? After 3 exchanges, I don't know whats going on. I'm not having any problems with other discs. Any suggestions and solutions would be greatly appreciated. Thanks

BlueMac77
Posts: 58
Joined: Fri Jul 13, 2018 10:49 pm
Contact:

Re: X-Men Apocalypse won't rip

Post by BlueMac77 » Tue May 28, 2019 8:13 am

@Recordplay. Please post the error messages that are appearing so the other expert members can check and comment. Sometimes it may be a hardware issue. It's also advisable to have 2 different brands of 4K friendly drives. Some movies may not work on a specific drive but works fine in another brand.

Post Reply