Dolby Vision and 1.15.1

Please post here for issues related to UHD discs
shawnc22
Posts: 388
Joined: Tue Jan 21, 2020 7:40 am

Re: Dolby Vision and 1.15.1

Post by shawnc22 » Mon Jul 27, 2020 2:03 am

chrisandy wrote:
Mon Jul 27, 2020 1:35 am
Thanks for providing this - added this .xml to the right folder in Kodi but only getting HDR10 (not DV) playback. Something I'm doing wrong?
shawnc22 wrote:
Sat Jul 25, 2020 8:58 pm
Once yusecope's modified exoplayer apk is released and installed on your Shield, you need to make the following changes:

1) Create a playercorefactory.xml file as shown from the example here: https://kodi.wiki/view/HOW-TO:Use_exter ... on_Android

2) Add this entry to the players block:

Code: Select all

<player name="ExoPlayer" type="ExternalPlayer" audio="false" video="true">
			<filename>com.google.android.exoplayer2.demo</filename>
			<hidexbmc>true</hidexbmc>
			<playcountminimumtime>120</playcountminimumtime>
		</player>
3) Move the file over to the Shield at /Android/data/org.xbmc.kodi/files/.kodi/userdata

4) Restart Kodi on your Shield and then browse to the mkv you're trying to play, hold down the select button and you should now see a "Play Using" option. Select that and then ExoPlayer to start playing.
Are you following step 4 and using the "Play Using" option?

PanBear
Posts: 2
Joined: Sun Jul 26, 2020 10:32 am

Re: Dolby Vision and 1.15.1

Post by PanBear » Mon Jul 27, 2020 2:06 am

For anyone interested have got DV working on mkv rips through emby player/server with the modded exoplayer in earlier posts and just ticking the use external player option in emby settings 😊

cipher
Posts: 52
Joined: Tue Sep 24, 2013 5:16 am

Re: Dolby Vision and 1.15.1

Post by cipher » Mon Jul 27, 2020 2:08 am

djbuddha wrote:
Sun Jul 26, 2020 9:54 pm
PLEX RUNNING DOLBY VISION AND ATMOS VIA KODI USING THE NEW APK FROM THIS THREAD:

It's FAR from perfect, but I made video showing the following with the 2019 Shield
Link to the video is at the very bottom:

- How to do it (after altering the playcorefactory.xml file for Kodi, it's easier than you think)
- How to fix the sync issue if you fall out of sync when the movie starts (in my testing, this quick method maintains sync throughout the playback)
- Proof that DV is triggered and not faked (bottom left corner using a Vertex 2 showing LLDV running vs running a non-LLDV file)
- Proof that Dolby Atmos is running (I hear it, but the receiver shows it as you'll see in the video).

Notes:

- This is super-alpha. You still can't resume
- This is super-awesome, it means it's possible (will post this on the Plex forum on their Dolby Vision thread for the shield).

To make this APK the default player on Kodi, it's in the thread, but here's what I did to my playercorefactory.xml file (after </players>)

</players>
<rules action="prepend">
<rule video="true" player="dvdplayer">
<rule filename=".*mkv.*|.*HEVC.*|.*hevc.*" player="ExoPlayer"/>
</rule>
</rules>
</playercorefactory>

https://www.dropbox.com/s/tpore7e80euwy ... 5.MOV?dl=0
I was going to wait until Plex officially released a supported update, but if i can use one of my plex clients now then I may have to set this up.

Thanks for testing and confirming this works, djbuddha. Also, good idea to post this on the Plex forums, hopefully it will light a fire under the butts of the devs (as a fellow dev, I say that with the upmost respect!).

chrisandy
Posts: 52
Joined: Fri May 29, 2020 6:33 am

Re: Dolby Vision and 1.15.1

Post by chrisandy » Mon Jul 27, 2020 2:19 am

shawnc22 wrote:
Mon Jul 27, 2020 2:03 am
chrisandy wrote:
Mon Jul 27, 2020 1:35 am
Thanks for providing this - added this .xml to the right folder in Kodi but only getting HDR10 (not DV) playback. Something I'm doing wrong?
shawnc22 wrote:
Sat Jul 25, 2020 8:58 pm
Once yusecope's modified exoplayer apk is released and installed on your Shield, you need to make the following changes:

1) Create a playercorefactory.xml file as shown from the example here: https://kodi.wiki/view/HOW-TO:Use_exter ... on_Android

2) Add this entry to the players block:

Code: Select all

<player name="ExoPlayer" type="ExternalPlayer" audio="false" video="true">
			<filename>com.google.android.exoplayer2.demo</filename>
			<hidexbmc>true</hidexbmc>
			<playcountminimumtime>120</playcountminimumtime>
		</player>
3) Move the file over to the Shield at /Android/data/org.xbmc.kodi/files/.kodi/userdata

4) Restart Kodi on your Shield and then browse to the mkv you're trying to play, hold down the select button and you should now see a "Play Using" option. Select that and then ExoPlayer to start playing.
Ah apologies, missed that part. Not seeing 'play using' as an option.. is there something I need to do to get ExoPlayer set up?

shawnc22
Posts: 388
Joined: Tue Jan 21, 2020 7:40 am

Re: Dolby Vision and 1.15.1

Post by shawnc22 » Mon Jul 27, 2020 2:28 am

No, if you’re not seeing it after a restart, then you’ve either put the xml in the wrong place or misspelled the name of the file.

SamuriHL
Posts: 1619
Joined: Mon Jun 14, 2010 5:32 pm

Re: Dolby Vision and 1.15.1

Post by SamuriHL » Mon Jul 27, 2020 2:29 am

chrisandy wrote:
Mon Jul 27, 2020 1:44 am

SHIELD mounted NAS drive - basically sharing a folder on my W10 machine via the network which is mounted as a network drive on the SHIELD.
That works for some of us, doesn't seem to for others. Try copying one locally as a test and see if it plays. Then you can narrow down the issue, but, my guess is it's this.

chrisandy
Posts: 52
Joined: Fri May 29, 2020 6:33 am

Re: Dolby Vision and 1.15.1

Post by chrisandy » Mon Jul 27, 2020 2:33 am

shawnc22 wrote:
Mon Jul 27, 2020 2:28 am
No, if you’re not seeing it after a restart, then you’ve either put the xml in the wrong place or misspelled the name of the file.
Ah got it. And just to confirm, this is the .xml I should try, correct? Without any edits?

https://mega.nz/file/9fZ3gCoa#bUL3DYXfc ... TMD7rccfzk

chrisandy
Posts: 52
Joined: Fri May 29, 2020 6:33 am

Re: Dolby Vision and 1.15.1

Post by chrisandy » Mon Jul 27, 2020 2:37 am

SamuriHL wrote:
Mon Jul 27, 2020 2:29 am
chrisandy wrote:
Mon Jul 27, 2020 1:44 am

SHIELD mounted NAS drive - basically sharing a folder on my W10 machine via the network which is mounted as a network drive on the SHIELD.
That works for some of us, doesn't seem to for others. Try copying one locally as a test and see if it plays. Then you can narrow down the issue, but, my guess is it's this.
Got it. But just to confirm I still need to use 'play using Exoplayer' right?

Donpoku
Posts: 23
Joined: Wed Jul 03, 2019 3:43 pm

Re: Dolby Vision and 1.15.1

Post by Donpoku » Mon Jul 27, 2020 2:52 am

...
Last edited by Donpoku on Mon Jul 27, 2020 4:17 am, edited 1 time in total.

SamuriHL
Posts: 1619
Joined: Mon Jun 14, 2010 5:32 pm

Re: Dolby Vision and 1.15.1

Post by SamuriHL » Mon Jul 27, 2020 2:54 am

chrisandy wrote:
Mon Jul 27, 2020 2:37 am
SamuriHL wrote:
Mon Jul 27, 2020 2:29 am
chrisandy wrote:
Mon Jul 27, 2020 1:44 am

SHIELD mounted NAS drive - basically sharing a folder on my W10 machine via the network which is mounted as a network drive on the SHIELD.
That works for some of us, doesn't seem to for others. Try copying one locally as a test and see if it plays. Then you can narrow down the issue, but, my guess is it's this.
Got it. But just to confirm I still need to use 'play using Exoplayer' right?

Yes, that's where the DV support for MKV is.

djbuddha
Posts: 36
Joined: Sun Jun 07, 2020 10:55 pm

Re: Dolby Vision and 1.15.1

Post by djbuddha » Mon Jul 27, 2020 3:02 am

cipher wrote:
Mon Jul 27, 2020 2:08 am
djbuddha wrote:
Sun Jul 26, 2020 9:54 pm
PLEX RUNNING DOLBY VISION AND ATMOS VIA KODI USING THE NEW APK FROM THIS THREAD:

It's FAR from perfect, but I made video showing the following with the 2019 Shield
Link to the video is at the very bottom:

- How to do it (after altering the playcorefactory.xml file for Kodi, it's easier than you think)
- How to fix the sync issue if you fall out of sync when the movie starts (in my testing, this quick method maintains sync throughout the playback)
- Proof that DV is triggered and not faked (bottom left corner using a Vertex 2 showing LLDV running vs running a non-LLDV file)
- Proof that Dolby Atmos is running (I hear it, but the receiver shows it as you'll see in the video).

Notes:

- This is super-alpha. You still can't resume
- This is super-awesome, it means it's possible (will post this on the Plex forum on their Dolby Vision thread for the shield).

To make this APK the default player on Kodi, it's in the thread, but here's what I did to my playercorefactory.xml file (after </players>)

</players>
<rules action="prepend">
<rule video="true" player="dvdplayer">
<rule filename=".*mkv.*|.*HEVC.*|.*hevc.*" player="ExoPlayer"/>
</rule>
</rules>
</playercorefactory>

https://www.dropbox.com/s/tpore7e80euwy ... 5.MOV?dl=0
I was going to wait until Plex officially released a supported update, but if i can use one of my plex clients now then I may have to set this up.

Thanks for testing and confirming this works, djbuddha. Also, good idea to post this on the Plex forums, hopefully it will light a fire under the butts of the devs (as a fellow dev, I say that with the upmost respect!).
No worries! I mostly copied this post and put it in the feature request section on the Plex forum (there's a thread about adding DV support already going).

Let's hope they can do it, but this is definitely more than serviceable as a temporary means to enjoy the new-found support for DV!

chrisandy
Posts: 52
Joined: Fri May 29, 2020 6:33 am

Re: Dolby Vision and 1.15.1

Post by chrisandy » Mon Jul 27, 2020 3:04 am

SamuriHL wrote:
Mon Jul 27, 2020 2:54 am
chrisandy wrote:
Mon Jul 27, 2020 2:37 am
SamuriHL wrote:
Mon Jul 27, 2020 2:29 am


That works for some of us, doesn't seem to for others. Try copying one locally as a test and see if it plays. Then you can narrow down the issue, but, my guess is it's this.
Got it. But just to confirm I still need to use 'play using Exoplayer' right?

Yes, that's where the DV support for MKV is.
Same situation as earlier - not seeing a 'play using..' icon.

https://mega.nz/file/9fZ3gCoa#bUL3DYXfc ... TMD7rccfzk

I just used that as the .xml. Was there something I was supposed to edit / change / add?

Donpoku
Posts: 23
Joined: Wed Jul 03, 2019 3:43 pm

Re: Dolby Vision and 1.15.1

Post by Donpoku » Mon Jul 27, 2020 3:12 am

...
Last edited by Donpoku on Mon Jul 27, 2020 4:18 am, edited 1 time in total.

shawnc22
Posts: 388
Joined: Tue Jan 21, 2020 7:40 am

Re: Dolby Vision and 1.15.1

Post by shawnc22 » Mon Jul 27, 2020 3:14 am

And where are you putting the file?

SamuriHL
Posts: 1619
Joined: Mon Jun 14, 2010 5:32 pm

Re: Dolby Vision and 1.15.1

Post by SamuriHL » Mon Jul 27, 2020 3:27 am

chrisandy wrote:
SamuriHL wrote:
Mon Jul 27, 2020 2:54 am
chrisandy wrote:
Mon Jul 27, 2020 2:37 am
Got it. But just to confirm I still need to use 'play using Exoplayer' right?

Yes, that's where the DV support for MKV is.
Same situation as earlier - not seeing a 'play using..' icon.

https://mega.nz/file/9fZ3gCoa#bUL3DYXfc ... TMD7rccfzk

I just used that as the .xml. Was there something I was supposed to edit / change / add?
I don't get any play using icon it just opens in exoplayer when I play an mkv in kodi.

Sent from my SM-G975U using Tapatalk


Post Reply