Dolby Vision and 1.15.1

Please post here for issues related to UHD discs
shawnc22
Posts: 563
Joined: Tue Jan 21, 2020 7:40 am

Re: Dolby Vision and 1.15.1

Post by shawnc22 » Wed Jun 17, 2020 3:35 pm

planet_hoarder wrote:
Wed Jun 17, 2020 9:14 am
SamuriHL wrote:
Thu Apr 16, 2020 9:54 pm
For those that are looking to make this work in the easiest way possible:

1) Rip to MKV with MakeMKV
2) eac3to titlename.mkv 2: titlename.thd+ac3
Note: titlename should be replaced with the actual name of the MKV
3) Add the MKV and the thd+ac3 track to TSMuxer
4) Remux to TS

I've done this to a few of them. Currently watching Ready Player One on my SHIELD Pro 2019 in Plex as we speak. This is fantastic.
have you tried if the same process works for a DV movie with FEL?
here is a list: https://forum.blu-ray.com/showthread.php?t=276448
It works the same with FEL titles and the Shield plays them just fine. Now, whether or not the Shield is playing them accurately is a whole different question.

planet_hoarder
Posts: 33
Joined: Tue Mar 17, 2020 10:32 am

Re: Dolby Vision and 1.15.1

Post by planet_hoarder » Wed Jun 17, 2020 4:46 pm

shawnc22 wrote:
Wed Jun 17, 2020 3:35 pm
planet_hoarder wrote:
Wed Jun 17, 2020 9:14 am
SamuriHL wrote:
Thu Apr 16, 2020 9:54 pm
For those that are looking to make this work in the easiest way possible:

1) Rip to MKV with MakeMKV
2) eac3to titlename.mkv 2: titlename.thd+ac3
Note: titlename should be replaced with the actual name of the MKV
3) Add the MKV and the thd+ac3 track to TSMuxer
4) Remux to TS

I've done this to a few of them. Currently watching Ready Player One on my SHIELD Pro 2019 in Plex as we speak. This is fantastic.
have you tried if the same process works for a DV movie with FEL?
here is a list: https://forum.blu-ray.com/showthread.php?t=276448
It works the same with FEL titles and the Shield plays them just fine. Now, whether or not the Shield is playing them accurately is a whole different question.
can you please cut 30 seconds of FEL and MEL each and share it? I'd like to try it myself, since the process doesn't work for me.
also which release of tsMuxer are you using?

box4m
Posts: 66
Joined: Tue Sep 10, 2019 7:23 pm

Re: Dolby Vision and 1.15.1

Post by box4m » Wed Jun 17, 2020 5:52 pm

shawnc22 wrote:
Wed Jun 17, 2020 3:35 pm
planet_hoarder wrote:
Wed Jun 17, 2020 9:14 am
SamuriHL wrote:
Thu Apr 16, 2020 9:54 pm
For those that are looking to make this work in the easiest way possible:

1) Rip to MKV with MakeMKV
2) eac3to titlename.mkv 2: titlename.thd+ac3
Note: titlename should be replaced with the actual name of the MKV
3) Add the MKV and the thd+ac3 track to TSMuxer
4) Remux to TS

I've done this to a few of them. Currently watching Ready Player One on my SHIELD Pro 2019 in Plex as we speak. This is fantastic.
have you tried if the same process works for a DV movie with FEL?
here is a list: https://forum.blu-ray.com/showthread.php?t=276448
It works the same with FEL titles and the Shield plays them just fine. Now, whether or not the Shield is playing them accurately is a whole different question.
with plex? did u try mxplayer?

shawnc22
Posts: 563
Joined: Tue Jan 21, 2020 7:40 am

Re: Dolby Vision and 1.15.1

Post by shawnc22 » Wed Jun 17, 2020 6:32 pm

I don't have a handy FEL title cut up at the moment, but here's a MEL sample:

https://mega.nz/file/YSxhkSLK#fkfy54tYV ... xIOBZLyGR4

If this works on your 2019 Shield, then a FEL title will also. There is no difference in the remux process. The version of tsmuxer people have been using is the one that's labeled 4.06 fix, and it's been extensively linked throughout the two threads. I'm also talking strictly about Plex. I have not done any extensive testing on MXPlayer to be able to say anything conclusively.

mathias19
Posts: 9
Joined: Wed Jun 10, 2020 3:27 pm

Re: Dolby Vision and 1.15.1

Post by mathias19 » Wed Jun 17, 2020 7:37 pm

shawnc22 wrote:
Wed Jun 17, 2020 1:21 am
mathias19 wrote:
Wed Jun 17, 2020 12:44 am
I've done what you suggested and created the MP4 with the base layer, enhanced layer and AC3. However my LG does not play from the attached USB drive. In mediainfo the file shows 2 seperate video streams plus the AC3 audio. One is HDR 10 and the second shows the dolby vision. Is this correct?
Can you post the mediainfo? And by "does not play", do you mean nothing happens at all when you try playing the file, the file can't be seen at all, or either video/audio not working?

The file can be seen but when I select it the coloured circles just rotate round for a couple of minutes then it states "This file cannot be recognised. Returning to list" Other UHD HDR10 files play fine from the USB attached hard drive. Even Plex will not play it on the LG.

Just to clarify this is what I did:

Made decrypted backup using MakeMKV v1.15.1

Found the BDMV/STREAM folders then found the largest m2ts file

Demuxed the 2 HEVC files along AC3 using TsMuxer (04.06 fix)

Renamed the files... bl.hevc, el.hevc and audio.ac3

Put these files in the bin folder of unzipped 'dlb_mp4base-master'

typed cmd in to address bar of the open bin folder

then I run this command: mp4muxer --dv-profile 7 --input-file bl.hevc --input-file el.hevc --input-file audio.ac3 --media-lang eng --output-file outputfile.mp4

it then takes about half an hour and outputfile.mp4 is created and it is the correct size.

This is the mediainfo for the file:

Thanks for your help!

Format : MPEG-4
Format profile : Base Media / Version 2
Codec ID : mp42 (mp42/dby1/isom)
File size : 38.5 GiB
Duration : 2 h 10 min
Overall bit rate : 42.4 Mb/s
Encoded date : UTC 2020-06-16 22:14:54
Tagged date : UTC 2020-06-16 22:14:54

Video #1
ID : 1
Format : HEVC
Format/Info : High Efficiency Video Coding
Format profile : Main 10@L5.1@High
HDR format : SMPTE ST 2086, HDR10 compatible
Codec ID : hev1
Codec ID/Info : High Efficiency Video Coding
Duration : 2 h 10 min
Bit rate : 41.9 Mb/s
Width : 3 840 pixels
Height : 2 160 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 23.976 (24000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:0 (Type 2)
Bit depth : 10 bits
Bits/(Pixel*Frame) : 0.211
Stream size : 38.1 GiB (99%)
Default : Yes
Alternate group : 1
Encoded date : UTC 2020-06-16 22:14:54
Tagged date : UTC 2020-06-16 22:14:54
Color range : Limited
Color primaries : BT.2020
Transfer characteristics : PQ
Matrix coefficients : BT.2020 non-constant
Mastering display color primaries : Display P3
Mastering display luminance : min: 0.0050 cd/m2, max: 4000 cd/m2
Maximum Content Light Level : 2782 cd/m2
Maximum Frame-Average Light Level : 105 cd/m2
Codec configuration box : hvcC

Video #2
ID : 2
Format : HEVC
Format/Info : High Efficiency Video Coding
Format profile : Main 10@L5.1@High
HDR format : Dolby Vision, Version 1.0, dvhe.07.06, EL+RPU, Blu-ray compatible / SMPTE ST 2086, HDR10 compatible
Codec ID : hev1
Codec ID/Info : High Efficiency Video Coding
Duration : 2 h 10 min
Bit rate : 66.9 kb/s
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 23.976 (24000/1001) FPS
Color space : YUV
Chroma subsampling : 4:2:0 (Type 2)
Bit depth : 10 bits
Bits/(Pixel*Frame) : 0.001
Stream size : 62.2 MiB (0%)
Default : No
Alternate group : 1
Encoded date : UTC 2020-06-16 22:14:54
Tagged date : UTC 2020-06-16 22:14:54
Color range : Limited
Color primaries : BT.2020
Transfer characteristics : PQ
Matrix coefficients : BT.2020 non-constant
Mastering display color primaries : Display P3
Mastering display luminance : min: 0.0050 cd/m2, max: 4000 cd/m2
Codec configuration box : hvcC+dvcC

Audio
ID : 3
Format : AC-3
Format/Info : Audio Coding 3
Commercial name : Dolby Digital
Codec ID : ac-3
Duration : 2 h 10 min
Bit rate mode : Constant
Bit rate : 448 kb/s
Channel(s) : 6 channels
Channel layout : L R C LFE Ls Rs
Sampling rate : 48.0 kHz
Frame rate : 31.250 FPS (1536 SPF)
Compression mode : Lossy
Stream size : 417 MiB (1%)
Language : English
Service kind : Complete Main
Default : Yes
Alternate group : 2
Encoded date : UTC 2020-06-16 22:14:54
Tagged date : UTC 2020-06-16 22:14:54

planet_hoarder
Posts: 33
Joined: Tue Mar 17, 2020 10:32 am

Re: Dolby Vision and 1.15.1

Post by planet_hoarder » Wed Jun 17, 2020 8:44 pm

shawnc22 wrote:
Wed Jun 17, 2020 6:32 pm
I don't have a handy FEL title cut up at the moment, but here's a MEL sample:

https://mega.nz/file/YSxhkSLK#fkfy54tYV ... xIOBZLyGR4

If this works on your 2019 Shield, then a FEL title will also. There is no difference in the remux process. The version of tsmuxer people have been using is the one that's labeled 4.06 fix, and it's been extensively linked throughout the two threads. I'm also talking strictly about Plex. I have not done any extensive testing on MXPlayer to be able to say anything conclusively.
hm very weird. I tested this file already checked this Doctor_Sleep_DV_Atmos.ts
It worked on my LG C8, but when I try to create another movie, it doesn't even play.

Are you sure you just put BL and EL tracks in tsMuxer, or did you use yusesope tool to make BL_EL_RPU.hevc first? Because MediaInfo shows only one track.

shawnc22
Posts: 563
Joined: Tue Jan 21, 2020 7:40 am

Re: Dolby Vision and 1.15.1

Post by shawnc22 » Wed Jun 17, 2020 9:16 pm

planet_hoarder wrote:
Wed Jun 17, 2020 8:44 pm
shawnc22 wrote:
Wed Jun 17, 2020 6:32 pm
I don't have a handy FEL title cut up at the moment, but here's a MEL sample:

https://mega.nz/file/YSxhkSLK#fkfy54tYV ... xIOBZLyGR4

If this works on your 2019 Shield, then a FEL title will also. There is no difference in the remux process. The version of tsmuxer people have been using is the one that's labeled 4.06 fix, and it's been extensively linked throughout the two threads. I'm also talking strictly about Plex. I have not done any extensive testing on MXPlayer to be able to say anything conclusively.
hm very weird. I tested this file already checked this Doctor_Sleep_DV_Atmos.ts
It worked on my LG C8, but when I try to create another movie, it doesn't even play.

Are you sure you just put BL and EL tracks in tsMuxer, or did you use yusesope tool to make BL_EL_RPU.hevc first? Because MediaInfo shows only one track.
I never said anything about using the BL and EL tracks separately. This sample has always been a test for a single track file (processed either through yusecope's tool or makemkv 1.15.1) on the 2019 Shield. Your mileage will vary on other playback devices. The x700 (and maybe oppo?) is the only device that will playback a TS file when the BL and EL tracks are muxed separately.

@mathias19
Are you sure you are using the version of mp4muxer from the version I linked? There should not be a mp4muxer.exe in the bin folder, just mp4muxer_64bits.exe and mp4muxer_32bits.exe. If there is only a mp4muxer.exe, then you are using the wrong version and it will not work.

Here's also a sample mp4 for you to try: https://mega.nz/file/kHY22ayA#mFSmIb4Fc ... ieHENENAgo . It doesn't have audio, but you can at least test to see if the video will work.

evilmatcher
Posts: 11
Joined: Fri Apr 24, 2020 9:17 am

Re: Dolby Vision and 1.15.1

Post by evilmatcher » Wed Jun 17, 2020 9:23 pm

Hi
I cannot get my TV to toggle Dolby Vision (only HDR) with my Shutter Island rip, which has been created with version 1.15.1 and remuxed to TS.

Mediainfo shows this:

Image

I am using Plex on my Shield Pro 2019 connected to my LG C9 via a Denon AVR-X3500 receiver.

Am I missing a setting on Shield? The resolution on Shield is set to "4K 23.976 Hz Dolby Vision and HDR10 ready" and Dolby Vision is activated in the Display & Sound menu. The Shield is fully updated.

What have I done wrong?

planet_hoarder
Posts: 33
Joined: Tue Mar 17, 2020 10:32 am

Re: Dolby Vision and 1.15.1

Post by planet_hoarder » Wed Jun 17, 2020 10:47 pm

shawnc22 wrote:
Wed Jun 17, 2020 9:16 pm
planet_hoarder wrote:
Wed Jun 17, 2020 8:44 pm
shawnc22 wrote:
Wed Jun 17, 2020 6:32 pm
I don't have a handy FEL title cut up at the moment, but here's a MEL sample:

https://mega.nz/file/YSxhkSLK#fkfy54tYV ... xIOBZLyGR4

If this works on your 2019 Shield, then a FEL title will also. There is no difference in the remux process. The version of tsmuxer people have been using is the one that's labeled 4.06 fix, and it's been extensively linked throughout the two threads. I'm also talking strictly about Plex. I have not done any extensive testing on MXPlayer to be able to say anything conclusively.
hm very weird. I tested this file already checked this Doctor_Sleep_DV_Atmos.ts
It worked on my LG C8, but when I try to create another movie, it doesn't even play.

Are you sure you just put BL and EL tracks in tsMuxer, or did you use yusesope tool to make BL_EL_RPU.hevc first? Because MediaInfo shows only one track.
I never said anything about using the BL and EL tracks separately. This sample has always been a test for a single track file (processed either through yusecope's tool or makemkv 1.15.1) on the 2019 Shield. Your mileage will vary on other playback devices. The x700 (and maybe oppo?) is the only device that will playback a TS file when the BL and EL tracks are muxed separately.

Here's also a sample mp4 for you to try: https://mega.nz/file/kHY22ayA#mFSmIb4Fc ... ieHENENAgo . It doesn't have audio, but you can at least test to see if the video will work.
Thanks for another sample file, but Joker is also MEL.
you can process through makemkv? How? I haven't noticed that option.
Ok, single track, got it. I have only FEL movies, so everything I do (except Dolby's mp4muxer), my TV doesn't playback, even though all the samples with BL+EL+RPU work perfectly on my C8 (except GeminiMan one).

I want to get Shield TV, but want to be sure that I can create DV movie with Atmos or DTS:X.

planet_hoarder
Posts: 33
Joined: Tue Mar 17, 2020 10:32 am

Re: Dolby Vision and 1.15.1

Post by planet_hoarder » Wed Jun 17, 2020 10:50 pm

evilmatcher wrote:
Wed Jun 17, 2020 9:23 pm
Hi
I cannot get my TV to toggle Dolby Vision (only HDR) with my Shutter Island rip, which has been created with version 1.15.1 and remuxed to TS.

Mediainfo shows this:

Image

I am using Plex on my Shield Pro 2019 connected to my LG C9 via a Denon AVR-X3500 receiver.

Am I missing a setting on Shield? The resolution on Shield is set to "4K 23.976 Hz Dolby Vision and HDR10 ready" and Dolby Vision is activated in the Display & Sound menu. The Shield is fully updated.

What have I done wrong?
I think I read something about that.
Your media info says profile 4, which is dual layer with MEL.
I think EL is being discarded, because movie is in FEL.

can you cut a sample out for me to test?

mathias19
Posts: 9
Joined: Wed Jun 10, 2020 3:27 pm

Re: Dolby Vision and 1.15.1

Post by mathias19 » Wed Jun 17, 2020 11:16 pm

shawnc22 wrote:
Wed Jun 17, 2020 9:16 pm
planet_hoarder wrote:
Wed Jun 17, 2020 8:44 pm
shawnc22 wrote:
Wed Jun 17, 2020 6:32 pm
I don't have a handy FEL title cut up at the moment, but here's a MEL sample:

https://mega.nz/file/YSxhkSLK#fkfy54tYV ... xIOBZLyGR4
@mathias19
Are you sure you are using the version of mp4muxer from the version I linked? There should not be a mp4muxer.exe in the bin folder, just mp4muxer_64bits.exe and mp4muxer_32bits.exe. If there is only a mp4muxer.exe, then you are using the wrong version and it will not work.

Here's also a sample mp4 for you to try: https://mega.nz/file/kHY22ayA#mFSmIb4Fc ... ieHENENAgo . It doesn't have audio, but you can at least test to see if the video will work.
@shawnc22

It looks like I have the incorrect version as I have 3 files in the bin folder... mp4muxer.exe, mp4muxer_mac and mp4muxer.
Maybe I got this one from this thread and not the 'dolby vision mp4' thread?

Ill give the test file a try and I'll look for the version you linked. Thanks!

EDIT: Test file works using attached USB and Plex! I'll use the 64bit mp4muxer and see if I can get it working. Thanks!

shawnc22
Posts: 563
Joined: Tue Jan 21, 2020 7:40 am

Re: Dolby Vision and 1.15.1

Post by shawnc22 » Thu Jun 18, 2020 12:03 am

planet_hoarder wrote:
Wed Jun 17, 2020 10:50 pm
evilmatcher wrote:
Wed Jun 17, 2020 9:23 pm
Hi
I cannot get my TV to toggle Dolby Vision (only HDR) with my Shutter Island rip, which has been created with version 1.15.1 and remuxed to TS.

Mediainfo shows this:

Image

I am using Plex on my Shield Pro 2019 connected to my LG C9 via a Denon AVR-X3500 receiver.

Am I missing a setting on Shield? The resolution on Shield is set to "4K 23.976 Hz Dolby Vision and HDR10 ready" and Dolby Vision is activated in the Display & Sound menu. The Shield is fully updated.

What have I done wrong?
I think I read something about that.
Your media info says profile 4, which is dual layer with MEL.
I think EL is being discarded, because movie is in FEL.

can you cut a sample out for me to test?
No, there's nothing wrong with that file from looking at the mediainfo, Profile 4 supports both MEL and FEL. When creating an mkv file with makemkv 1.15.1, the original BL and EL tracks will be combined into a single track just like yusecope's tool. Here's a sample from an FEL title created the same way as all the others: https://mega.nz/file/MHpBBLjK#4bM5jsNgP ... glhYbzLcQ0 . And again, this is confirmed to work on the 2019 Shield. Playback on anything else, including the LG internal player, is not guaranteed.

@evilmatcher
Please give the above sample a try. If it works, then it's your remux process that's the issue and if not, then there's something going on with your setup.

evilmatcher
Posts: 11
Joined: Fri Apr 24, 2020 9:17 am

Re: Dolby Vision and 1.15.1

Post by evilmatcher » Thu Jun 18, 2020 6:44 am

shawnc22 wrote:
Thu Jun 18, 2020 12:03 am
planet_hoarder wrote:
Wed Jun 17, 2020 10:50 pm
evilmatcher wrote:
Wed Jun 17, 2020 9:23 pm
Hi
I cannot get my TV to toggle Dolby Vision (only HDR) with my Shutter Island rip, which has been created with version 1.15.1 and remuxed to TS.

Mediainfo shows this:

Image

I am using Plex on my Shield Pro 2019 connected to my LG C9 via a Denon AVR-X3500 receiver.

Am I missing a setting on Shield? The resolution on Shield is set to "4K 23.976 Hz Dolby Vision and HDR10 ready" and Dolby Vision is activated in the Display & Sound menu. The Shield is fully updated.

What have I done wrong?
I think I read something about that.
Your media info says profile 4, which is dual layer with MEL.
I think EL is being discarded, because movie is in FEL.

can you cut a sample out for me to test?
No, there's nothing wrong with that file from looking at the mediainfo, Profile 4 supports both MEL and FEL. When creating an mkv file with makemkv 1.15.1, the original BL and EL tracks will be combined into a single track just like yusecope's tool. Here's a sample from an FEL title created the same way as all the others: https://mega.nz/file/MHpBBLjK#4bM5jsNgP ... glhYbzLcQ0 . And again, this is confirmed to work on the 2019 Shield. Playback on anything else, including the LG internal player, is not guaranteed.

@evilmatcher
Please give the above sample a try. If it works, then it's your remux process that's the issue and if not, then there's something going on with your setup.
Thanks for the help, but it didn't work. I now see that I have two problems instead of one ;-)

When I played the video sample on Shield connected to the TV via the receiver is still showed HDR, but when I connected Shield directly to the TV's HDMI2 port first HDR was toggled but after a few seconds Dolby vision showed up perfectly. I tried to play Shutter Island on the Shield directly connected to the TV and it still only showed HDR.

All this leads me to think that I have a problem with the TS remux and I have a problem with settings on the surround receiver.

Do you have any tips?

dysprosium
Posts: 5
Joined: Thu Jun 18, 2020 6:52 am

Re: Dolby Vision and 1.15.1

Post by dysprosium » Thu Jun 18, 2020 6:56 am

Dolby Vision in MKV standard pull request has been merged, and is live.

http://cellar-wg.github.io/matroska-spe ... specs.html

ElegyD
Posts: 2
Joined: Thu Jun 18, 2020 7:11 am

Re: Dolby Vision and 1.15.1

Post by ElegyD » Thu Jun 18, 2020 7:41 am

Hi guys, new here, I've lurked this thread for some days now.

Good news, the pull request for the matroska specification has been merged and the issue has been closed.
Now ExoPlayer can start working on this issue to bring DV MKV support to Android devices.

Also, I don't know if someone needs this, but I've forked the current version of tsMuxer and committed a "04.06 fix".
So that we have a current version of tsMuxer with the "04.06 fix" that creates profile 4 instead of profile 6 ts files.
I try to keep it up to date with the main repo until ExoPlayer adds this feature.
Binaries can be created by following the compiling guide for now. Maybe I can provide them later some day if someone wants it.

Post Reply