Did my drive die? BD-RE WH14NS40

Forum for discussions about UHD-capable dives
djkms
Posts: 11
Joined: Fri Nov 30, 2018 4:45 am

Did my drive die? BD-RE WH14NS40

Post by djkms » Fri Nov 30, 2018 4:49 am

Hello all,

Been using makemkv for a while without issue. UHD has been working fine until yesterday. According to the drive information I am on 1.02. The drive is reading dvd ok but not bluray or UHD. Laser go bad maybe? Should I do the downgrade again or pointless since its already listed as 1.02? Windows update maybe bork this? What replacement drive do you suggest if needed?

Drive Information
OS device name: B:
Manufacturer: HL-DT-ST
Product: BD-RE WH14NS40
Revision: 1.02
Serial number: **********
Firmware date: 2115-12-11 15:03:
Bus encryption flags: 17
Highest AACS version: 65

Any and all help appreciated. Thanks!

Woodstock
Posts: 5974
Joined: Sun Jul 24, 2011 11:21 pm

Re: Did my drive die? BD-RE WH14NS40

Post by Woodstock » Fri Nov 30, 2018 2:01 pm

Your drive may simply have encountered a version of AACS that your copy of MakeMKV does not handle yet. AACS v66 revoked the MakeMKV access key used in versions prior to 1.14.x, so if you've put an AACS v66 disk in that drive, it will refuse to let MakeMKV read ANY BDs with 1.12.x or earlier.

What version MakeMKV are you using?
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

djkms
Posts: 11
Joined: Fri Nov 30, 2018 4:45 am

Re: Did my drive die? BD-RE WH14NS40

Post by djkms » Fri Nov 30, 2018 2:52 pm

MakeMKV version 1.14.1. Its not reading any bluray discs, even in windows. Prior to this happening when putting in BluRays, MPC would pop up and try to play the movie. Now I get nothing in the windows environment either.

Woodstock
Posts: 5974
Joined: Sun Jul 24, 2011 11:21 pm

Re: Did my drive die? BD-RE WH14NS40

Post by Woodstock » Fri Nov 30, 2018 6:35 pm

There is only one laser in the drive. If it can read DVDs, the laser is working.

If you insert a DVD, Windows registers that it is there, but inserting a BD, it shows the drive empty?

If MakeMKV acknowledges that a disk is in the drive, can you do a backup of it?
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

djkms
Posts: 11
Joined: Fri Nov 30, 2018 4:45 am

Re: Did my drive die? BD-RE WH14NS40

Post by djkms » Fri Nov 30, 2018 6:52 pm

You are correct, DVD registers, BD does not. MakeMKV doesn't even show a disc in the drive.

While all this is happening my key expired early..not sure if this has something to do with it? I did change the date on my PC to get it running again, same issue - shows no disc in the drive.

Maybe wait until a new temp key is issued to see if this resolves the problem?

Thanks again for your time and help!

Woodstock
Posts: 5974
Joined: Sun Jul 24, 2011 11:21 pm

Re: Did my drive die? BD-RE WH14NS40

Post by Woodstock » Fri Nov 30, 2018 7:49 pm

Even if the key is expired, MakeMKV should show a disk... then say it can't read it. :)

Try setting the system date to 25 November, start MakeMKV, and see if it loads the disk. If it IS the key, that will fix it temporarily. (the date can be reset after MakeMKV starts)
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

djkms
Posts: 11
Joined: Fri Nov 30, 2018 4:45 am

Re: Did my drive die? BD-RE WH14NS40

Post by djkms » Mon Dec 03, 2018 3:29 pm

That didnt work. I upgraded to the latest MakeMKV this morning, same issue. When I put a disc in the icon on the software shows a disc spinning, it says "disc is being loaded" then after it spins up it says no disc inserted. Thoughts? Hardware, software, bios, windows, firmware issue?

I have no problem going out and buying a new drive if that is what is needed, I just dont want to drop the money just to have the same thing happen with another drive. Thanks

djkms
Posts: 11
Joined: Fri Nov 30, 2018 4:45 am

Re: Did my drive die? BD-RE WH14NS40

Post by djkms » Mon Dec 03, 2018 4:53 pm

You did say AACS v66 might have revoked MakeMKV access, I have the latest MakeMKV but it still shows AACS v65? Could AACS v66 somehow stopped MakeMKV from reading all blu-ray/UHD discs? How do I get MakeMKV to read/use/acess AACS v66?

Woodstock
Posts: 5974
Joined: Sun Jul 24, 2011 11:21 pm

Re: Did my drive die? BD-RE WH14NS40

Post by Woodstock » Mon Dec 03, 2018 8:12 pm

Support for AACS v66 was a big reason why 1.14.x came out, so it should not be a revocation issue if you're on 1.14.2.

MakeMKV shows the highest AACS version that it has seen, but that is not necessarily the highest one your drive has seen, because you only have to load a disk with a "bad" revocation list for the drive to refuse MakeMKV's access.

The "no disk" indication is the same as what you get when you put a UHD disk into a regular BD drive; You'll get the same response from Windows, and Explorer will not be able to look at the directory structure.
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

djkms
Posts: 11
Joined: Fri Nov 30, 2018 4:45 am

Re: Did my drive die? BD-RE WH14NS40

Post by djkms » Mon Dec 03, 2018 8:19 pm

Alright, so what is my solution you think? Should I follow the steps in your signature to see if that helps?

Woodstock
Posts: 5974
Joined: Sun Jul 24, 2011 11:21 pm

Re: Did my drive die? BD-RE WH14NS40

Post by Woodstock » Mon Dec 03, 2018 10:24 pm

Debug mode being on is rarely an issue - I leave it on all the time. Sending to logs to Mike.... not so much in this case, because the log isn't going to say much, other than "no disk".
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

djkms
Posts: 11
Joined: Fri Nov 30, 2018 4:45 am

Re: Did my drive die? BD-RE WH14NS40

Post by djkms » Mon Dec 03, 2018 10:36 pm

understood. So what will fix this? New drive, reformat windows, other solution?

Woodstock
Posts: 5974
Joined: Sun Jul 24, 2011 11:21 pm

Re: Did my drive die? BD-RE WH14NS40

Post by Woodstock » Tue Dec 04, 2018 2:47 am

Silly thought, but... When was the machine last reset? And by reset, I don't mean a soft-restart, but a power removed from the motherboard, or (if so equipped) the RESET button pushed on the computer? It's only during those times that the hardware is in a completely known state, and the software isn't making any assumptions.

There can be times when Windows (or Linux, or MacOS) can get confused about hardware, and things don't quite work like they should. We've been discussing this for 5 days now, which used to be an eternity for computer up-time, but my Windows system's coming up on 33 days since it was last reset, so maybe yours is, too...
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

djkms
Posts: 11
Joined: Fri Nov 30, 2018 4:45 am

Re: Did my drive die? BD-RE WH14NS40

Post by djkms » Tue Dec 04, 2018 4:00 am

Unplugged the computer, still not working :(

Tried to see if media player classic could play the DVD, its if as though when I put a disc in, windows not any software recognize that I actually put any disc in the drive.

cholla
Posts: 6
Joined: Sun Oct 28, 2018 3:11 pm

Re: Did my drive die? BD-RE WH14NS40

Post by cholla » Tue Dec 04, 2018 3:27 pm

Try IsoBuster to see if it can "see" a disc in this drive.
I haven't checked for a long time but IsoBuster used to have a trial version.
If it can't see any disc then I would say the problem is the drive or a bad connection to the drive.

I don't know if this would cause any problems but your firmware update says this: Firmware date: 2115-12-11 15:03:
So the year is way off for some reason.

Post Reply