Did my drive die? BD-RE WH14NS40

Forum for discussions about UHD-capable dives
djkms
Posts: 11
Joined: Fri Nov 30, 2018 4:45 am

Re: Did my drive die? BD-RE WH14NS40

Post by djkms » Tue Dec 04, 2018 3:46 pm

ISO Buster did not recognize a disc. I also tried putting in a blank blu ray disc to see if I could write to it, it does not recognize that disc either.

Shut down the PC and pulled out the sata cables and reinstalled, no go.

Not sure on the firmware date. It was a couple years ago when I got the drive, not sure if I did the firmware downgrade or not.

This is looking to be a bad drive, ordered a LG WH16NS40 last night from Amazon with an external case Vantec NST-536S3-BK. I have a desktop PC and a Surface Pro 3, between the 2, this new drive should work...

fidesachates
Posts: 2
Joined: Thu Dec 06, 2018 4:11 am

Re: Did my drive die? BD-RE WH14NS40

Post by fidesachates » Thu Dec 06, 2018 4:20 am

I'm not convinced it's the hardware exactly. Maybe it needs a firmware update that hasn't been released yet?

I have the same drive model and I had been using it just fine until I tried to burn a disk around the same time as your first post. After the disk was inserted, it would spin and then the drive would open(In Mac OSX drive opens, but in Windows the drive remains closed) and MakeMKV says there's no disk.

I dual boot between Mac OSX and Windows 10 and neither OS lets me mount the drive even. I tried Mike's suggestion posted multiple times elsewhere (in Mac OSX, open MakeMKV in DASAPI mode, insert disc, burn, close MakeMKV).

I find it hard to believe you and I have the same model and have the same problem at the same time without it being a software problem. Disjoined hardware doesn't break together without coicidence.

My details:

Drive Information
OS device name: E:
Manufacturer: HL-DT-ST
Product: BD-RE WH14NS40
Revision: 1.03
Firmware date: 2117-11-21 16:58
Bus encryption flags: 17

MakeMKV Version: 1.14.2

djkms
Posts: 11
Joined: Fri Nov 30, 2018 4:45 am

Re: Did my drive die? BD-RE WH14NS40

Post by djkms » Thu Dec 06, 2018 3:44 pm

I was literally in the process of backing up a 6 movie set I just ordered on Black Friday. Disc 1 ripped fine and this happened on disc 2. I have my new drive coming in today. Personally I think the protection made the drive unreadable or a windows update applied, making discs unreadable. Either case, with a new drive here I can continue the process of elimination on exactly what the problem is, between 2 pc's and 2 drives with an external case...

fidesachates
Posts: 2
Joined: Thu Dec 06, 2018 4:11 am

Re: Did my drive die? BD-RE WH14NS40

Post by fidesachates » Wed Dec 12, 2018 12:07 am

Did the new drive work?

djkms
Posts: 11
Joined: Fri Nov 30, 2018 4:45 am

Re: Did my drive die? BD-RE WH14NS40

Post by djkms » Wed Dec 12, 2018 3:05 am

Sure did, it was hardware for sure.

Post Reply