Page 1 of 1

WH16NS40 and WH14NS40

Posted: Mon Oct 28, 2019 6:31 pm
by de2000
I am a noob. I've been reading the how to's and forum posts.

I have both drives, WH16NS40 and WH14NS40. The WH16NS40 is at 1.03 and SVC NS50. The WH14NS40 is at 1.02 (and I don't know the SVC code at the moment as I don't have access to the computer at home now).

So, initially, I tried to flash the 1.02 firmware from this forum (the Google Drive link) to the WH16NS40. It kept telling me that there was a mismatch and went to emergency mode. I rebooted the computer and tried to flash again. I think on the third try, it actually finished flashing without giving me errors and asked me to reboot. I did. I can see that MakeMKV tells me that the firmware is at 1.02. However, the drive still cannot load my UHD Lucy disc (spins, tries to read, then just stopped, and MakeMKV says no disc). I tried to read a regular BD disc just to make sure that the drive isn't bricked. It reads the regular BD disc.

I then tried the WH14NS40 in my computer. Seeing that it is already at 1.02, I tried to read the same UHD Lucy disc. No go, just like the other drive. I then tried to flash the 1.02 firmware from the Google drive archive, but it gave me errors.

So, this is where I stopped.

Can you guys see what is going on here? What else do I need to try? Need to try a different UHD disc? etc...

Any help is much appreciated!

Re: WH16NS40 and WH14NS40

Posted: Tue Oct 29, 2019 3:30 pm
by de2000
Well, I guess my situation is unique since no one responded.

Anyway, I forged on and flashed the MK firmware on the 14 since it is currently in the computer. And I also got another disc (Oblivion) from my stash to try. So, during the flashing, it gave me error again saying that it is in emergency mode. I rebooted, and it appeared that it took the update... I don't know why.

So, I used Oblivion, and it worked... Then I tried Lucy, it didn't work.

So all this time, I may have been screwed up by the Lucy disc. So, is Lucy a known problem disc, or it's just my drive?

Re: WH16NS40 and WH14NS40

Posted: Mon Nov 04, 2019 7:10 pm
by VarHD
While I can't say if "Lucy" is a known bad release, I can definitely confirm that this is a possibility and something that happened to me with "The Hunger Games: Catching Fire" - I bought 3 different copies of it, a UK, Australian and German release. Both the UK and Australian will not work on two different drives, the German will... but the German one is a 2-layered disc while the other two are 3-layered.

It's not uncommon for the UHD friendly drives to not be able to read a certain release and these drives tend to have more issues with 3-layered UHD discs. Sometimes it's as simple as a dirty disc, even if it's factory new, it might have a barely visible or completely invisible thin layer of... "factory goo" (for the lack of a better word) and you'll find many people here reporting cases where cleaning the seemingly already clean disc helped. On the other hand, you might really have a "bad disc" in which case no amount of cleaning will help.

I found one other thread where someone complaints about the same movie: viewtopic.php?f=12&t=16989 so it does seem to be a bit problematic.

Re: WH16NS40 and WH14NS40

Posted: Mon Nov 04, 2019 11:33 pm
by MartyMcNuts
It sounds to me like your WH14NS40 drive may not be SVC NS50 and is too old to be UHD compatible.

Does it still rip standard blu-ray discs?
Also, you didn't say if your Oblivion is BD or UHD.

Re: WH16NS40 and WH14NS40

Posted: Wed Nov 06, 2019 6:15 pm
by de2000
Thank you for the replies.

Both drives now working on all of my collection of UHD discs (I have like 5 of them) except Lucy. I went ahead and flash 1.02 firmware on the 16 (came with 1.03). Even though I got errors during flashing, both drives worked after a reboot. I don't know why.

So on the 14, I flashed the MK firmware. On the 16, I flashed the factory 1.02 firmware. Both are working now, with regular BD and UHD discs. I must say that I didn't fully know what I was doing, but I tried to read and then tried the flashing. And both are now working, sort of like an idiot's luck...

I also bought a PCIE SATA card for my computer as I ran out of SATA ports. Now I have both drives in the computer, but I did not flash the drives via the card. So I don't know if the card can support that.

I will try to see if my Lucy has any kind of optical obstruction on the disc or not. My discs are immaculate, but I guess I never know. I also read on the other Lucy thread and other forums, I have tried to see if I can get a replacement for free.

So, which discs are 3 layer ones? Maybe I need to try one of those.

Thank you.