flashing

Forum for discussions about UHD-capable dives
Coopervid
Posts: 144
Joined: Tue Feb 19, 2019 10:32 pm

Re: flashing

Post by Coopervid » Sat Oct 24, 2020 12:28 pm

Failure #4 usually occurs if you run the program in a virtual machine. You have to flash your drive in your native OS. If on a Mac please check the Mac section or under Linux check the Linux section.

yamahaman
Posts: 19
Joined: Thu Oct 22, 2020 5:01 pm

Re: flashing

Post by yamahaman » Sat Oct 24, 2020 2:10 pm

I am running it on windows 10 x64 not on virtual.machine.

Billycar11
Posts: 1167
Joined: Sun Aug 24, 2014 5:49 am

Re: flashing

Post by Billycar11 » Sat Oct 24, 2020 3:33 pm

yamahaman wrote:
Sat Oct 24, 2020 12:08 pm
updating with that flasher gives updating failure #4
This is the problem you are flashing the wrong firmware if you followed my pined guide this would not be an issue flash WH16NS60 1.02mk like my guide says.

Wh16NS40 1.03 mk does not have the additional downgrade checks disabled so it will always fail.

Coopervid
Posts: 144
Joined: Tue Feb 19, 2019 10:32 pm

Re: flashing

Post by Coopervid » Sat Oct 24, 2020 5:15 pm

Billy,

I'm puzzled.... Where do you say that WH16NS60 1.02 has be be flashed first???

Yamahaman:Try this and if successful you can then flash your drive specific firmware if you want

yamahaman
Posts: 19
Joined: Thu Oct 22, 2020 5:01 pm

Re: flashing

Post by yamahaman » Sat Oct 24, 2020 5:36 pm

I do not have WH16NS60 I have WN16NS40 on firmware 1.4 its starting to get confusing now.

Coopervid
Posts: 144
Joined: Tue Feb 19, 2019 10:32 pm

Re: flashing

Post by Coopervid » Sat Oct 24, 2020 5:41 pm

Billy says that you have to cross-flash first before you can flash to your drive specific firmware. So try to flash WH16NS60 1.02 and then afterwards W16NS40 1.02 or 1.03 or 1.04. If you are using only Makemkv you can also stay on WH16NS60. If you want to use other progs as well like AnyDVD you need to flash it to WH16NS40 firmware.

yamahaman
Posts: 19
Joined: Thu Oct 22, 2020 5:01 pm

Re: flashing

Post by yamahaman » Sat Oct 24, 2020 7:58 pm

nothing appears to work none of the programmes will open without errors looks like it is down to net framework but I have tried uninstalling then reinstalling but has not fixed problem.

Coopervid
Posts: 144
Joined: Tue Feb 19, 2019 10:32 pm

Re: flashing

Post by Coopervid » Sat Oct 24, 2020 8:02 pm

Any chance to put your drive in another PC?

Coopervid
Posts: 144
Joined: Tue Feb 19, 2019 10:32 pm

Re: flashing

Post by Coopervid » Sat Oct 24, 2020 8:10 pm

Last theory. Any Antivirus software running could also interfere.

yamahaman
Posts: 19
Joined: Thu Oct 22, 2020 5:01 pm

Re: flashing

Post by yamahaman » Sat Oct 24, 2020 8:35 pm

The drive is used external not in pc connected by Unitek Y-1099 its a dell XPS 8930 pc so no room to install a drive within.

Coopervid
Posts: 144
Joined: Tue Feb 19, 2019 10:32 pm

Re: flashing

Post by Coopervid » Sat Oct 24, 2020 8:53 pm

That's your problem. Not all USB adapters allow flashing. If you have no other possibilty you need a different adapter. Need to say that you come up with that information very late. That would have been very obvious in the first place.

Coopervid
Posts: 144
Joined: Tue Feb 19, 2019 10:32 pm

Re: flashing

Post by Coopervid » Sat Oct 24, 2020 9:05 pm

yamahaman. I'm out now and will not support this thread any further. You provided too less information in the first place and only did by small slices. If you would have stated your configuration right from the beginning we would have saved a lot of posts etc. and poking here and there. The way you asked for help is frustrating for us who want to help. Too little information to drill down to the problem. You see - I'm also frustrated. There could have been a real shortcut if we would have known about how you use your drive.

yamahaman
Posts: 19
Joined: Thu Oct 22, 2020 5:01 pm

Re: flashing

Post by yamahaman » Sat Oct 24, 2020 9:32 pm

So sorry but thanks every one for your help.

MartyMcNuts
Posts: 1017
Joined: Wed Nov 22, 2017 11:45 pm

Re: flashing

Post by MartyMcNuts » Sat Oct 24, 2020 11:04 pm

yamahaman wrote:
Sat Oct 24, 2020 9:32 pm
So sorry but thanks every one for your help.
The Unitek Y-1099 adapter is fine for flashing your drive. I use one myself!

You can use either the modified ASUS flasher or the SDFtool Flasher, however .net framework 4.7.2 is required. If you install the latest version you should be ok.

Once you have that sorted out, I suggest flashing your drive to WH16NS40 1.04 MK from the MK firmware pack. Once you have completed this initial flash, you can then flash the drive to whatever desktop firmware you please.
Cheers :D
----------------------------------------------------------------------------------------------------------------------------------------
For UHD capable drives in AUS & NZ: viewtopic.php?f=20&t=18747

yamahaman
Posts: 19
Joined: Thu Oct 22, 2020 5:01 pm

Re: flashing

Post by yamahaman » Sun Oct 25, 2020 12:33 am

Thank you so much for the confirmatiom

Post Reply