Makemkv 1.14.2 with Kodi 18.0 or VLC 3.0

The place to discuss linux version of MakeMKV
Post Reply
dgktkr
Posts: 17
Joined: Thu Dec 30, 2010 7:51 pm

Makemkv 1.14.2 with Kodi 18.0 or VLC 3.0

Post by dgktkr » Sun Feb 10, 2019 11:27 pm

On my Ubuntu 18.04 system blurays without BD+ would play without issue with unmodified Makemkv 1.14.2, but discs with BD+ protection would fail.

There have been some changes to Makemkv since 1.12 that accommodate the libbluray API for aacs decryption. Unfortunately, the changes didn't go as far as fixing things for BD+ discs.

A solution isn't difficult. Before you build Makemkv 1.14.2, modify the source files according to steps 5 through 7 in this post viewtopic.php?t=16824#p61608

That's what got bluray discs playing again for me. Hopefully it'll work for you too.

dgktkr

PS Don't use snap to install VLC; it forces VLC to use open source versions of libaacs and libbdplus.

Post Reply