Page 2 of 7

Re: Optical Drive not being found

Posted: Fri Jan 19, 2018 5:18 pm
by JohnJasonJordan
spl147 wrote:has this been fixed in V.1.10.10?
I just installed it on Xubuntu 14.04 and it is not fixed:

Code: Select all

MakeMKV v1.10.10 linux(x64-release) started
The program can't find any usable optical drives.
Back to 1.10.8. :( :( :(

Re: Optical Drive not being found

Posted: Fri Jan 19, 2018 5:20 pm
by spl147
comon mike.....this is a real issue!

Re: Optical Drive not being found

Posted: Fri Jan 19, 2018 10:09 pm
by BillyPilgrim
Can confirm this has NOT been fixed in 1.10.10. I'm running Arch Linux, tried both my user and root and it does not detect the optical drive in my laptop (same message as above).

Re: Optical Drive not being found

Posted: Fri Jan 19, 2018 11:28 pm
by __ap0
BillyPilgrim wrote:Can confirm this has NOT been fixed in 1.10.10. I'm running Arch Linux, tried both my user and root and it does not detect the optical drive in my laptop (same message as above).
Same here.

Re: Optical Drive not being found

Posted: Sat Jan 20, 2018 12:51 am
by Djoss
Same thing for me: issue not fixed.

Re: Optical Drive not being found

Posted: Sat Jan 20, 2018 12:17 pm
by saarg
Here is a debug log when starting Makemkv and it fails to find a drive.

Code: Select all

Debug log started at Sat Jan 20 12:15:16 2018 , written by MakeMKV v1.10.10 linux(x64-release)
Using 524544KB for read cache.
001005:0000 MakeMKV v1.10.10 linux(x64-release) started
001004:0000 Debug logging enabled, log will be saved as /nobody/MakeMKV_log.txt
001003:0020 DEBUG: Code 0 at i8o_\FrH@0!.%J*iw:y>:29394620
001003:0020 DEBUG: Code 0 at f(07n6+@P+;Fd>E:121262187
001003:0020 DEBUG: Code 0 at i8o_\FrH@0!.%J*iw:y>:29394620
001003:0020 DEBUG: Code 0 at f(07n6+@P+;Fd>E:121262187
005042:0000 The program can't find any usable optical drives.

Re: Optical Drive not being found

Posted: Sat Jan 20, 2018 2:14 pm
by akshunj
For those of us using the PPA, the maintainer is quite responsive and has rolled back to 1.10.8

https://launchpad.net/~heyarje/+archive ... -downgrade

Re: Optical Drive not being found

Posted: Sat Jan 20, 2018 3:24 pm
by Kebast
Same issue for me. On Ubuntu 14.04. 1.10.9 and 1.10.10 can't find optical drive. I reverted to 1.10.6 since .7 and .8 have another issue with some bluray discs.

Re: Optical Drive not being found

Posted: Sat Jan 20, 2018 8:54 pm
by rodgerdodger
I'm having the same problem on mint

Re: Optical Drive not being found

Posted: Sun Jan 21, 2018 6:31 pm
by mike admin
Can you please post the output of

Code: Select all

ls -la /sys/bus/scsi/devices/

Re: Optical Drive not being found

Posted: Sun Jan 21, 2018 8:03 pm
by saarg
mike admin wrote:Can you please post the output of

Code: Select all

ls -la /sys/bus/scsi/devices/

Code: Select all

root@80434ed9af8b:/# ls -la /sys/bus/scsi/devices/
total 0
drwxr-xr-x 2 root root 0 Jan 21 20:58 .
drwxr-xr-x 4 root root 0 Jan 21 20:58 ..
lrwxrwxrwx 1 root root 0 Jan 21 20:58 0:0:0:0 -> ../../../devices/pci0000:00/0000:00:1c.2/0000:08:00.0/usb1/1-1/1-1:1.0/host0/target0:0:0/0:0:0:0
lrwxrwxrwx 1 root root 0 Jan 21 20:58 1:0:0:0 -> ../../../devices/pci0000:00/0000:00:1f.2/ata1/host1/target1:0:0/1:0:0:0
lrwxrwxrwx 1 root root 0 Jan 21 20:58 2:0:0:0 -> ../../../devices/pci0000:00/0000:00:1f.2/ata2/host2/target2:0:0/2:0:0:0
lrwxrwxrwx 1 root root 0 Jan 21 20:58 5:0:0:0 -> ../../../devices/pci0000:00/0000:00:1f.2/ata5/host5/target5:0:0/5:0:0:0
lrwxrwxrwx 1 root root 0 Jan 21 20:58 6:0:0:0 -> ../../../devices/pci0000:00/0000:00:1f.2/ata6/host6/target6:0:0/6:0:0:0
lrwxrwxrwx 1 root root 0 Jan 21 20:58 host0 -> ../../../devices/pci0000:00/0000:00:1c.2/0000:08:00.0/usb1/1-1/1-1:1.0/host0
lrwxrwxrwx 1 root root 0 Jan 21 20:58 host1 -> ../../../devices/pci0000:00/0000:00:1f.2/ata1/host1
lrwxrwxrwx 1 root root 0 Jan 21 20:58 host2 -> ../../../devices/pci0000:00/0000:00:1f.2/ata2/host2
lrwxrwxrwx 1 root root 0 Jan 21 20:58 host3 -> ../../../devices/pci0000:00/0000:00:1f.2/ata3/host3
lrwxrwxrwx 1 root root 0 Jan 21 20:58 host4 -> ../../../devices/pci0000:00/0000:00:1f.2/ata4/host4
lrwxrwxrwx 1 root root 0 Jan 21 20:58 host5 -> ../../../devices/pci0000:00/0000:00:1f.2/ata5/host5
lrwxrwxrwx 1 root root 0 Jan 21 20:58 host6 -> ../../../devices/pci0000:00/0000:00:1f.2/ata6/host6
lrwxrwxrwx 1 root root 0 Jan 21 20:58 host7 -> ../../../devices/pci0000:00/0000:00:11.0/0000:05:00.0/host7
lrwxrwxrwx 1 root root 0 Jan 21 20:58 target0:0:0 -> ../../../devices/pci0000:00/0000:00:1c.2/0000:08:00.0/usb1/1-1/1-1:1.0/host0/target0:0:0
lrwxrwxrwx 1 root root 0 Jan 21 20:58 target1:0:0 -> ../../../devices/pci0000:00/0000:00:1f.2/ata1/host1/target1:0:0
lrwxrwxrwx 1 root root 0 Jan 21 20:58 target2:0:0 -> ../../../devices/pci0000:00/0000:00:1f.2/ata2/host2/target2:0:0
lrwxrwxrwx 1 root root 0 Jan 21 20:58 target5:0:0 -> ../../../devices/pci0000:00/0000:00:1f.2/ata5/host5/target5:0:0
lrwxrwxrwx 1 root root 0 Jan 21 20:58 target6:0:0 -> ../../../devices/pci0000:00/0000:00:1f.2/ata6/host6/target6:0:0
And here is lsscsi.

Code: Select all

root@80434ed9af8b:/# lsscsi
[0:0:0:0]    disk    SanDisk  Cruzer Fit       1.27  -
[1:0:0:0]    disk    ATA      Samsung SSD 850  1B6Q  -
[2:0:0:0]    disk    ATA      OCZ-TRION100     11.2  -
[5:0:0:0]    disk    ATA      TOSHIBA HDWD130  ACF0  -
[6:0:0:0]    cd/dvd  ATAPI    iHOS104          WL0G  /dev/sr0

Re: Optical Drive not being found

Posted: Mon Jan 22, 2018 1:00 am
by Djoss

Code: Select all

# ls -la /sys/bus/scsi/devices/
total 0
drwxr-xr-x    2 root     root             0 Jan 22 00:59 .
drwxr-xr-x    4 root     root             0 Jan 22 00:59 ..
lrwxrwxrwx    1 root     root             0 Jan 22 00:59 0:0:0:0 -> ../../../devices/pci0000:00/0000:00:11.0/ata1/host0/target0:0:0/0:0:0:0
lrwxrwxrwx    1 root     root             0 Jan 22 00:59 1:0:0:0 -> ../../../devices/pci0000:00/0000:00:11.0/ata2/host1/target1:0:0/1:0:0:0
lrwxrwxrwx    1 root     root             0 Jan 22 00:59 host0 -> ../../../devices/pci0000:00/0000:00:11.0/ata1/host0
lrwxrwxrwx    1 root     root             0 Jan 22 00:59 host1 -> ../../../devices/pci0000:00/0000:00:11.0/ata2/host1
lrwxrwxrwx    1 root     root             0 Jan 22 00:59 target0:0:0 -> ../../../devices/pci0000:00/0000:00:11.0/ata1/host0/target0:0:0
lrwxrwxrwx    1 root     root             0 Jan 22 00:59 target1:0:0 -> ../../../devices/pci0000:00/0000:00:11.0/ata2/host1/target1:0:0

Re: Optical Drive not being found

Posted: Mon Jan 22, 2018 6:20 am
by twjaeger
I am trying to use MakeMKV to rip blu ray directly to my Qnap TS-451+ using LinuxStation - Ubuntu 16.04. I have been able to get the Qnap to recognize the drive and when using Linuxstation, it shows that it is a block device in /dev/sr0, mounts at /.share/external/dev3304_-1. VLC, MakeMKV (both v 1.10.8 and 1.10.10), DVD:Rip can't find the optical drive. I can access the drive using the file explorer (both inQnap and Linuxstation). I can also scan it using Handbrake. Anyone have any ideas?

lsscsi:

Code: Select all

root@ubuntu_1604:~# lsscsi
[2:0:0:0]    disk    WDC      WD40EFRX-68WT0N0 82.0  -        
[3:0:0:0]    disk    WDC      WD40EFRX-68WT0N0 82.0  -        
[10:0:0:0]   disk             USB DISK MODULE  PMAP  -        
[12:0:0:0]   cd/dvd  PIONEER  BD-RW   BDR-XD05 3.01  -

Re: Optical Drive not being found

Posted: Mon Jan 22, 2018 6:23 am
by twjaeger

Code: Select all

root@ubuntu_1604:~# ls -la /sys/bus/scsi/devices/
total 0
drwxr-xr-x 2 root root 0  一  21 21:02 .
drwxr-xr-x 4 root root 0  一  21 17:37 ..
lrwxrwxrwx 1 root root 0  一  21 17:37 10:0:0:0 -> ../../../devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.0/host10/target10:0:0/10:0:0:0
lrwxrwxrwx 1 root root 0  一  21 17:37 12:0:0:0 -> ../../../devices/pci0000:00/0000:00:14.0/usb2/2-1/2-1.2/2-1.2:1.0/host12/target12:0:0/12:0:0:0
lrwxrwxrwx 1 root root 0  一  21 17:37 2:0:0:0 -> ../../../devices/pci0000:00/0000:00:1c.0/0000:01:00.0/ata3/host2/target2:0:0/2:0:0:0
lrwxrwxrwx 1 root root 0  一  21 17:37 3:0:0:0 -> ../../../devices/pci0000:00/0000:00:1c.0/0000:01:00.0/ata4/host3/target3:0:0/3:0:0:0
lrwxrwxrwx 1 root root 0  一  21 17:42 host0 -> ../../../devices/pci0000:00/0000:00:1c.0/0000:01:00.0/ata1/host0
lrwxrwxrwx 1 root root 0  一  21 17:42 host1 -> ../../../devices/pci0000:00/0000:00:1c.0/0000:01:00.0/ata2/host1
lrwxrwxrwx 1 root root 0  一  21 17:42 host10 -> ../../../devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.0/host10
lrwxrwxrwx 1 root root 0  一  21 17:42 host12 -> ../../../devices/pci0000:00/0000:00:14.0/usb2/2-1/2-1.2/2-1.2:1.0/host12
lrwxrwxrwx 1 root root 0  一  21 17:42 host2 -> ../../../devices/pci0000:00/0000:00:1c.0/0000:01:00.0/ata3/host2
lrwxrwxrwx 1 root root 0  一  21 17:42 host3 -> ../../../devices/pci0000:00/0000:00:1c.0/0000:01:00.0/ata4/host3
lrwxrwxrwx 1 root root 0  一  21 17:42 host4 -> ../../../devices/pci0000:00/0000:00:1c.1/0000:02:00.0/ata5/host4
lrwxrwxrwx 1 root root 0  一  21 17:42 host5 -> ../../../devices/pci0000:00/0000:00:1c.1/0000:02:00.0/ata6/host5
lrwxrwxrwx 1 root root 0  一  21 17:42 host6 -> ../../../devices/pci0000:00/0000:00:1c.1/0000:02:00.0/ata7/host6
lrwxrwxrwx 1 root root 0  一  21 17:42 host7 -> ../../../devices/pci0000:00/0000:00:1c.1/0000:02:00.0/ata8/host7
lrwxrwxrwx 1 root root 0  一  21 17:42 target10:0:0 -> ../../../devices/pci0000:00/0000:00:14.0/usb1/1-4/1-4:1.0/host10/target10:0:0
lrwxrwxrwx 1 root root 0  一  21 17:42 target12:0:0 -> ../../../devices/pci0000:00/0000:00:14.0/usb2/2-1/2-1.2/2-1.2:1.0/host12/target12:0:0
lrwxrwxrwx 1 root root 0  一  21 17:42 target2:0:0 -> ../../../devices/pci0000:00/0000:00:1c.0/0000:01:00.0/ata3/host2/target2:0:0
lrwxrwxrwx 1 root root 0  一  21 17:42 target3:0:0 -> ../../../devices/pci0000:00/0000:00:1c.0/0000:01:00.0/ata4/host3/target3:0:0

Re: Optical Drive not being found

Posted: Mon Jan 22, 2018 11:57 am
by mike admin
Ok, looks like permissions issue. Please post one more output of

Code: Select all

ls -la /dev/sg*