Using FLAC Profile on 1.12.2 bluray speed issues

The place to discuss linux version of MakeMKV
Post Reply
TheClaus
Posts: 1
Joined: Tue May 22, 2018 5:04 pm

Using FLAC Profile on 1.12.2 bluray speed issues

Post by TheClaus » Tue May 22, 2018 5:09 pm

Hi, I have been using MakeMKV for awhile and noticed when I upgraded to 1.12.2 that the FLAC profile would cause MakeMKV to rip Blurays at a very slow speed. So slow that I stopped it from ripping because it was trying to do it at 0.6X speed. This happens regardless of if it is an actual disc or an ISO image.

Going back to 1.12.0 and the issue isn't there.

Let me know if any logs or anything would help.

Thanks

Claus

JohnJasonJordan
Posts: 14
Joined: Mon Jun 19, 2017 11:47 pm

Re: Using FLAC Profile on 1.12.2 bluray speed issues

Post by JohnJasonJordan » Sun Jul 08, 2018 5:44 am

TheClaus wrote:Hi, I have been using MakeMKV for awhile and noticed when I upgraded to 1.12.2 that the FLAC profile would cause MakeMKV to rip Blurays at a very slow speed. So slow that I stopped it from ripping because it was trying to do it at 0.6X speed. This happens regardless of if it is an actual disc or an ISO image.
Going back to 1.12.0 and the issue isn't there.
I have the same problem with 1.12.2 on Xubuntu 16.04. I have a desktop computer with 18.04 and 1.12.0, and the problem does not appear. Even on 1.12.2 it does not appear if I leave the audio at default; it is slow only if I select FLAC.

And I do need to use FLAC because the default setting does not include all the audio tracks in a Blu-ray disc. Only FLAC works correctly.

JohnJasonJordan
Posts: 14
Joined: Mon Jun 19, 2017 11:47 pm

Re: Using FLAC Profile on 1.12.2 bluray speed issues

Post by JohnJasonJordan » Fri Sep 07, 2018 4:14 pm

Yesterday I tried to encode a Blu-ray movie with FLAC and it took over ten hours. And the 12.0 copy on my other computer wouldn't encode this movie at all. Today I needed to do another Blu-ray movie so I decided it was time to upgrade to 12.3, which went successfully. However, the problem with the FLAC profile is unchanged. It says it is reading the disc at .1x (about 500K/s) and it will take eight hours to finish. If I use the Default profile it usually takes about half an hour for a Blu-ray movie, but the Default profile grabs the audio track from one of the other titles on the disc, like 'the making of...' or 'commentary by the director.' The FLAC profile does this also, but at least adds the correct audio track for the movie.

I wonder if the problem is in the profile. I haven't looked at them because I probably wouldn't understand anything anyway. From what I have read here the upgrade to 12.3 should have overwritten the FLAC profile, so it doesn't make any sense that the problem is in the profile. I could use some advice for where to look to solve this problem.

Woodstock
Posts: 5376
Joined: Sun Jul 24, 2011 11:21 pm

Re: Using FLAC Profile on 1.12.2 bluray speed issues

Post by Woodstock » Fri Sep 07, 2018 5:33 pm

Profiles that are stock aren't separate files in 1.12.x and later; they're stored in appdata.tar in the MakeMKV program directory. More information on them can be found here: https://makemkv.com/forum/viewtopic.php?f=10&t=17814

As for the SPEED of FLAC, I don't know about that - I don't have MakeMKV do audio conversions, since I'll be running the files through handbrake anyway.
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

JohnJasonJordan
Posts: 14
Joined: Mon Jun 19, 2017 11:47 pm

Re: Using FLAC Profile on 1.12.2 bluray speed issues

Post by JohnJasonJordan » Fri Sep 07, 2018 6:38 pm

As for the SPEED of FLAC, I don't know about that - I don't have MakeMKV do audio conversions, since I'll be running the files through handbrake anyway.
Oh wait, I didn't realize that selecting the FLAC profile meant that MakeMKV was converting the audio. Maybe that's why it's taking so long.

I didn't used to use FLAC, but the Default profile grabs the wrong audio track for the movie, and that is the only audio track I get. FLAC also includes the wrong audio track, but at least it includes the real audio track for the movie. And, like you, once it is finished I'm going to run it through Handbrake, where I can just not include the wrong audio file.

I would go back to using the Default profile if I could make it select the correct audio track.

Woodstock
Posts: 5376
Joined: Sun Jul 24, 2011 11:21 pm

Re: Using FLAC Profile on 1.12.2 bluray speed issues

Post by Woodstock » Fri Sep 07, 2018 7:08 pm

Use my method - have MakeMKV rip ALL tracks, both audio and subtitle, then sort them out at the handbrake side.

My default profile uses this selection string, which you can enter on the Preferences->Advanced tab to test:

Code: Select all

-sel:all,+sel:(favlang|nolang),-sel:mvcvideo,=100:all,-10:favlang
It deselects everything, then selects all language tracks, leaving out the MVC 3D track on 3D disks.
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

JohnJasonJordan
Posts: 14
Joined: Mon Jun 19, 2017 11:47 pm

Re: Using FLAC Profile on 1.12.2 bluray speed issues

Post by JohnJasonJordan » Sat Sep 08, 2018 1:31 am

Code: Select all
-sel:all,+sel:(favlang|nolang),-sel:mvcvideo,=100:all,-10:favlang
The existing line was:

Code: Select all

-sel:all,+sel:(favlang|nolang|single),-sel:(havemulti|havecore),-sel:mvcvideo,=100:all,-10:favlang
I replaced it with your line above, then ripped a Blu-ray movie of 1:10 length. It took 35 minutes, which is what I always get with the Default profile. But when I opened the MKV file there were no audio tracks at all. The video was lovely, and the subtitles were there, but no audio.

This is with 12.3 on Ubuntu 16.04.

Further suggestions?

Woodstock
Posts: 5376
Joined: Sun Jul 24, 2011 11:21 pm

Re: Using FLAC Profile on 1.12.2 bluray speed issues

Post by Woodstock » Sat Sep 08, 2018 3:13 am

Do you have a favorite language selected in Preferences->Language ? Mine is set to "None", and I get all tracks with the rule I posted.
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

JohnJasonJordan
Posts: 14
Joined: Mon Jun 19, 2017 11:47 pm

Re: Using FLAC Profile on 1.12.2 bluray speed issues

Post by JohnJasonJordan » Sat Sep 08, 2018 4:48 am

Do you have a favorite language selected in Preferences->Language ? Mine is set to "None", and I get all tracks with the rule I posted.
I had English as my preferred language, but I changed it to 'None' and re-made the MKV file. No luck. Still no audio. So then I poked through all the settings in Preferences looking for anything that might be relevant, and I noticed that I had set the default profile to FLAC (lest I forget to set it manually), so I set it back to Default and when I clicked to Apply the change I was prompted to restart MakeMKV for the change to take effect. I had not done so previously, so I restarted, and then tried the same movie again. And again it took about 35 minutes, but when it was done the file size was a few hundred MB larger and ... voilà! It worked!

Many thanks for your patient help!

Post Reply