Page 1 of 1

Linux Not Detecting LibreDrive Functionality

Posted: Sun Mar 31, 2019 7:02 pm
by spicyboots
So I downloaded the 3.02 firmware for my ASUS BW-16D1HT and flashed that, and afterward was able to do a test rip on the windows machine I was using without any issue. Afterwards I installed it in my Linux machine (Mint 19.1) and when I go to try and rip a disk I get:

Code: Select all

MakeMKV v1.14.3 linux(x64-release) started
Automatic checking for updates is enabled, you may disable it in preferences if you don't want MakeMKV to contact web server.
Using direct disc access mode
Saved AACS dump file as /home/<user>/.MakeMKV/MKB20_v61_THE_CABIN_IN_THE_WOODS_2565.tgz
LibreDrive compatible drive is required to open this disc - video can't be decrypted.
Failed to open disc
I have already tried uninstalling and reinstalling MakeMKV but that did not seem to help. Any advice would be appreciated!

[SOLVED] Re: Linux Not Detecting LibreDrive Functionality

Posted: Sat Apr 06, 2019 4:59 pm
by spicyboots
Hey so if anyone else is having this issue, here is how I fixed it...

Backup the config files (important if you have a registration key)

Code: Select all

mv ~/.MakeMKV ~/.MakeMKV_bkp
Remove the actual program

Code: Select all

sudo rm /usr/bin/makemkv
sudo rm /usr/bin/makemkvcon
Rebuild from source (the software manager did not work for some reason)

Code: Select all

tar xvzf makemkv-oss-1.14.3.tar.gz
tar xvzf makemkv-bin-1.14.3.tar.gz
cd makemkv-oss-1.14.3
sudo make install
cd ../makemkv-bin-1.14.3
sudo make install
Then you just need to copy over your registration key, start MakeMKV and you should be good to go! Now when you insert a disk into your libredrive capable drive, it should download the additional packages.


Re: Linux Not Detecting LibreDrive Functionality

Posted: Thu Apr 30, 2020 4:04 am
by icntoaun
Thank you so much! I was having a very similar issue with the makemkv snap - building from source fixed this and several other problems I was having.