update mkv writing librarys

The place to discuss linux version of MakeMKV
Post Reply
pipo233
Posts: 18
Joined: Sat Oct 17, 2020 6:14 pm

update mkv writing librarys

Post by pipo233 » Tue Nov 24, 2020 2:49 pm

will those libs be updated in future releases?
Those are relatively old and are included in the build, maybe it is beter to softlink them to the operating system ones?

Reason:
I have a few blu-ray rips that are made with makemkv that does not work correctly in my subtitle editor, subtitlecomposer. The waveform is not generated.
If i open those files with mkvtoolnix 51, change nothing and save as new file it does work correctly in subtitlecomposer.

Remains the question where the problem lays, but it think it is because makemkv uses relatively old mkv librarys?

For the record, the file that has troubles has dolby trueHD audio, so maybe that is improved/fixed in newer mkv libs?

Something to think about i guess

Ezatoka
Posts: 89
Joined: Fri Dec 06, 2019 6:55 pm

Re: update mkv writing librarys

Post by Ezatoka » Tue Nov 24, 2020 6:22 pm

It's new to me that Windows has native libraries for working with MKV files.

MKVtoolnix is a 3rd Party Program that needs to be installed and I'm sure by far not installed by most of the standard users.

So probably only the build in mkv files should be updated some time.

Woodstock
Posts: 7933
Joined: Sun Jul 24, 2011 11:21 pm

Re: update mkv writing librarys

Post by Woodstock » Tue Nov 24, 2020 7:21 pm

The "MKV writing libraries" that come with an operating system aren't going to have things like support for Dolby Vision, which is quite new. Maybe its an issue with obsolete MKV reading libraries?
MakeMKV Frequently Asked Questions
How to aid in finding the answer to your problem: Activating Debug Logging

dcoke22
Posts: 388
Joined: Wed Jul 22, 2020 11:25 pm

Re: update mkv writing librarys

Post by dcoke22 » Tue Nov 24, 2020 9:33 pm

Does the OP mean the data shown by MediaInfo?

Code: Select all

Writing application               : MakeMKV v1.15.3 darwin(x64-release)
Writing library                   : libmakemkv v1.15.3 (1.3.10/1.5.2) darwin(x64-release)
As near as I can tell, they track closely with the version of MakeMKV. But maybe things are different on Linux or Windows?

pipo233
Posts: 18
Joined: Sat Oct 17, 2020 6:14 pm

Re: update mkv writing librarys

Post by pipo233 » Wed Nov 25, 2020 3:34 pm

Writing application : MakeMKV v1.15.3 darwin(x64-release)
Writing library : libmakemkv v1.15.3 (1.3.10/1.5.2) darwin(x64-release)
jep i think that this represent the included versions that makemkv uses?
I'm using Linux by the way, that's why i posted this here

pipo233
Posts: 18
Joined: Sat Oct 17, 2020 6:14 pm

Re: update mkv writing librarys

Post by pipo233 » Wed Nov 25, 2020 3:41 pm

The main issue is that the file written by makemkv does not work while the version i created with mkvtoolnix of the same file does work.
That get me thinking about possibly older libs in makemkv?

In this screenshot of mediainfo, on the right side is my new created file, left the version written by makemkv
Attachments
Screenshot from 2020-11-24 15-22-32.png
Screenshot from 2020-11-24 15-22-32.png (111.15 KiB) Viewed 9440 times

pipo233
Posts: 18
Joined: Sat Oct 17, 2020 6:14 pm

Re: update mkv writing librarys

Post by pipo233 » Wed Nov 25, 2020 3:44 pm

it may be because the file written by makemkv has 24bit audio and the version written by mkvtoolnix has not?
the output of ffmpeg -i from both files states both have 24bit audio so i'm not sure what to believe..

dcoke22
Posts: 388
Joined: Wed Jul 22, 2020 11:25 pm

Re: update mkv writing librarys

Post by dcoke22 » Wed Nov 25, 2020 3:58 pm

One thing I notice is the data rate for both the audio and the video is different between the two. It looks like the one on the right, created by mkvtoolnix, has transcoded the file.

I don't know what version of MediaInfo you're using, but the the 20.09 version (https://mediaarea.net/MediaInfo/ChangeLog) has updates to understand the new way Dolby Vision is stored in mkv files.

Also, it seems you a're running MakeMKV version 1.15.2. 1.15.3 is the newest version, so it might be worth giving that a try.

pipo233
Posts: 18
Joined: Sat Oct 17, 2020 6:14 pm

Re: update mkv writing librarys

Post by pipo233 » Wed Nov 25, 2020 6:36 pm

As far as i know mkvtoolnix is a muxer not a transcoder? But sure i noticed that too, but it looks strange agree

I'm using mediainfo 20.08 on Manjaro, newer is not available jet.

I am using 1.15.3 but this file was made with a previous version of makemkv, but that might be something considering this in the changelog:
MakeMKV now can extract Dolby Vision metadata from elementary stream data and rebuild missing or invalid DV descriptors

Maby i re-rip the disk with latest version of makemkv and check if that improves things, thanks.

pipo233
Posts: 18
Joined: Sat Oct 17, 2020 6:14 pm

Re: update mkv writing librarys

Post by pipo233 » Wed Nov 25, 2020 7:38 pm

just made a new copy with makemkv 1.15.3, same results.

Writing application : MakeMKV v1.15.3 linux(x64-release)
Writing library : libmakemkv v1.15.3 (1.3.10/1.5.2) x86_64-pc-linux-gnu

So writing libs are the same i guess

Updated mediainfo to 20.09, same output, nothing changed

pipo233
Posts: 18
Joined: Sat Oct 17, 2020 6:14 pm

Re: update mkv writing librarys

Post by pipo233 » Wed Nov 25, 2020 7:57 pm

@mike Is it possible to update the libs to the latest versions?
Or could it be mkvmerge is also al older version? I don't know if that is used by makemkv

My problem only happens with TrueHD dolby atmos files made by makemkv, all other files made by makemkv works fine.

dcoke22
Posts: 388
Joined: Wed Jul 22, 2020 11:25 pm

Re: update mkv writing librarys

Post by dcoke22 » Wed Nov 25, 2020 9:43 pm

There has been some discussion elsewhere on this forum about weirdness seemingly related to TrueHD Atmos tracks.

viewtopic.php?f=8&t=21079&p=99556#p99467

In that thread, Mike has said the forthcoming 1.15.4 that has some relevant fixes.

pipo233
Posts: 18
Joined: Sat Oct 17, 2020 6:14 pm

Re: update mkv writing librarys

Post by pipo233 » Thu Nov 26, 2020 10:22 am

dcoke22 wrote:
Wed Nov 25, 2020 9:43 pm
There has been some discussion elsewhere on this forum about weirdness seemingly related to TrueHD Atmos tracks.

viewtopic.php?f=8&t=21079&p=99556#p99467

In that thread, Mike has said the forthcoming 1.15.4 that has some relevant fixes.
Thanks for the info, hope that this will fix it. For now i can fix it by using mkvtoolnix and save again but it is time consuming

Post Reply