Audio track not automatically selected on some BD

The place to discuss Mac OS X version of MakeMKV
Post Reply
johnnygoodface
Posts: 12
Joined: Sun Sep 15, 2013 12:30 am

Audio track not automatically selected on some BD

Post by johnnygoodface » Fri Dec 22, 2017 3:52 pm

Hi,

For the second time now, I realize, after finishing up the conversion with HandBrake that the audio track is no where to be found (thus no sound in the movie file)
When going back to MakeMKV, you clearly see that the program didn't checked any Audio tracks by default, like it normally does all the time.
(see attached)

Of course it's easy to check it myself, but I never had to do that before that.

Any reason that would explain that new behaviour

Thx
Johnny
Attachments
Screen Shot 2017-12-22 at 10.45.19 AM.png
Screen Shot 2017-12-22 at 10.45.19 AM.png (71.03 KiB) Viewed 3192 times

Woodstock
Posts: 5354
Joined: Sun Jul 24, 2011 11:21 pm

Re: Audio track not automatically selected on some BD

Post by Woodstock » Fri Dec 22, 2017 4:28 pm

If you are using Expert mode (Preferences->General), you can check the default selection rule on the Advanced tab. We need to see that rule, and whether or not you have selected a preferred language (Preferences->Language, Preferred language).
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

johnnygoodface
Posts: 12
Joined: Sun Sep 15, 2013 12:30 am

Re: Audio track not automatically selected on some BD

Post by johnnygoodface » Fri Dec 22, 2017 5:27 pm

Indeed I set it up to

Interface Language: Eng
Prefered language: Eng

but the problem was that only French was on the BD!
That might explain a few things! :)

Now I've set them to :

Interface Language: Eng
Prefered language: None

So for future French movies (and setup that way), should I expect MakeMKV will select the first default language, thus in this case French?

Woodstock
Posts: 5354
Joined: Sun Jul 24, 2011 11:21 pm

Re: Audio track not automatically selected on some BD

Post by Woodstock » Fri Dec 22, 2017 6:02 pm

Actually, MakeMKV will default to selecting all languages now.
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

johnnygoodface
Posts: 12
Joined: Sun Sep 15, 2013 12:30 am

Re: Audio track not automatically selected on some BD

Post by johnnygoodface » Fri Dec 22, 2017 6:03 pm

Great!
Thx :)

Post Reply