MakeMKV and High Sierra 10.13.4

The place to discuss Mac OS X version of MakeMKV
Post Reply
manmeetsdog
Posts: 1
Joined: Sun Apr 08, 2018 5:57 pm

MakeMKV and High Sierra 10.13.4

Post by manmeetsdog » Sun Apr 08, 2018 6:07 pm

Does anyone know if there is an issue with MakeMKV and High Sierra 10.13.4? I tried a new Blu Ray disc and got the following message:
Error 'Scsi error - ILLEGAL REQUEST:COPY PROTECTION KEY EXCHANGE FAILURE - AUTHENTICATION FAILURE' occurred while issuing SCSI command A30..00200740100720..0275A48C4B7A7DBC059A36661FDFD9940DF to device 'IoKit:IOBDServices:27e4efb2ee35ab47:HL-DT-ST BDDVDRW CA40N KD01

There was a continuous stream of this same message in the application's main window.

So I went back and tried a disc that I had ripped a while back and that I know worked, but am getting the same error message on that one as well now.

Might this indicate, perhaps, that there is a problem with the drive rather than the software?

MakeMKV has been working flawlessly for me up until recently. I am running Mac OS X 10.13.4.
Now everything seems to generate this same error?

FWIT, I tried a demo version of DVDFab 10 and got the same error with that too.

Any help would be appreciated.

Woodstock
Posts: 5354
Joined: Sun Jul 24, 2011 11:21 pm

Re: MakeMKV and High Sierra 10.13.4

Post by Woodstock » Sun Apr 08, 2018 7:12 pm

High Sierra is causing issues for a lot of programs, in different ways. Whether this is a bug in MakeMKV or a change of permissions in MacOS, we will have to wait for Mike...
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

Post Reply