Gatekeeper High Sierra 10.13.4 never freely allows MakeMKV

The place to discuss Mac OS X version of MakeMKV
Post Reply
nemike
Posts: 13
Joined: Thu Feb 13, 2014 9:17 pm

Gatekeeper High Sierra 10.13.4 never freely allows MakeMKV

Post by nemike » Mon May 21, 2018 10:03 pm

No matter what I do I can not get gatekeeper to freely allow MakeMKV. Instead every time I run it I get the dialog that it is a downloaded application and I have to click on the open button on the dialog for it to actually allow MakeMKV to run. Anyone know how to solve this? I've even tried spctl --master-disable and it still pops up the dialog.

I've tried the following:

1. spctl --master-disable
2. spctl --add --label "MyApps" /PATH/To/MakeMKV.app
a. spctl --enable --label "MyApps"
3. Select open from the context menu on the icon for MakeMKV

Help this is driving me crazy!

Thanks, Mike

PS Anyone super familiar with mac's that can tell me TRUELY how to completely turn off gatekeeper??

T'hain Esh Kelch
Posts: 47
Joined: Thu Apr 20, 2017 5:59 am

Re: Gatekeeper High Sierra 10.13.4 never freely allows MakeM

Post by T'hain Esh Kelch » Tue May 22, 2018 7:55 am

Right click the MakeMKV binary in Finder, and select Open, and then say yes in the next dialog. GateKeeper shouldn't annoy you from then on with MakeMKV, until you update it. (That's what I do)

To turn off Gatekeeper completely, use the same as your command #1, but run it with sudo:
sudo spctl --master-disable
Alhtough, I would recommend you keep it on. Using the solution I wrote at the top, you can easily circumvent Gatekeeper in those few cases where it is needed.

nemike
Posts: 13
Joined: Thu Feb 13, 2014 9:17 pm

Re: Gatekeeper High Sierra 10.13.4 never freely allows MakeM

Post by nemike » Tue May 22, 2018 4:48 pm

In my original post I said I tried that in step #3, it didn't work. And neither did trying to turn off gatekeeper with "sudo spctl --master-disable"

Mike

Post Reply