Drive not found in Make MKV

The place to discuss Mac OS X version of MakeMKV
Post Reply
Posts: 1
Joined: Thu Nov 15, 2018 2:08 pm

Drive not found in Make MKV

Post by jens123 » Thu Nov 15, 2018 2:17 pm


I used a LG external BD drive on my MacBook Pro for some time without any problems. Now after two month without use the drive isn't found by Make MKV. In OS X the drive and the disc is found without problems.

This week I did a clean set up of the MacBook and directly testet if the drive is found by Make MKV. This was successfull. But after installing all the software I usually use now the drive is not dectected from Make MKV anymore. I didn't use other software than before.

Does anyone have the same problem or anyone a solution how to solve this problem? I really don't know which of the software could be the problem.

Posts: 7369
Joined: Sun Jul 24, 2011 11:21 pm

Re: Drive not found in Make MKV

Post by Woodstock » Thu Nov 15, 2018 3:03 pm

Did you restart the computer after installing all the software?

The usual issue is that some software (sometimes the operating system itself!) takes control over the drive, and it no longer gets reported as an optical device when MakeMKV asks.
How to aid in finding the answer to your problem:

Posts: 1
Joined: Fri Dec 07, 2018 6:24 pm

Re: Drive not found in Make MKV

Post by Videocassette88 » Fri Dec 07, 2018 6:31 pm

Sometimes unplugging the drive and plugging it back into the computer resolves this problem. I've had this myself last night and this solved it

Posts: 4
Joined: Wed Jan 17, 2018 5:38 am

Re: Drive not found in Make MKV

Post by mbnwa » Tue Mar 12, 2019 7:36 pm

I know this is an old(er) thread, however I have recently started to have this same issue with my MBP

I get the following error in MakeMKV
MakeMKV v1.14.3 darwin(x64-release) started
The program can't find any usable optical drives.

however in System Profile I see the following
External Blu-ray Writer:

Product ID: 0x2571
Vendor ID: 0x152e (HLDS (Hitachi-LG Data Storage, Inc.))
Version: 1.00
Serial Number: HITACHLGDA00000000E
Speed: Up to 5 Gb/sec
Manufacturer: HLDS Inc
Location ID: 0x02200000 / 2
Current Available (mA): 900
Current Required (mA): 96
Extra Operating Current (mA): 0
Capacity: 65.33 GB (65,325,432,832 bytes)
Removable Media: Yes
BSD Name: disk4
Logical Unit: 0
Partition Map Type: Unknown
USB Interface: 0

Posts: 4
Joined: Sat Mar 23, 2019 10:44 pm

Re: Drive not found in Make MKV

Post by PaulM2019 » Sat Mar 23, 2019 10:53 pm

For what it's worth, I've started having the exact same issue. MakeMKV has always seen the BD drive since I plugged it in about 6 months ago (a highly recommended LG unit), and worked flawlessly. Suddenly, the OS sees the BD drive (it never has), and now it's not available as an optical drive for MakeMKV any more. It can open as a hard drive, but that too seems to present challenges.

Mac Pro 5,1; macOS 10.13.6

Posts: 2
Joined: Tue Mar 26, 2019 4:10 pm

Re: Drive not found in Make MKV

Post by stemll » Tue Mar 26, 2019 4:19 pm

On my old 2012 MBP it sometimes doesn't see the drive if I insert the disc before starting MakeMKV. Eject the disc, restart MakeMKV, reinsert disc and it works. May be the same with external drives on newer Macs?

Posts: 4
Joined: Sat Mar 23, 2019 10:44 pm

Re: Drive not found in Make MKV

Post by PaulM2019 » Sun Mar 31, 2019 3:34 pm

Yeah, mine's a 2012 mid-year unit (off topic: which can't support AirDrop - wtf?)

Tried putting disks into the external BD both before and after starting MKV; I've reinstalled MKV; I've restarted the machine, clearing the PROM and SCM. Doesn't I've tried using MKV on the "hard drive" it sees containing the Blu-ray disk. No joy.

I've I've refreshed the O/S, reinstalled MKV. It only sees the originally installed DVD drive.

I put the drive on a different, newer MBP (2017). MKV worked on the first try (recognizing and ripping a BD movie), so it's not a bad drive.

Posts: 4
Joined: Sat Mar 23, 2019 10:44 pm

Re: Drive not found in Make MKV - SOLVED

Post by PaulM2019 » Thu May 09, 2019 12:40 am

I finally solved this tonight. I found it by chasing down some different web discussions: since the drive was visible to OSX, and could mount BD disks with no issue, but was TOTALLY UNAVAILABLE to MakeMKV. I ran SystemReport, then after verifying (for the eleventeenth time) that the physical machine could see the physical drive, looked at Software. I ran down through the items, and hit StartupItems. There was software I didn't recognize: Nalpeiron. Googling, I found it had a copy protection product, ProTec6.

Firing up the mighty Finder, lo and behold, there was some piece of copy protection software, ProTec6, which had gotten installed by something I used (don't know what yet), into the /mybootdrive/Library/StartupItems folder.

Nuked software -- reboot -- JOY UNBOUNDED!! Ripping BD as I write this.

Posts: 5
Joined: Mon Apr 01, 2019 2:31 am

Re: Drive not found in Make MKV

Post by stigcrafter » Sat Aug 03, 2019 4:23 am

So I've grappled with this issue too, and it seems like it is different from case to case, but here's the issue that I ran into: The sata to usb adapter I was using didn't allow make mkv to find the drive, so I replaced it a different one and it worked fine. Hopefully this helps anyone still troubleshooting the issue.


Post Reply