Rainbow in some spots

MKV playback, recompression, remuxing, codec packs, players, howtos, etc.
Post Reply
Posts: 1
Joined: Wed Aug 22, 2018 12:46 am

Rainbow in some spots

Post by marly » Wed Aug 22, 2018 1:20 am

I’ve been backing up a few of my Blu Ray Discs and in a few of them I’m getting a flash of a “rainbow” on my screen between scenes. It seems to happen when most action packed than not, as in the screens are fast moving. I’m not sure if it’s in my rip, or if it’s my computer, but I get it on a fresh install of Windows 10 using the built-in player or VLC media player. I’ve attached a picture of what it looks like.
2018-08-21_20-19-15.png (464.28 KiB) Viewed 1641 times

Posts: 6787
Joined: Sun Jul 24, 2011 11:21 pm

Re: Rainbow in some spots

Post by Woodstock » Wed Aug 22, 2018 2:21 pm

Are you using "Backup" or "Open and save as MKV"?

With Backup, when you play a title by playlist, it is being reconstructed from the M2TS as needed to match the play list. As an MKV, this is done during the rip, which usually smooths the transition between sections.
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

Posts: 2
Joined: Wed Jun 23, 2010 7:31 pm

Re: Rainbow in some spots

Post by Malnilion » Sun Sep 02, 2018 1:49 am

There is definitely something going on when muxing either directly from the disc or from a backup. I'm seeing other posts in this subforum with similar issues. I have absolutely no issues playing backups, but then when I go to convert it and let MakeMKV remux it, random pixelation artifacts and rainbow stuff (like what the OP is describing) present themselves to me.

I have no idea whether this is a computer hardware-related incompatibility with the MakeMKV software or what, but since I've discovered the issue I've at least been able to start remuxing with other software (which of course is a little bit of a pain since it's so much easier to just do it all in MakeMKV). It took me a long time trying to isolate the issue for a couple reasons:

1) I hadn't used the software in a couple months since my computer was out of commission for a rebuild, so no idea what version of MakeMKV I had been on and I'd not been having issues previously. But I knew now I was having issues with both 1.12.3 and 1.12.2.
2) I initially thought something about my new hardware config was busted. I tested ripping/muxing to my HDD storage pool, bad. Ripping to my SSD, bad. Thought maybe something was up with my BD drive, tested it through other SATA ports, tested with both Marvell controller drivers and standard Windows AHCI drivers for my SATA controller. Tested both 3.01 and 3.02 firmware. Always artifacts. Throughout this whole ordeal, trying to remux through MakeMKV occasionally gives me a Fatal Error and I have to restart. Occasionally my rips were cleaner than other times, but there would always be pixelation somewhere. Nothing was making sense.

So finally I just tried making a backup. And lo and behold playing it in MPC-BE shows no issues. Remuxed the backed up disc folder using other software (in this case I just tried DVDFab because I had it) and had no pixelation artifacts or rainbows.

So now it just seems to me we need to look at what specifically is happening in the muxing process that's messing everything up.

I've been having this issue with the following hardware/software:
  • AMD Threadripper 1950X
  • AsRock Taichi x399
  • Ballistix Tactical Tracer RGB DDR4 Ram 2x16GB
  • Asus BW-16D1HT
  • Various UHD Discs, seemed to happen to a greater or lesser extent with all of them
  • Western Digital WDS500G1B0A
  • Windows 10 1803 (17134.228)
  • MakeMKV 1.12.2/1.12.3
I'm going to try to get hold of Mike and point him to this thread and hopefully someone can help me figure out what logs, if any, we need to collect in order to get to the bottom of this issue. It didn't look like anything obviously helpful was output when I enabled logging to text file in the settings.


Posts: 2
Joined: Wed Jun 23, 2010 7:31 pm

Re: Rainbow in some spots

Post by Malnilion » Mon Sep 10, 2018 11:39 pm

Sorry, I know I'm hijacking your post, but I've been doing some more testing on my end. I attempted testing out mkvtoolnix using the 64-bit version and I was getting very similar results to makemkv. I decided to try out the 32-bit version of mkvtoolnix and I don't appear to be getting any sort of corruption. This leads me to wonder 2 more things: 1) is makemkv built on top of mkvtoolnix and 2) what's going on with the 64-bit version of mkvtoolnix with my setup? If the answer to #1 is yes and makemkv is built on mkvtoolnix, it looks like I need to take this issue upstream. But in the meantime I would be curious if it's possible to force makemkv to use 32bit muxing on 64bit arch.

Post Reply