UHD Blade Runner final cut HUGE Frame DROPS. HELP!

MKV playback, recompression, remuxing, codec packs, players, howtos, etc.
Post Reply
loganm187
Posts: 17
Joined: Thu Jul 26, 2018 11:40 pm

UHD Blade Runner final cut HUGE Frame DROPS. HELP!

Post by loganm187 » Tue Nov 13, 2018 10:40 pm

I currently have 3 copies of the Blade Runner Final cut UHD, The newest version of MAkeMKV. I have tried MPC-HC with madvr/reclock (My go to player) and potplayer and vlc. Same results with all of them. I have played countless Blu ray and UHD rips from MAKEMKV without a slightest hitch, but I can not figure out what is happening with this and can't find anyone mentioning this

File plays perfectly fine until the blond replicant smashes through the window after being shot I get 100's of dropped frames. They are not identical each time either, but always occurs during that segment which made me think it was not the rip, but the whole thing just falls apart. We just played big labowski and Dark Crystal UHD rips with zero issues. My PC is totally up to spec. GTX1080TI and Ryzen 2700x, files running of locaL 256GB ssd, 64 GB DDR4. CPU and GPU are at moderate usage and not being pushed. I need to figure this out for friday as we have a showing of this film at our Theater. Would rather not have to switch to bluray playback after trailers.

Any known issues with this? Like I said I have 3 copies of this movie with me currently. All rips the same.

Woodstock
Posts: 6097
Joined: Sun Jul 24, 2011 11:21 pm

Re: UHD Blade Runner final cut HUGE Frame DROPS. HELP!

Post by Woodstock » Tue Nov 13, 2018 10:48 pm

A test would be to run the file through handbrake. Using one of their standard "fast" presets to 1080p, encoding with x264, will let you see if the actual UHD MKV file is damaged or has dropped frames. Handbrake's decoder doesn't have to try reading the file at "real time" speeds, so it can analyze the file more completely.

My first suspicion is that the playback cannot process the bit rate while decoding h.265 encoding. h.265 takes a LOT more CPU power to decode than h.264.

If the 1080p handbrake encode does not have dropped frames, recoding the film as h.264 may "fix" the problem in the short run, because hardware decoding of the h.264 stream is faster than software decoding of h.265.
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

loganm187
Posts: 17
Joined: Thu Jul 26, 2018 11:40 pm

Re: UHD Blade Runner final cut HUGE Frame DROPS. HELP!

Post by loganm187 » Tue Nov 13, 2018 11:16 pm

I would agree with you, but I play UHD files much bigger than this one weekly. My PC is very capable of running these files. The GTX 1080ti and 2700x have no issues with H265 Unless blade runner 4k has some kinda INSANE never before implemented H265 MEGA bit rate. Something is suspect.

I will run it through handbrake as a test though. Thanks.

loganm187
Posts: 17
Joined: Thu Jul 26, 2018 11:40 pm

Re: UHD Blade Runner final cut HUGE Frame DROPS. HELP!

Post by loganm187 » Tue Nov 13, 2018 11:44 pm

CONVERTED to MP4 and frame drops in the exact same spot still. So it's the file. All 3 files from 3 different UHD discs...

loganm187
Posts: 17
Joined: Thu Jul 26, 2018 11:40 pm

Re: UHD Blade Runner final cut HUGE Frame DROPS. HELP!

Post by loganm187 » Wed Nov 14, 2018 5:25 am

UPDATE. Changing cpu queue length to 16 from 8 fixed the issue entirely. Apparently that was too low to handle the bit rate in blade runner in certain spots. you can delete this thread.

Woodstock
Posts: 6097
Joined: Sun Jul 24, 2011 11:21 pm

Re: UHD Blade Runner final cut HUGE Frame DROPS. HELP!

Post by Woodstock » Wed Nov 14, 2018 1:16 pm

Why delete a topic that contains useful information? I know I wouldn't have thought to tweak the CPU parameters...
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

loganm187
Posts: 17
Joined: Thu Jul 26, 2018 11:40 pm

Re: UHD Blade Runner final cut HUGE Frame DROPS. HELP!

Post by loganm187 » Wed Nov 14, 2018 6:20 pm

Woodstock wrote:
Wed Nov 14, 2018 1:16 pm
Why delete a topic that contains useful information? I know I wouldn't have thought to tweak the CPU parameters...
Yea, you're right PLUS get this. The movie now gets through the part i mentioned and plays perfect until 1:27:15 it totally shits the bed again with like 200 dropped frames!!! It's just HArrison ford in a damn car too...nothing is happening that would warrant a super high bit rate (Although I think UHD's are CONSTANT bit rate which makes this even more confusing)

Can anyone chime in on this? Changing the CPU queue obviously helped something as it no longer drops any frames AT ALL until the time mentioned above.

Like I said does anyone else have this MKV and can test for me? Our theater just showed Halloween and Big labowski and Dark Crystal 4k UHD rips and never had a single issue (They still play fine) and those files are actually much bigger than the blade runner.

This is maddening.

loganm187
Posts: 17
Joined: Thu Jul 26, 2018 11:40 pm

Re: UHD Blade Runner final cut HUGE Frame DROPS. HELP!

Post by loganm187 » Thu Nov 15, 2018 3:53 pm

FIXXXXXXXXXED!!!!

For anyone using MPC-HC with LAVS listen up.

I realized I was not getting the "H/W" sign when opening H265 HVEC files and thought that has to be the using. I have been playing these things with just software!!!

I disabled my external video lav and applied the internal video LAV with the EXACT same settings and then BAM!!! I got HW support on the UHD rips! and no drops on blade runner!!!!

So apparently there is a hardware issue with external video lav on MPC-HC!!

wippet
Posts: 11
Joined: Sun Nov 18, 2018 11:36 pm

Re: UHD Blade Runner final cut HUGE Frame DROPS. HELP!

Post by wippet » Thu Nov 29, 2018 1:54 pm

loganm187 wrote:
Thu Nov 15, 2018 3:53 pm
FIXXXXXXXXXED!!!!

I disabled my external video lav and applied the internal video LAV with the EXACT same settings and then BAM!!! I got HW support on the UHD rips! and no drops on blade runner!!!!
Would you mind explaining a little more on what you did? I'm using MPC-BE and Shark007 codec pack, but I'm getting a lot of stuttering (specifically the intro panning scene in Coco). I've played around with MPC-BE and Shark007 codec settings but still haven't been able to resolve the problem. Would be appreciated!

wippet
Posts: 11
Joined: Sun Nov 18, 2018 11:36 pm

Re: UHD Blade Runner final cut HUGE Frame DROPS. HELP!

Post by wippet » Sat Dec 15, 2018 11:34 pm

Disregard. Now working perfect with MPC-BE & MadVR following this video https://www.youtube.com/watch?v=aGfffqS46pw&t=26s

Post Reply