MKV files frequently end early

MKV playback, recompression, remuxing, codec packs, players, howtos, etc.
Post Reply
doomedtx
Posts: 11
Joined: Thu Dec 29, 2011 4:59 pm
Location: Arkansas, USA

MKV files frequently end early

Post by doomedtx » Mon Dec 30, 2013 3:39 am

As the title says, my MKVs seems to be susceptible to minor corruption that causes an early EOF as reported by VLC, causing the movie to end early in XBMC. The only way to get past these parts is to skip past them or re-mux the movie. I think I know where the answer lies, but just in case I'm asking in the forums related to all the parts of my workflow.

Right now I use MakeMKV for Windows to copy all my Blu Ray and DVD titles to disk, I transfer completed movies to a Thecus N5200XXX NAS with a RAID5 array. Although the NAS is supposed to provide protected storage, I frequently find movies (that worked before) ending early. If I play them in VLC, the messages report end of file at one or more points in the movie that are prior to the actual end. Sometimes I can skip past the bad part and keep watching the movie, often finding another early EOF. I frequently have to repeat the MKV process with the original disc to get a working file.

It seems like my only choices are to re-mux the movie using mkvtoolnix or to re-copy it using MakeMKV. I saw an MKV repair program today (Meteorite), but it was dated 2009 and segfaulted as soon as I dragged a title to it.

I'm just curious if anyone has experienced this problem and found a way to produce better MKVs that don't fail as easily.

Thanks.

Chetwood
Posts: 733
Joined: Mon Aug 30, 2010 9:16 am

Re: MKV files frequently end early

Post by Chetwood » Mon Dec 30, 2013 7:25 am

No early ending MKVs EVER, not when playing from NAS or USB.
MultiMakeMKV: MakeMKV batch processing (Win)
MultiShrink: DVD Shrink batch processing
Offizieller Uebersetzer von DVD Shrink deutsch

doomedtx
Posts: 11
Joined: Thu Dec 29, 2011 4:59 pm
Location: Arkansas, USA

Re: MKV files frequently end early

Post by doomedtx » Mon Dec 30, 2013 3:34 pm

Is there any way to troubleshoot this besides buying a new NAS and seeing if it works better? Any point in comparing the good and bad versions of a file to see where it went bad? I'm glad to hear it works perfectly for you. The amount of errors is making the wife approval factor decline for me.

Woodstock
Posts: 5372
Joined: Sun Jul 24, 2011 11:21 pm

Re: MKV files frequently end early

Post by Woodstock » Mon Dec 30, 2013 3:34 pm

Would the file size on the titles that end early be right around 4GB?

Like Chetwood, I have not had files like you're describing, as long as MakeMKV said it completed the rip.
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

doomedtx
Posts: 11
Joined: Thu Dec 29, 2011 4:59 pm
Location: Arkansas, USA

Re: MKV files frequently end early

Post by doomedtx » Mon Dec 30, 2013 3:39 pm

No, the RAID is formatted ext4 so AFAIK 4GB files aren't the problem. The files are anywhere from 900MB to 25+ GB. I'm pretty sure the problem lies with my Thecus NAS and its inability to preserve data. The fact that a title will work once and fail later indicates the data is becoming corrupt somehow. I've posted a question on their forum to see if there's any way to troubleshoot there.

Thanks again for the replies.

Chetwood
Posts: 733
Joined: Mon Aug 30, 2010 9:16 am

Re: MKV files frequently end early

Post by Chetwood » Mon Dec 30, 2013 3:52 pm

Rip to local disc and create an MD5 hash, copy media and hash over to your NAS and see if gets corrupted.
MultiMakeMKV: MakeMKV batch processing (Win)
MultiShrink: DVD Shrink batch processing
Offizieller Uebersetzer von DVD Shrink deutsch

doomedtx
Posts: 11
Joined: Thu Dec 29, 2011 4:59 pm
Location: Arkansas, USA

Re: MKV files frequently end early

Post by doomedtx » Mon Dec 30, 2013 4:09 pm

Chetwood wrote:Rip to local disc and create an MD5 hash, copy media and hash over to your NAS and see if gets corrupted.
That's a good idea, thanks. I'll do that and see what turns up.

mulox
Posts: 7
Joined: Tue Jan 07, 2014 2:24 pm

Re: MKV files frequently end early

Post by mulox » Tue Jan 07, 2014 2:49 pm

So what did you find out? I have a similar problem, but not with makemkv. I have been ripping blu-rays using AnyDVD HD and had an eof issue with the resulting iso. Have not tried it with makemkv yet, as I am just started the free trial.

doomedtx
Posts: 11
Joined: Thu Dec 29, 2011 4:59 pm
Location: Arkansas, USA

Re: MKV files frequently end early

Post by doomedtx » Thu Jan 09, 2014 5:18 pm

I haven't had a chance to look at this until today. The most recent file with a problem is reporting something different in VLC:

Code: Select all

mkv warning: Dummy element found 7465922547... skipping it
mkv error: Dummy Element at unexpected position... corrupted file?
mkv error: Dummy element too large or misplaced at 7465922667... skipping to next upper element
main warning: playback way too early (-687092): playing silence
VLC is able to handle this error with some on-screen glitching, but XBMC doesn't. It jumps to near the end of the movie at this point if I don't skip past it.

I'm going to re-burn it from disc and generate an MD5 hash to see if/when the file gets corrupted on my NAS. Guess I'll start shopping for a new NAS as well :(

neosenate
Posts: 1
Joined: Sat Dec 09, 2017 8:21 pm

Re: MKV files frequently end early

Post by neosenate » Sat Dec 09, 2017 8:28 pm

Hi,

I know this is an old thread but I've recently (over the past 2-3 months) been encountering the same problem. Process is to rip bluray to external harddrive using makemkv and then play the mkv through VLC.

Results in EOF exception. The behaviour is not unique to this file.

Code: Select all

core debug: VoutDisplayEvent 'mouse button' 0 t=8
core debug: VoutDisplayEvent 'mouse button' 0 t=9
core debug: auto hiding mouse cursor
core debug: picture might be displayed late (missing 3 ms)
core debug: auto hiding mouse cursor
core debug: picture might be displayed late (missing 5 ms)
core debug: picture might be displayed late (missing 2 ms)
core debug: picture might be displayed late (missing 1 ms)
core debug: picture might be displayed late (missing 7 ms)
core debug: picture might be displayed late (missing 17 ms)
mkv error: Dummy element too large or misplaced at 26632106019... skipping to next upper element
mkv error: Dummy element too large or misplaced at 26632138117... skipping to next upper element
mkv error: This element is outside its known parent... upping level
mkv debug: unknown (PN7libebml11EbmlElementE)
...
...
...
mkv debug: unknown (PN7libebml11EbmlElementE)
mkv warning: MKV/Ebml Parser: m_el[mi_level] == NULL 
mkv warning: EOF
mkv warning: cannot get block EOF?
core debug: EOF reached
core debug: waiting decoder fifos to empty
core debug: waiting decoder fifos to empty
core debug: waiting decoder fifos to empty
core debug: waiting decoder fifos to empty
core debug: waiting decoder fifos to empty
core debug: picture might be displayed late (missing 16 ms)
core debug: waiting decoder fifos to empty
core debug: waiting decoder fifos to empty
core debug: waiting decoder fifos to empty
core debug: waiting decoder fifos to empty
core debug: waiting decoder fifos to empty
core debug: finished input
core debug: removing module "avcodec"
avcodec debug: ffmpeg codec (H264 - MPEG-4 AVC (part 10)) stopped
core debug: killing decoder fourcc `h264', 0 PES in FIFO
core debug: saving a free vout
core debug: reusing provided vout
qt4 debug: Qt: Fullscreen state changed
core debug: removing module "dts"
core debug: killing decoder fourcc `dts ', 0 PES in FIFO
core debug: removing module "samplerate"
core debug: removing module "dtstofloat32"
core debug: removing module "scaletempo"
core debug: removing module "simple_channel_mixer"
directsound debug: closing audio device
core debug: removing module "float_mixer"
core debug: keeping audio output
core debug: removing module "avcodec"
avcodec debug: ffmpeg codec (BD subtitles) stopped
core debug: killing decoder fourcc `bdpg', 0 PES in FIFO
core debug: removing module "mkv"
core debug: Program doesn't contain anymore ES
mkv debug: Stopping the UI Hook
core debug: removing module "record"
core debug: removing module "filesystem"
core debug: dead input
core debug: changing item without a request (current 0/1)
core debug: nothing to play
core debug: destroying useless vout
core debug: removing module "direct3d"
direct3d debug: Direct3D scene released successfully
direct3d debug: Win32 Vout EventThread terminating
direct3d debug: Win32VoutCloseWindow
direct3d debug: WinProc WM_DESTROY
qt4 debug: releasing video...
qt4 debug: IM: Deleting the input
qt4 debug: Video is not needed anymore
core debug: removing module "freetype"
core debug: removing module "yuvp"
core debug: removing module "swscale"
Has anyone been able to find a fix to this issue?

Post Reply