mkv 'd' flag

Please post here for issues related to DVD discs
Post Reply
renfield
Posts: 13
Joined: Fri May 10, 2019 2:07 am

mkv 'd' flag

Post by renfield » Fri Jul 12, 2019 7:00 pm

Mac version.

When saving DVD to mkv, I've found that the first subtitle track gets the mkv 'd' flag set, which becomes default flag in the mkv. This causes the subtitles to be shown by default with vlc. I didn't test other players.

It might not be strictly the first track, it might be that the first track happens to be english and that is my favlang.

No, I am not referring to forced subtitles, which I expect to get the forced flag and maybe also default flag to be set.

This does not happen for BD.

Is this a known problem? Is there a workaround within makemkv that doesn't involve interactively clearing the flag?

Post Reply