Broken audio on Blu-Rays with AACS v57.

Please post here for issues related to Blu-ray discs
Post Reply
rubricalelk647
Posts: 5
Joined: Wed Mar 16, 2016 4:33 pm

Broken audio on Blu-Rays with AACS v57.

Post by rubricalelk647 » Wed Mar 16, 2016 4:38 pm

The two Blu-Ray discs I am having trouble with are as follows:

- Mad Max: Fury Road
- The Man From U.N.C.L.E.

I am running program version 1.9.9 on Windows 7 x64-bit.

When I try to rip these two files, the video portion rips perfectly, but the audio is completely broken. I will get odd sounds that spike, and then the audio goes silent, and then another audio spike, then silent, etc.

I have only had a problem with these two discs. Anything I should try? They are both Warner Bros. Blu-Rays with AACS v57.

matt198t
Posts: 82
Joined: Mon Jun 24, 2013 1:39 pm

Re: Broken audio on Blu-Rays with AACS v57.

Post by matt198t » Wed Mar 16, 2016 6:08 pm

What media player are you using to play these files?

Which audio codec did you select?

Any movies which I rip that use Dolby TrueHD 7.1 do what you describe when played through my standard default installation of VLC (ie no additional codecs installed). Dolby TrueHD 5.1 anecdotally play fine.

rubricalelk647
Posts: 5
Joined: Wed Mar 16, 2016 4:33 pm

Re: Broken audio on Blu-Rays with AACS v57.

Post by rubricalelk647 » Thu Mar 17, 2016 4:34 pm

matt198t wrote:What media player are you using to play these files?

Which audio codec did you select?

Any movies which I rip that use Dolby TrueHD 7.1 do what you describe when played through my standard default installation of VLC (ie no additional codecs installed). Dolby TrueHD 5.1 anecdotally play fine.
Okay... Well. That's exactly what I was trying to do. 7.1 sound in a vanilla install of VLC Media Player. Would my Blu-Ray movies have a 5.1 option I could rip instead? or is there a workaround I could use with VLC?

matt198t
Posts: 82
Joined: Mon Jun 24, 2013 1:39 pm

Re: Broken audio on Blu-Rays with AACS v57.

Post by matt198t » Thu Mar 17, 2016 4:55 pm

rubricalelk647 wrote:
matt198t wrote:What media player are you using to play these files?

Which audio codec did you select?

Any movies which I rip that use Dolby TrueHD 7.1 do what you describe when played through my standard default installation of VLC (ie no additional codecs installed). Dolby TrueHD 5.1 anecdotally play fine.
Okay... Well. That's exactly what I was trying to do. 7.1 sound in a vanilla install of VLC Media Player. Would my Blu-Ray movies have a 5.1 option I could rip instead? or is there a workaround I could use with VLC?
I've not looked into it. I only use VLC to identify forced subtitles. I use Kodi as my media player and 7.1 Dolby TrueHD play fine.

rubricalelk647
Posts: 5
Joined: Wed Mar 16, 2016 4:33 pm

Re: Broken audio on Blu-Rays with AACS v57.

Post by rubricalelk647 » Thu Mar 17, 2016 5:01 pm

matt198t wrote:
rubricalelk647 wrote:
matt198t wrote:What media player are you using to play these files?

Which audio codec did you select?

Any movies which I rip that use Dolby TrueHD 7.1 do what you describe when played through my standard default installation of VLC (ie no additional codecs installed). Dolby TrueHD 5.1 anecdotally play fine.
Okay... Well. That's exactly what I was trying to do. 7.1 sound in a vanilla install of VLC Media Player. Would my Blu-Ray movies have a 5.1 option I could rip instead? or is there a workaround I could use with VLC?
I've not looked into it. I only use VLC to identify forced subtitles. I use Kodi as my media player and 7.1 Dolby TrueHD play fine.
I'm sure there's other workarounds; but Kodi looks fantastic. I'll give it a shot. Thanks!

angelgraves13
Posts: 91
Joined: Thu Jun 06, 2013 9:36 pm

Re: Broken audio on Blu-Rays with AACS v57.

Post by angelgraves13 » Thu Mar 24, 2016 6:18 pm

MPC HC or BE is a much better player than VLC.

rubricalelk647
Posts: 5
Joined: Wed Mar 16, 2016 4:33 pm

Re: Broken audio on Blu-Rays with AACS v57.

Post by rubricalelk647 » Thu Mar 24, 2016 6:35 pm

angelgraves13 wrote:MPC HC or BE is a much better player than VLC.
I was disappointed in Kodi (XBMC) because it isn't a lightweight program by any means. I switched to MPC-HC about a week ago, and my movie rips already play way better than they did in VLC.

Thank you for your suggestion. :)

Krawk
Posts: 170
Joined: Thu Jul 02, 2015 12:10 am

Re: Broken audio on Blu-Rays with AACS v57.

Post by Krawk » Mon May 02, 2016 5:14 pm

Successfully ripped Harbinger Down (German Import) which uses AACS v57. I ripped only the DTS-HD MA track for audio and not the lesser core audios.
I use MPC HC and have the K-Lite Pack installed, plays back as it should. I suspect AACS 57 has nothing to do with the issues you're seeing.

Post Reply