Can't rip Kingsman: The Secret Service

Please post here for issues related to Blu-ray discs
Post Reply
TheMemes
Posts: 3
Joined: Thu Sep 28, 2017 4:47 pm

Can't rip Kingsman: The Secret Service

Post by TheMemes » Thu Sep 28, 2017 5:04 pm

MakeMKV absolutely refuses to rip this disc. I would check if other discs are similarly unrippable, but this is the only one I've got at the moment.
Here's a bunch of information and the debug log:
Drive Information
OS device name: E:
Current profile: BD-ROM
Manufacturer: TSSTcorp
Product: BDDVDW SE-506BB
Revision: TS00
Serial number: R9306GWD2003V2
Bus encryption flags: 1F
Highest AACS version: 58

Disc Information
Label: Kingsman - The Secret Service
Timestamp: 2015-04-20 11:45:50
Data capacity: 44.41 Gb
Disc type: BD-ROM
Number of layers: 2
Channel bit length: 74,5 nm (25.0 GB max. per layer)
Bus encryption flags: 80

Code: Select all

MakeMKV v1.10.7 win(x64-release) started
Debug logging enabled, log will be saved as C:\Users\username/MakeMKV_log.txt
Backing up disc into folder "D:/Video/backup/Kingsman - The Secret Service"
DEBUG: Code 3221225629 at __3PiwfHcXV.eS,('h:213131686
DEBUG: Code 3221225629 at __3PiwfHcXV.eS,('h:29393930
Error 'OS error - STATUS_DEVICE_NOT_CONNECTED' occurred while reading 'BD-RE TSSTcorp BDDVDW SE-506BB TS00' at offset '655360'
LIBMKV_TRACE: UDF mount: disc not properly formatted or damaged disc (rootdirs failing)
DEBUG: Code 3221225664 at __3PiwfHcXV.eS,('h:213131686
DEBUG: Code 3221225664 at __3PiwfHcXV.eS,('h:29393930
Error 'OS error - This device does not exist' occurred while reading 'BD-RE TSSTcorp BDDVDW SE-506BB TS00' at offset '32768'
DEBUG: Code 0 at }G!ig~l;7kcBz+X}8ox:213129777
DEBUG: Code 0 at "HDl:v;1w])uzw/XDzU1:29396759
Backup failed
DEBUG: Code 3221225486 at 's+Ay19T1\mWh,AL:213134676
DEBUG: Code 3221225486 at 's+Ay19T1\mWh,AL:213134676
(The last two lines keep repeating)
At first glance, I'd say my drive's busted, but I tried manually copying the disc's contents to my hard drive to open those in MakeMKV, and that did work.
The copying part did, at least, the ripping part didn't.
Here's the debug log:

Code: Select all

MakeMKV v1.10.7 win(x64-release) started
Debug logging enabled, log will be saved as C:\Users\username/MakeMKV_log.txt
Opening files on harddrive at H:/Bluray-Rips/Kingsman
The volume key is unknown for this disc - video can't be decrypted
DEBUG: Code 0 at |ZK_arA)zXt>w*x):29396046
DEBUG: Code 0 at |ZK_arA)zXt>w*x):213134009
Failed to open disc
I have a fairly recent KEYDB.cfg at C:\Users\username\.MakeMKV\KEYDB.cfg with five instances of "Kingsman: The Secret Service" inside it.
Did I miss some option or why isn't MakeMKV using that file? Or am I missing something else entirely?

Woodstock
Posts: 5365
Joined: Sun Jul 24, 2011 11:21 pm

Re: Can't rip Kingsman: The Secret Service

Post by Woodstock » Thu Sep 28, 2017 6:27 pm

Error 'OS error - STATUS_DEVICE_NOT_CONNECTED' occurred while reading 'BD-RE TSSTcorp BDDVDW SE-506BB TS00' at offset '655360'
Something is causing the drive to disconnect from the computer.

Is that happening ONLY for this disk, or for other disks as well? Have you tried unplugging the drive, and plugging it back in, to reset the operating system's interface with it?
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

TheMemes
Posts: 3
Joined: Thu Sep 28, 2017 4:47 pm

Re: Can't rip Kingsman: The Secret Service

Post by TheMemes » Thu Sep 28, 2017 7:47 pm

I just connected the same drive with the same BD in it to my Mac using the same USB cable and it's currently ripping the movie, no problem.
I have no idea why it wouldn't work on my Windows PC. I checked the USB ports and they appear to be working fine, it's just that MakeMKV gets the STATUS_DEVICE_NOT_CONNECTED error. Weird.

Edit: Oh, I did all sorts of troubleshooting steps, including un- and replugging the drive, trying different USB ports and wedging the drive between heavy books in case it was a loose connection.

Woodstock
Posts: 5365
Joined: Sun Jul 24, 2011 11:21 pm

Re: Can't rip Kingsman: The Secret Service

Post by Woodstock » Thu Sep 28, 2017 8:47 pm

There is an issue with a lot of USB-powered drives that will reset if you spin them too fast without adequate power available. But that would have to be pretty bad for it to disconnect as early as your log snippet shows. The fix for that issue is to make sure that the drive is plugged into a fully-powered USB port, rather than a hub.

If the drive is plugged into a laptop, making sure that the charger is plugged in can help, if it is a power issue.
How to aid in finding the answer to your problem: https://www.makemkv.com/faq/item/8

TheMemes
Posts: 3
Joined: Thu Sep 28, 2017 4:47 pm

Re: Can't rip Kingsman: The Secret Service

Post by TheMemes » Thu Sep 28, 2017 9:36 pm

Unless something is really wrong with my PC, the USB ports I used should qualify as fully-powered.
I'll take a look at it tomorrow. For now, I'll just keep using the Mac. Thanks for your help though!

MagmaiKH
Posts: 8
Joined: Sun Sep 24, 2017 9:57 am

Re: Can't rip Kingsman: The Secret Service

Post by MagmaiKH » Fri Sep 29, 2017 1:00 am

A USB 2.0/3.0 port only delivers 500/900 mA (@ 5V) and if you over-current the port the IC will emergency disconnect it (to prevent permanent damage or potentially a fire).
Windows will cycle the port to try to bring it back so by the time you check it in Explorer or something it will be back online.
I have a keyboard that has a short in it ...

Post Reply