Page 1 of 1

Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB'

Posted: Mon Mar 16, 2020 4:15 pm
by imfergus
hello all.

i pulled a drive from an old blu-ray player so i could try and rip some blu-rays gifted by someone.

however, makemkv is throwing me errors (as per thread title):

Code: Select all

Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB' occurred while issuing SCSI command A30..0020..03F to device 'SPTI:\Device\CdRom0'
Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB' occurred while issuing SCSI command A40..0020..03F to device 'SPTI:\Device\CdRom0'
Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB' occurred while issuing SCSI command A30..0020..07F to device 'SPTI:\Device\CdRom0'
Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB' occurred while issuing SCSI command A40..0020..07F to device 'SPTI:\Device\CdRom0'
Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB' occurred while issuing SCSI command A30..0020..0BF to device 'SPTI:\Device\CdRom0'
Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB' occurred while issuing SCSI command A40..0020..0BF to device 'SPTI:\Device\CdRom0'
Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB' occurred while issuing SCSI command A30..0020..0FF to device 'SPTI:\Device\CdRom0'
Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB' occurred while issuing SCSI command A40..0020..0FF to device 'SPTI:\Device\CdRom0'
Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB' occurred while issuing SCSI command A40..002000800 to device 'SPTI:\Device\CdRom0'
Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB' occurred while issuing SCSI command A30..0020..03F to device 'SPTI:\Device\CdRom0'
dvdfab seems to be able to read the contents fine, and can output, but i would like to use makemkv.

any advice would be greatly appreciated

Re: Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB'

Posted: Thu Apr 02, 2020 11:43 am
by imfergus
anybody?

i searched all i can, but the fact that Dvd-Fab can read the discs implies its not hardware.

Re: Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB'

Posted: Thu Apr 02, 2020 6:13 pm
by BlueMac77
imfergus wrote:
Thu Apr 02, 2020 11:43 am
anybody?

i searched all i can, but the fact that Dvd-Fab can read the discs implies its not hardware.
Can you indicate what OS are you on and how is your blu-ray connected to your PC. Are you using the latest version of MakeMKV

Re: Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB'

Posted: Fri Apr 03, 2020 9:13 am
by imfergus
BlueMac77 wrote:
Thu Apr 02, 2020 6:13 pm

Can you indicate what OS are you on and how is your blu-ray connected to your PC. Are you using the latest version of MakeMKV
certainly.

windows 10 version 1909 OS Build 18363.720.
drive has been tried via sata directly, and via a sata-usb adapter (modified to fit the non-standard drive).
MakeMKV Beta Version 1.15.0(x64-release)

also

Ubuntu 18.04.4 LTS
using a usb adapter
MakeMKV v1.15.0 Linux(x64-release) (built following the instructions on this forum)


the drive itself appears to work perfectly since DVD-Fab managed to extract all the files from the blu-ray i ripped, but its done it in a very simplistic way, and its honestly a very clunky piece of software.

Re: Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB'

Posted: Mon Apr 06, 2020 5:20 pm
by BlueMac77
@iimfergus. Since your using the latest version of MakeMKV, not sure why you’re getting the Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD” Years ago I once encountered a similar Scsi error message, the solution I did was to get a newer version of MakeMKV and that solved the problem. It’s likely the AACS version on the disc is quite new and the old version of MakeMKV app is not updated in reading newer AACS version.

Re: Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB'

Posted: Sun Apr 12, 2020 1:07 pm
by imfergus
BlueMac77 wrote:
Mon Apr 06, 2020 5:20 pm
@iimfergus. Since your using the latest version of MakeMKV, not sure why you’re getting the Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD” Years ago I once encountered a similar Scsi error message, the solution I did was to get a newer version of MakeMKV and that solved the problem. It’s likely the AACS version on the disc is quite new and the old version of MakeMKV app is not updated in reading newer AACS version.
it happens whatever blu-ray disc i put into the drive.

i have tried:
District 9
Transformers Revenge of the Fallen
Star Trek II Wrath of khan
and the first one i tried: an anime blu-ray set by the name of "Rokka - Braves of the Six Flowers"

all produce the same result.

i tried testing again, and received this:

Code: Select all

Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB' occurred while issuing SCSI command A30..0020..0FF to device 'SG:dev_21:9'
Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB' occurred while issuing SCSI command A40..0020..0FF to device 'SG:dev_21:9'
Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB' occurred while issuing SCSI command A40..002000800 to device 'SG:dev_21:9'
Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB' occurred while issuing SCSI command AD010..080002400 to device 'SG:dev_21:9'
Can't read AACS VID from disc - most likely current AACS host certificate is revoked by your drive
Saved AACS dump file as <user>/.MakeMKV/MKB_v12_Star_Trek_II_The_Wrath_of_Khan_099A.tgz
The volume key is unknown for this disc - video can't be decrypted
Failed to open disc

Re: Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB'

Posted: Sun Apr 12, 2020 1:35 pm
by Grauhaar
i pulled a drive from an old blu-ray player
Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB' occurred while issuing SCSI command
Because you have and SCSI Interface protokoll problem, I think the drive from an old Blu-ray payer does not understand the commands.

Re: Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB'

Posted: Sun Apr 12, 2020 4:02 pm
by BlueMac77
imfergus wrote:
Sun Apr 12, 2020 1:07 pm
it happens whatever blu-ray disc i put into the drive.

i have tried:
District 9
Transformers Revenge of the Fallen
Star Trek II Wrath of khan
and the first one i tried: an anime blu-ray set by the name of "Rokka - Braves of the Six Flowers"

all produce the same result.

i tried testing again, and received this:

Code: Select all

Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB' occurred while issuing SCSI command A30..0020..0FF to device 'SG:dev_21:9'
Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB' occurred while issuing SCSI command A40..0020..0FF to device 'SG:dev_21:9'
Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB' occurred while issuing SCSI command A40..002000800 to device 'SG:dev_21:9'
Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB' occurred while issuing SCSI command AD010..080002400 to device 'SG:dev_21:9'
Can't read AACS VID from disc - most likely current AACS host certificate is revoked by your drive
Saved AACS dump file as <user>/.MakeMKV/MKB_v12_Star_Trek_II_The_Wrath_of_Khan_099A.tgz
The volume key is unknown for this disc - video can't be decrypted
Failed to open disc
Sorry, I could not think of other possible solutions to your problem. On my end I didn't have major issues with MakeMKV on various optical drive brands. I also have an old Pioneer blu-ray BDR-2007 from 2011 and a Sony DVD 2006 that still works fine with MakeMKV

Re: Error 'Scsi error - ILLEGAL REQUEST:INVALID FIELD IN CDB'

Posted: Wed Apr 15, 2020 11:53 am
by imfergus
Grauhaar wrote:
Sun Apr 12, 2020 1:35 pm

Because you have and SCSI Interface protokoll problem, I think the drive from an old Blu-ray payer does not understand the commands.
it has a standard sata interface, is read as a standard sata drive, and was able to read the discs with another application (DVD-Fab).