forced subtitle issue solved

Please post here for issues related to Blu-ray discs
pfm555
Posts: 14
Joined: Mon Sep 10, 2012 1:30 pm

forced subtitle issue solved

Post by pfm555 » Fri Sep 28, 2012 7:53 pm

i love makemkv. So thanks to everyone who has been involved in making this great product. By converting all my Bluray BDMV folders to MKV's, I am now able to play all my movies through Windows Media Player, eliminating the need for external players which have done nothing but cause me hours upon hours of frustration. The one issue that remained using WIndows media player for me was the force subtitles i.e. alien languages in movies such as John Carter, Avatar, and others not appearing. i have searched this site and have not found a simple solution until now. First you need to download Shark 007 codecs. Check Shark007 suggested settings. Then under Config tab go to subtitle control and check FFDshow decoder. Under the Swap tab check Use FFDshow's codec under the top left section titled XVID/DIVX/MP4V in Direct Show. Make sure if you are running 64 bit that you download both from Shark and duplicate the settings in the 64 version. Put the disc in and once makemkv does its thing. Open the main movie like you would if you wanted to add high def soundtrack and you typically will see three subtitle and forced tracks that are all checked. The third one is usually the one you want. Simply uncheck the first two subtitle and forced tracks and then click the makemkv button and voila you will now have the movie with the force subtitles. So far i have done this on John Carter and Avengers and it has worked perfectly. Finally while each movie could be different going forward. If you want to find which subtitle track is the right one, you can by using an external player like TMT. Once the movie is playing right click and bring up the menu go to the subtitle section and click on it and you will see which one of the English tracks is active. This is the one you want. As i said it typically has been the third one, but i am sure that could change. Hope this helps.

Chetwood
Posts: 781
Joined: Mon Aug 30, 2010 9:16 am

Re: forced subtitle issue solved

Post by Chetwood » Sat Sep 29, 2012 6:26 pm

pfm555 wrote:Simply uncheck the first two subtitle and forced tracks and then click the makemkv button and voila you will now have the movie with the force subtitles.
Not necessarily cause not all forced subs are flagged as forced, as explained here. Playback is also much less of a hassle if you simply use VLC.
MultiMakeMKV: MakeMKV batch processing (Win)
MultiShrink: DVD Shrink batch processing
Offizieller Uebersetzer von DVD Shrink deutsch

pfm555
Posts: 14
Joined: Mon Sep 10, 2012 1:30 pm

Re: forced subtitle issue solved

Post by pfm555 » Mon Oct 01, 2012 8:51 pm

I stand corrected in my use of the word "forced". In my explanation on determining the correct subtitle track I should have referred to it as default . The default subtitle track is the track that contains the foreign/alien languages whether they are classified as forced or not. This should hold true for all movies. In regards to VLC, my goal when i started converting all my BDMV folders to MKV was to use the native Windows player so that playing a Bluray movie was as seamless as playing a DVD. I feel I have accomplished that now.
ONE UPDATE
In the Shark Settings one setting that i left off that needs to be changed is under the MKV tab, the LAV splitter needs to be checked.

pfm555
Posts: 14
Joined: Mon Sep 10, 2012 1:30 pm

Re: forced subtitle issue solved

Post by pfm555 » Thu Oct 04, 2012 6:43 pm

Update #2

John Carter bluray track to use is the second one even though the third is the one that appears as the default track. If you select the third one you will get the director's comments in the subtitles. Dont know what the issue is but it is with the bluray only. My buddy has the DVD and he did not have this issue.

bigzaj
Posts: 8
Joined: Wed Feb 11, 2009 3:05 pm

Re: forced subtitle issue solved

Post by bigzaj » Mon Oct 08, 2012 5:13 pm

I still can't get subtitles to work properly with Avatar. I just ripped Captain America with forced only and they work fine, but when I rip Avatar forced only the PGS stream does not show that it is even present using "MediaInfo"

Captain America shows 1 PGS stream when checking BOTH English Forced subtitles, when doing the same with Avatar it shows no subtitles at all.

paulster
Posts: 197
Joined: Sat Aug 20, 2011 6:54 pm

Re: forced subtitle issue solved

Post by paulster » Mon Oct 08, 2012 5:38 pm

It's been a couple of years since I ripped Avatar so I can't remember for certain but the forced subtitles might be in a separate stream which isn't flagged as forced.

Play the movie in a regular Blu-ray player and then use the equivalent of the Display button to see if a set of subtitles has been turned on without you doing anything. If it has then the forced subtitles are in a separate stream, and you therefore have to go and find the other non-forced English stream on the disc when you rip.

pfm555
Posts: 14
Joined: Mon Sep 10, 2012 1:30 pm

Re: forced subtitle issue solved

Post by pfm555 » Mon Oct 08, 2012 6:52 pm

i have never used a stand alone blu ray player so if this is what you have then Paulster's suggestion would work. if you have an external player like Total Media Theater, Powerdvd right click on your mouse to get the drop down menu once you have the movie going and then go to subtitles. This will show you which track is the default track. This is the one you want. Leave both the subtitle and the forced checked. Uncheck the others. Make sure you have the Shark 007 settings correct. you do have to go in the LAV splitter configurator and select default for the subtitles and uncheck the two boxes below. It defaults to automatic. Lastly it is usually been the third subtitle track with the exception of some glitch with the blu ray of John Carter. It shows to be the third but it is the second. Hopefully this helps.

bigzaj
Posts: 8
Joined: Wed Feb 11, 2009 3:05 pm

Re: forced subtitle issue solved

Post by bigzaj » Tue Oct 09, 2012 5:41 pm

Ok, so if I change LAV to 'default' from 'forced only' and uncheck the boxes the subtitle works. Unfortunately this also enables subtitles for a lot of my other MKV's that have them. Is there a way to change the flag to 'forced' so I can leave the 'forced only' option enabled?

pfm555
Posts: 14
Joined: Mon Sep 10, 2012 1:30 pm

Re: forced subtitle issue solved

Post by pfm555 » Tue Oct 09, 2012 9:06 pm

i tried to include everything i have done to get these to work properly, but your comment brought up something i have not included. if you are referring to all the subtitles appearing, then what i did was go into settings in media center and under dvd go to subtitles and select "on when muted". I want to correct one thing i said in an earlier post that the LAV splitter defaults to "automatic" it is actually "advanced". This is drop down that is associated with the Subtitle Selection Mode and yes it needs to be default. The two boxes below that need to be unchecked are under the Blu-ray Subtitles (PGS). Hope this helps.

bigzaj
Posts: 8
Joined: Wed Feb 11, 2009 3:05 pm

Re: forced subtitle issue solved

Post by bigzaj » Tue Oct 09, 2012 9:26 pm

The issue with the Avatar rip is that the subtitles (2nd English stream) were not flagged as forced. So I used MKVMerge Header Editor to set the forced flag on for my Avatar MKV and then set LAV to display only forced subtitles a viola it works.

robpdotcom
Posts: 86
Joined: Thu Nov 11, 2010 5:58 pm

Re: forced subtitle issue solved

Post by robpdotcom » Tue Oct 09, 2012 9:33 pm

You can also run the subs through BDSup2Sub and there is an option to set the entire stream as forced.

Chetwood
Posts: 781
Joined: Mon Aug 30, 2010 9:16 am

Re: forced subtitle issue solved

Post by Chetwood » Wed Oct 10, 2012 6:09 am

Why waste time demuxing/remuxing subs when you can simply do it via header editor?
MultiMakeMKV: MakeMKV batch processing (Win)
MultiShrink: DVD Shrink batch processing
Offizieller Uebersetzer von DVD Shrink deutsch

paulster
Posts: 197
Joined: Sat Aug 20, 2011 6:54 pm

Re: forced subtitle issue solved

Post by paulster » Wed Oct 10, 2012 6:18 am

Thanks for saving me the bother of typing the same, obvious question!

fryk.
Posts: 35
Joined: Tue Oct 09, 2012 7:57 am

Re: forced subtitle issue solved

Post by fryk. » Wed Oct 10, 2012 12:19 pm

Change forced & default track flag in mkv by mkvpropedit from mkvtoolnix. Easy from the command line or Jmkvpropedit gui application (with batch processing).

robpdotcom
Posts: 86
Joined: Thu Nov 11, 2010 5:58 pm

Re: forced subtitle issue solved

Post by robpdotcom » Wed Oct 10, 2012 2:08 pm

Chetwood wrote:Why waste time demuxing/remuxing subs?
Normally, I wouldn't - but if you want the subs to be identified by a filter that can pick out forced subs (such as the MPC-BE subtitle renderer), then you need to use BDSup2Sub on the Avatar subs.

Post Reply