Profiles settings discussion

Discussion of advanced MakeMKV functionality, expert mode, conversion profiles
joe42
Posts: 103
Joined: Mon Jan 03, 2011 7:44 pm

Profiles settings discussion

Post by joe42 » Tue Dec 27, 2011 8:42 pm

Here is my first attempt at making some (small) changes to the profile. My goal was to make the behavior the same as previous makemkv default behavior, with one change: I want HD-audio tracks to be selected (so I removed "-havecore").

Questions:

1) Do I need to change the ":5086"? It seems like it is a name or ID, and maybe I do not want it the same as the default profile?

2) Will it make any difference if I change "ignoreForcedSubtitlesFlag" to "false"? It seemed like Mike was saying that some output settings are not yet implemented.

Code: Select all

<?xml version="1.0" encoding="utf-8"?>
<profile>
    <name lang="eng">myprofile</name>

    <!-- Common MKV flags -->
    <mkvSettings ignoreForcedSubtitlesFlag="true" />

    <!-- Output formats currently supported by MakeMKV -->
    <outputSettings name="discard" outputFormat="discard">
        <description lang="eng">Discard track</description>
    </outputSettings>

    <outputSettings name="copy" outputFormat="directCopy">
        <description lang="eng">Copy track as is</description>
    </outputSettings>

    <outputSettings name="lpcm" outputFormat="LPCM-raw">
        <description lang="eng">Save as raw LPCM</description>
        <channelOrder>L,R</channelOrder>
        <byteOrder>big</byteOrder>
    </outputSettings>

    <outputSettings name="wavex" outputFormat="LPCM-wavex">
        <description lang="eng">Save as LPCM in WAV container</description>
    </outputSettings>

    <!-- Default rule - copy as is -->
    <trackSettings input="default">
        <output outputSettingsName="copy" 
                defaultSelection="-all,+favlang,+nolang,-havemulti,-havelossless,+core">
        </output>
    </trackSettings>

    <!-- Save LPCM mono or stereo as raw LPCM -->
    <trackSettings input="LPCM-stereo">
        <output outputSettingsName="lpcm"
                defaultSelection="-all,+favlang,+nolang,-havemulti,-havelossless,+core">
        </output>
    </trackSettings>

    <!-- Put multi-channel LPCM into WAVEX container-->
    <trackSettings input="LPCM-multi">
        <output outputSettingsName="wavex"
                defaultSelection="-all,+favlang,+nolang,-havemulti,-havelossless,+core">
        </output>
    </trackSettings>

</profile>
Last edited by joe42 on Fri Dec 30, 2011 6:43 am, edited 3 times in total.

MikeMcr
Posts: 13
Joined: Mon Feb 07, 2011 10:13 pm

Re: Profiles settings discussion

Post by MikeMcr » Tue Dec 27, 2011 8:58 pm

Hmm, mine doesn't look like that. How did you create the profile? Did you use the attachment in this thread as the starting point:

http://www.makemkv.com/forum2/viewtopic.php?f=10&t=4386

MikeMcr
Posts: 13
Joined: Mon Feb 07, 2011 10:13 pm

Re: Profiles settings discussion

Post by MikeMcr » Tue Dec 27, 2011 9:02 pm

I'd like to know exactly what the "ignoreForcedSubtitlesFlag" tag means? Does this control whether a forced track is actually flagged as "forced" in the MKV metadata?

joe42
Posts: 103
Joined: Mon Jan 03, 2011 7:44 pm

Re: Profiles settings discussion

Post by joe42 » Tue Dec 27, 2011 10:03 pm

MikeMcr wrote:Hmm, mine doesn't look like that. How did you create the profile?
I copied it from my MakeMKV application directory:

\ Program Files (x86) \ MakeMKV \ default.mmcp.xml

MikeMcr
Posts: 13
Joined: Mon Feb 07, 2011 10:13 pm

Re: Profiles settings discussion

Post by MikeMcr » Tue Dec 27, 2011 10:07 pm

joe42 wrote:
MikeMcr wrote:Hmm, mine doesn't look like that. How did you create the profile?
I copied it from my MakeMKV application directory:

\ Program Files (x86) \ MakeMKV \ default.mmcp.xml
I think you should use the template from the other thread - the name tag looks important to me and is different in the template.

joe42
Posts: 103
Joined: Mon Jan 03, 2011 7:44 pm

Re: Profiles settings discussion

Post by joe42 » Tue Dec 27, 2011 10:10 pm

MikeMcr wrote: I think you should use the template from the other thread - the name tag looks important to me and is different in the template.
I changed the ":5086" to "myprofile" and it eliminated the error message I had been getting on start up, so I think I am okay now. By the way, in case it was not clear, I copied the file from the application directory, but I put the new file in my User .MakeMKV directory.

Crazy Marty
Posts: 11
Joined: Wed Dec 08, 2010 5:42 am

Re: Profiles settings discussion

Post by Crazy Marty » Wed Dec 28, 2011 8:34 pm

Which parts of the profile apply to the "backup" mode of makemkv?

joe42
Posts: 103
Joined: Mon Jan 03, 2011 7:44 pm

Re: Profiles settings discussion

Post by joe42 » Fri Dec 30, 2011 1:18 am

I have started using this:

Code: Select all

-all,+favlang,+nolang,-havemulti,-havelossless,+core
for my track selection criteria. It gives me the lossless audio track(s) in my favorite language (or no language), including the core audio, but none of the lossy audio tracks, unless there is no lossless track in which case it will select the multi-channel track if possible otherwise stereo or mono...and it selects the normal and forced subtitle tracks in my favorite language.

The only flaw is that I think if there are multiple core audio tracks (eg., different languages), it will select the core audio (only) in the other languages. I'm not sure how to avoid that given the current selection tools that are available in MakeMKV. Too bad we cannot use boolean AND / OR logic together with the various selection tokens.

_r0lZ
Posts: 14
Joined: Fri Jan 13, 2012 12:02 pm

Re: Profiles settings discussion

Post by _r0lZ » Fri Jan 13, 2012 12:23 pm

I'm trying to use the "N" selection token, but without success.
N - matches if Nth (or bigger) track of the same type and language
How is the "same type and language" specified? Should I assume that it's the latest language selector that is taken into account?

My goal is to select the preferred language (French in my case) plus the first audio track, regardless of its language code. (I assume that the first language is the original language of the movie, and I want to keep it.)

This line produces an error:

Code: Select all

defaultSelection="-all,+favlang,+1,+nolang,-havemulti,-havecore,+core,+forced"
Error:

Code: Select all

Profile parsing error: Invalid token '+1'
Also, I don't want to include the first subtitle track (unless it is in the default language), but currently, it seems that the same logic is applied to the audio and subtitle tracks. Is it possible to include or exclude a specific audio or subtitle track number? How?

_r0lZ
Posts: 14
Joined: Fri Jan 13, 2012 12:02 pm

Re: Profiles settings discussion

Post by _r0lZ » Fri Jan 13, 2012 12:46 pm

joe42 wrote:1) Do I need to change the ":5086"? It seems like it is a name or ID, and maybe I do not want it the same as the default profile?
I guess ":5086" is an index in the translation file, used to retrieve the word "Default" translated in the GUI language.
You have to change that string to a meaningful name for your setting file. (Do not use a long name, as the Profile button as only room for a few characters).

mike admin
Posts: 3605
Joined: Wed Nov 26, 2008 2:26 am
Contact:

Re: Profiles settings discussion

Post by mike admin » Tue Jan 31, 2012 7:13 am

MikeMcr wrote:I'd like to know exactly what the "ignoreForcedSubtitlesFlag" tag means? Does this control whether a forced track is actually flagged as "forced" in the MKV metadata?
Yes, but it's not yet implemented. Very likely that it will be implemented soon.

joe42
Posts: 103
Joined: Mon Jan 03, 2011 7:44 pm

Re: Profiles settings discussion

Post by joe42 » Tue Jan 31, 2012 9:22 pm

With MakeMKV 1.7.1, I am using this for my default selection criteria:

-sel:all, +sel:(favlang|nolang), -sel:(havemulti|havelossless), +sel:(core*(favlang|nolang)), =100:all, -10:favlang

It gives me the lossless audio track(s) in my favorite language (or no language), including the core audio in my favorite language (or no language), but none of the lossy audio tracks unless there is no lossless track in which case it will select the multi-channel track if possible otherwise stereo or mono...and it selects the normal and forced subtitle tracks in my favorite language.

So far it has selected the tracks exactly as I would have done manually in previous versions. Nice!

By the way, for people who only want forced subtitles in their favorite language (or no language), I guess they would append something like this (I have NOT tested this):

-sel:(!forced)

NodNarb012
Posts: 23
Joined: Wed Feb 01, 2012 1:27 pm

Re: Profiles settings discussion

Post by NodNarb012 » Wed Feb 01, 2012 1:56 pm

joe42 wrote:-sel:all, +sel:(favlang|nolang), -sel:(havemulti|havelossless), +sel:(core*(favlang|nolang)), =100:all, -10:favlang
I'm using the same settings as joe42 and it works great.

One thing I would like to adjust is the way it handles multiple instances of my favlang subtitle tracks; I only want to keep the first set (both regular and forced). From my understanding, I should be able to accomplish this with the N token, so I added -sel:2 as follows:

Code: Select all

-sel:all, +sel:(favlang|nolang), -sel:(havemulti|havelossless), +sel:(core*(favlang|nolang)), -sel:2, =100:all, -10:favlang
I think that -sel:2 should match second (and third, forth, and so on) instance of my favlang subtitle tracks and de-select it, but instead I get the error: Profile parsing error: Invalid token '-sel:2'

Do I have the syntax wrong or is this broken?

MikeMcr
Posts: 13
Joined: Mon Feb 07, 2011 10:13 pm

Re: Profiles settings discussion

Post by MikeMcr » Sun Feb 05, 2012 1:37 pm

joe42 wrote:By the way, for people who only want forced subtitles in their favorite language (or no language), I guess they would append something like this (I have NOT tested this):

-sel:(!forced)
Unfortunately, this unselects all tracks that are not forced including all audio tracks! I think we need to request a new token that means "subtitle track"; something like this:

-sel:(subtitle*(!forced))

MikeMcr
Posts: 13
Joined: Mon Feb 07, 2011 10:13 pm

Re: Profiles settings discussion

Post by MikeMcr » Sun Feb 05, 2012 1:51 pm

I still think it would be useful to have a subtitle token but a workaround seems to be this:

-sel:((!special)*(!mono)*(!stereo)*(!multi)*(!forced))

Post Reply