Current Debian Sid: "configure: error: C compiler cannot create executables"

The place to discuss linux version of MakeMKV
Post Reply
Vicky4
Posts: 9
Joined: Mon Nov 07, 2011 9:52 pm

Current Debian Sid: "configure: error: C compiler cannot create executables"

Post by Vicky4 » Sat Sep 22, 2018 6:49 pm

Hi,
following the usual procedure with an up-to-date Debian Unstable,

Code: Select all

$ sudo apt-get install build-essential pkg-config libc6-dev libssl-dev libexpat1-dev libavcodec-dev libgl1-mesa-dev libqt4-dev zlib1g-dev
$ wget http://www.makemkv.com/download/makemkv-bin-1.12.3.tar.gz
$ wget http://www.makemkv.com/download/makemkv-oss-1.12.3.tar.gz
$ tar xvzf makemkv-oss-1.12.3.tar.gz 
$ tar xvzf makemkv-bin-1.12.3.tar.gz
...compiling just gets me the following error:

Code: Select all

$ ./configure 
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
configure: WARNING: Libtool does not cope well with whitespace in `pwd`
checking how to print strings... printf
checking for gcc... gcc
checking whether the C compiler works... no
configure: error: in `.../makemkv-oss-1.12.3':
configure: error: C compiler cannot create executables
See `config.log' for more details
Some package versions you might find relevant:

Code: Select all

ii  gcc                                  4:8.2.0-1               amd64 
ii  build-essential                      12.5                    amd64 
ii  libavcodec-dev:amd64                 7:4.0.2-1+b1            amd64 
ii  libc6-dev:amd64                      2.27-6                  amd64 
ii  libexpat1-dev:amd64                  2.2.6-1                 amd64 
ii  libgl1-mesa-dev:amd64                18.1.8-1                amd64 
ii  libqt4-dev                           4:4.8.7+dfsg-17         amd64 
ii  libssl-dev:amd64                     1.1.1-1                 amd64 
ii  pkg-config                           0.29-4+b1               amd64 
ii  zlib1g-dev:amd64                     1:1.2.11.dfsg-1         amd64 
I'm hesitant to post the whole config.log (to not bore you), but here's what looks interesting (preceding errors):

Code: Select all

(...)
configure:3233: gcc -V >&5
gcc: error: unrecognized command line option '-V'
gcc: fatal error: no input files
compilation terminated.
configure:3244: $? = 1
configure:3233: gcc -qversion >&5
gcc: error: unrecognized command line option '-qversion'; did you mean '--version'?
gcc: fatal error: no input files
compilation terminated.
configure:3244: $? = 1
configure:3264: checking whether the C compiler works
configure:3286: gcc    conftest.c  >&5
/usr/lib/gcc/x86_64-linux-gnu/8/../../../../x86_64-linux-gnu/bin/ld: /usr/lib/gcc/x86_64-linux-gnu/8/liblto_plugin.so: error loading plugin: /usr/lib/gcc/x86_64-linux-gnu/8/liblto_plugin.so: wrong ELF class: ELFCLASS64
collect2: error: ld returned 1 exit status
configure:3290: $? = 1
configure:3328: result: no
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "ffabi"
| #define PACKAGE_TARNAME "ffabi"
| #define PACKAGE_VERSION "0"
| #define PACKAGE_STRING "ffabi 0"
| #define PACKAGE_BUGREPORT ""
| #define PACKAGE_URL ""
| /* end confdefs.h.  */
Any ideas? This surely has to do with some updated Debian packages; re-compiling my current MakeMKV Version 1.12.0 also gives the same error.

(Edit: Made some corrections due to copy&paste errors)
Last edited by Vicky4 on Mon Sep 24, 2018 6:33 pm, edited 1 time in total.

xr200
Posts: 43
Joined: Tue Nov 10, 2015 3:11 am

Re: Current Debian Sid: "configure: error: C compiler cannot create executables"

Post by xr200 » Sun Sep 23, 2018 11:25 pm

$ wget http://www.makemkv.com/download/makemkv ... 2.1.tar.gz
$ wget http://www.makemkv.com/download/makemkv ... 2.1.tar.gz
$ tar xvzf makemkv-oss-1.12.0.tar.gz
$ tar xvzf makemkv-bin-1.12.0.tar.gz

The current version is 1.12.3. As far as I know, older versions for Linux are not maintained.
In other words, your wget-s for version 1.12.1 should fail. If I run those commands,
they fail for me with a "not found" error.

Secondly, you say you downloaded version 1.12.1, but you unpacked (with tar xvzf)
version 1.12.0.

So I don't know what you are trying to compile.

Vicky4
Posts: 9
Joined: Mon Nov 07, 2011 9:52 pm

Re: Current Debian Sid: "configure: error: C compiler cannot create executables"

Post by Vicky4 » Mon Sep 24, 2018 5:33 am

Sorry, that was to illustrate the process... copy&paste error. Of course, I downloaded and precessed the currect version 1.12.3. That all went well, up to "./configure". And that error isn't specific to 1.12.3, but also to 1.12.0 which compiled ok back then.

Vicky4
Posts: 9
Joined: Mon Nov 07, 2011 9:52 pm

Re: Current Debian Sid: "configure: error: C compiler cannot create executables"

Post by Vicky4 » Thu Jan 17, 2019 9:53 pm

I still fail to compile any MakeMKV version on my Debian Unstable installation, be it the latest 1.14.2 or the old 1.12.0 I'm still forced to use now (which compiled just fine back then).

Would be glad to hear from other Debian users if they have problems, too... or preferably, any hint on what the problem could be...

edent
Posts: 7
Joined: Mon Nov 28, 2011 1:51 pm

Re: Current Debian Sid: "configure: error: C compiler cannot create executables"

Post by edent » Fri Mar 01, 2019 7:29 pm

I also have this problem on Ubuntu.

Used to work just fine, a few versions back. So strange!

edent
Posts: 7
Joined: Mon Nov 28, 2011 1:51 pm

Re: Current Debian Sid: "configure: error: C compiler cannot create executables"

Post by edent » Fri Mar 01, 2019 7:52 pm

SOLVED! Problem appears to be with

Code: Select all

cc1: error: /usr/local/include/x86_64-linux-gnu: Not a directory
cc1: warning: /usr/local/include: not a directory
My `/usr/local/include`appears to be a file created by some other program. I ran:

Code: Select all

sudo mv /usr/local/include /usr/local/include.bak
It then compiled perfectly!

Post Reply