problems after compiling Makemkv on x86 in chroot

The place to discuss linux version of MakeMKV
Post Reply
Posts: 1
Joined: Thu Feb 04, 2016 11:36 am
Location: Italy

problems after compiling Makemkv on x86 in chroot

Post by silvietta » Thu Feb 04, 2016 11:55 am

Hello all,

I'm maintaining a "school distro" (I'm teacher) based on Ubuntu 14.04 that comes in amd64 and x86 flavours (the x86 one, mostly to be ran from usb key, working on every pc); I've migrated Makemkv from 1.9.8 to 1.9.9 but while on amd64 version doesn't give any problem, on x86 gives "failed to initialise application"; the fun side of the whole thing is that if I make my distro iso anyway, then run it in Virtualbox and re-install Makemkv from scratch, then it works (obviously, then, I can't save it, since is a mounted iso). I can't obligate our students to re-install Makemkv compiling it - and I fear that lots of them won't be able to - but I can't even access any log file to check what went wrong. And more, if I run my distro via Xephyr from chroot, even reinstalling it is useless.

In this forum and in FAQ I've read how to enable logging in Makemkv ... but it must be running at least once, so my question is: is there a way to enable logging (or to run from terminal in verbose mode) before launching it? This way maybe I'll be able to understand what goes wrong and correct it.

I've tried also to launch /usr/bin/makemkvcon but, even if it's in 755 and it exists (proof by sight and by a simple script), I always get "no such file or directory" both launching it from / (calling it with /usr/bin/makemkvcon) and directly from /usr/bin/ (via ./makemkvcon and via sh makemkvcon: in this last case I get "makemkvcon: 1: makemkvcon: Syntax error "(" unexpected).

I've resolved in this dirty way, since I've noticed that installing means build just two files, /usr/bin/makemkv and /usr/bin/makemkvcon, but it isn't definitely a practical solution, anyway:

* I've generated the iso from distro in chroot and opened it with VirtualBox;
* tried to launch makemkv with no luck (obviously)
* re-installed makemkv within VirtualBox, did a test and Makemkv worked
* copied /usr/bin/makemkv and /usr/bin/makemkvcon via scp on my real PC and from there on chrooted /usr/bin: here I noticed that while the working makemkv and the "buggy" one were the same size ( 25.280.968 bytes), a diff between them reported different files and that makemkvcon and the "buggy" one were different in size (5.146.556 bytes the working one, 5.350.080 bytes the "buggy" one)
* launched makemkvcon from console and this way it works.
* remastered a new iso and now everything works.

Obviously is just a dirty workaround, but maybe it will help the programmer understanding the problem

Thanks and best regards,


Post Reply